summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-05-13 17:20:27 +0100
committerJustin Lecher <jlec@gentoo.org>2017-05-13 17:20:27 +0100
commit2d4da3be6401b50a657e5a10296cf265fca3198c (patch)
treebb43cbab529b3b7d5dab1cc2af8cca757883eaba /sci-chemistry/openbabel-python
parentsci-chemistry/openbabel-perl: Backport Fix for gcc 6/7 (diff)
downloadgentoo-2d4da3be6401b50a657e5a10296cf265fca3198c.tar.gz
gentoo-2d4da3be6401b50a657e5a10296cf265fca3198c.tar.bz2
gentoo-2d4da3be6401b50a657e5a10296cf265fca3198c.zip
sci-chemistry/openbabel-python: Backport Fix for gcc 6/7
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=594154 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/openbabel-python')
-rw-r--r--sci-chemistry/openbabel-python/files/openbabel-python-2.3.2-gcc-6_and_7-backport.patch13
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild3
2 files changed, 15 insertions, 1 deletions
diff --git a/sci-chemistry/openbabel-python/files/openbabel-python-2.3.2-gcc-6_and_7-backport.patch b/sci-chemistry/openbabel-python/files/openbabel-python-2.3.2-gcc-6_and_7-backport.patch
new file mode 100644
index 000000000000..e23dc6020ee5
--- /dev/null
+++ b/sci-chemistry/openbabel-python/files/openbabel-python-2.3.2-gcc-6_and_7-backport.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0ee545cf..7f4b944e 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -239,7 +239,7 @@ check_type_size(clock_t CLOCK_T)
+ # Get the GCC version - from KDE4 cmake files
+ if(CMAKE_COMPILER_IS_GNUCXX)
+ exec_program(${CMAKE_C_COMPILER} ARGS --version OUTPUT_VARIABLE _gcc_version_info)
+- string(REGEX MATCH "[345]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
++ string(REGEX MATCH "[34567]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
+ # gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
+ # patch level, handle this here:
+ if (NOT _gcc_version)
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
index e7a1cb5908b7..704ad576bc70 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -30,6 +30,7 @@ PATCHES=(
"${FILESDIR}"/${P}-testpybel.patch
"${FILESDIR}"/${P}-bindings_only.patch
"${FILESDIR}"/${P}-swig-3.0.3.patch
+ "${FILESDIR}"/${P}-gcc-6_and_7-backport.patch
)
src_prepare() {