summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-12 21:17:28 +0100
committerSam James <sam@gentoo.org>2024-07-12 21:17:28 +0100
commite7ea26f08a0d2a9b4c4f4c385a8c2488c073387c (patch)
tree689856ff36181560397f7408fe2a5f4e8ffb5c1b /sci-chemistry/autodock_vina
parentkde-frameworks/kfilemetadata: enable py3.13 (diff)
downloadgentoo-e7ea26f08a0d2a9b4c4f4c385a8c2488c073387c.tar.gz
gentoo-e7ea26f08a0d2a9b4c4f4c385a8c2488c073387c.tar.bz2
gentoo-e7ea26f08a0d2a9b4c4f4c385a8c2488c073387c.zip
sci-chemistry/autodock_vina: fix build w/ boost-1.85
Closes: https://bugs.gentoo.org/932237 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-chemistry/autodock_vina')
-rw-r--r--sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild1
-rw-r--r--sci-chemistry/autodock_vina/files/autodock_vina-1.2.5-boost-1.85.patch21
2 files changed, 22 insertions, 0 deletions
diff --git a/sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild b/sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild
index e9edf1f9c991..a74066d3963a 100644
--- a/sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild
+++ b/sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-boost-1.85.patch
)
src_prepare() {
diff --git a/sci-chemistry/autodock_vina/files/autodock_vina-1.2.5-boost-1.85.patch b/sci-chemistry/autodock_vina/files/autodock_vina-1.2.5-boost-1.85.patch
new file mode 100644
index 000000000000..55906b093a49
--- /dev/null
+++ b/sci-chemistry/autodock_vina/files/autodock_vina-1.2.5-boost-1.85.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/932237
+--- a/src/lib/vina.h
++++ b/src/lib/vina.h
+@@ -35,7 +35,6 @@
+ #include <boost/program_options.hpp>
+ #include <boost/filesystem/fstream.hpp>
+ #include <boost/filesystem/exception.hpp>
+-#include <boost/filesystem/convenience.hpp> // filesystem::basename
+ #include <boost/thread/thread.hpp> // hardware_concurrency // FIXME rm ?
+ #include <boost/algorithm/string.hpp>
+ //#include <openbabel/mol.h>
+--- a/src/split/split.cpp
++++ b/src/split/split.cpp
+@@ -30,7 +30,6 @@
+ #include <boost/program_options.hpp>
+ #include <boost/filesystem/fstream.hpp>
+ #include <boost/filesystem/exception.hpp>
+-#include <boost/filesystem/convenience.hpp> // filesystem::basename
+
+ #include "file.h"
+ #include "parse_error.h"