summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/GromacsWrapper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/GromacsWrapper')
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild41
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild41
-rw-r--r--sci-chemistry/GromacsWrapper/Manifest2
-rw-r--r--sci-chemistry/GromacsWrapper/files/0001-Drop-chmod-hack.patch28
-rw-r--r--sci-chemistry/GromacsWrapper/metadata.xml12
5 files changed, 124 insertions, 0 deletions
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild
new file mode 100644
index 000000000000..ef7987d5d03e
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="
+ git://github.com/orbeckst/${PN}.git
+ https://github.com/orbeckst/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/orbeckst/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit eutils distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Python framework for Gromacs"
+HOMEPAGE="http://orbeckst.github.com/GromacsWrapper/"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-python/matplotlib-0.91.3[${PYTHON_USEDEP}]
+ >=dev-python/RecSQL-0.3[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.9[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/0001-Drop-chmod-hack.patch"
+)
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild
new file mode 100644
index 000000000000..6d95361ce0f4
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="
+ git://github.com/orbeckst/${PN}.git
+ https://github.com/orbeckst/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/orbeckst/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit eutils distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Python framework for Gromacs"
+HOMEPAGE="http://orbeckst.github.com/GromacsWrapper/"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-python/matplotlib-0.91.3[${PYTHON_USEDEP}]
+ >=dev-python/RecSQL-0.3[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.9[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/0001-Drop-chmod-hack.patch"
+)
diff --git a/sci-chemistry/GromacsWrapper/Manifest b/sci-chemistry/GromacsWrapper/Manifest
new file mode 100644
index 000000000000..4c77ff3c1ead
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/Manifest
@@ -0,0 +1,2 @@
+DIST GromacsWrapper-0.3.1.tar.gz 1575486 SHA256 ddd2668060668528878370961a9a33257cf3643fd0d9e9191b1d26d4f78e803b SHA512 655dae431bf575963af58a5f75abe6703fe1ecdddba5839b671d9237ddee0e33ab19b528e89bcba4db9063fe30622d44e8f47c7b6452b4d1eed8c7400873a012 WHIRLPOOL 3b848aff931190eabd49426d61186a3c1eef9779a9fabf95b4d21d47793e5543adbcba5ac2b39c8a9af7c2479930a8ea65bb336e2155dfca98378df56ba4cb3e
+DIST GromacsWrapper-0.3.2.tar.gz 1592147 SHA256 2fe0173275ca125a4260aa05f82746338f237766fe8aa998e85a5b40cf83e42c SHA512 a9e0abb5e7ad0c6831e23b6a8c09c6e4cc74b33d66cd17df8e00b876dc275dda11c3d3723565d8d58c45bdf6b2b00323bf85e24e2d5324a8d8b597cc3e5d78a4 WHIRLPOOL 852d73d01e1060369521ec5ff5197c86daa30ae98f285fe5e3d392a315cff10c68e2ba54ec9a2659260cf6830cf17cb1e094eecbd63652e9c3f13fff8707a824
diff --git a/sci-chemistry/GromacsWrapper/files/0001-Drop-chmod-hack.patch b/sci-chemistry/GromacsWrapper/files/0001-Drop-chmod-hack.patch
new file mode 100644
index 000000000000..8645df77b86e
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/files/0001-Drop-chmod-hack.patch
@@ -0,0 +1,28 @@
+From 49b8d9662365e0e9b0725682b8a8479de402b272 Mon Sep 17 00:00:00 2001
+From: Alexey Shvetsov <alexxy@gentoo.org>
+Date: Sat, 23 Mar 2013 16:40:04 +0400
+Subject: [PATCH] Drop chmod hack.
+
+It doesnt work if wrapper installed system-wide
+
+Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
+---
+ gromacs/config.py | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/gromacs/config.py b/gromacs/config.py
+index cece6fc..2e686e7 100644
+--- a/gromacs/config.py
++++ b/gromacs/config.py
+@@ -619,8 +619,6 @@ del g
+ # Must extract because it is part of a zipped python egg;
+ # see http://peak.telecommunity.com/DevCenter/PythonEggs#accessing-package-resources
+ GridMAT_MD = resource_filename(__name__,'external/GridMAT-MD_v1.0.2/GridMAT-MD.pl')
+-os.chmod(GridMAT_MD, 0755)
+-
+
+ #: 3rd party bundled analysis scripts and tools; this is a list of triplets of
+ #:
+--
+1.8.1.5
+
diff --git a/sci-chemistry/GromacsWrapper/metadata.xml b/sci-chemistry/GromacsWrapper/metadata.xml
new file mode 100644
index 000000000000..43390c98619e
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">orbeckst/GromacsWrapper</remote-id>
+ </upstream>
+</pkgmetadata>