summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-10-24 15:15:18 +0200
committerJeroen Roovers <jer@gentoo.org>2017-10-24 15:15:57 +0200
commitcba707ea3f9ccb11c68eb14f1e43b1bc3a3798ea (patch)
treecfe68fee28233de1efce53bdf38f526e0395d771 /sci-calculators
parentdev-python/future: Mark ~hppa too. (diff)
downloadgentoo-cba707ea3f9ccb11c68eb14f1e43b1bc3a3798ea.tar.gz
gentoo-cba707ea3f9ccb11c68eb14f1e43b1bc3a3798ea.tar.bz2
gentoo-cba707ea3f9ccb11c68eb14f1e43b1bc3a3798ea.zip
sci-calculators/units: Version bump.
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/Manifest1
-rw-r--r--sci-calculators/units/units-2.14-r1.ebuild1
-rw-r--r--sci-calculators/units/units-2.15.ebuild56
3 files changed, 58 insertions, 0 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index f8eb7ff13859..92f6ef4bd8cd 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -1 +1,2 @@
DIST units-2.14.tar.gz 1177024 SHA256 9d33893d82f3ddd831d5822992007c40bcd0826ae67d3cbc96539951fb0a82e8 SHA512 3cd09a76fb1cccbafaa3e023c791740738c8347425b2645cad1fa768dee3ebde917602cf65988ee8922fed512ec0bc2367f68545450789fc6bf1a79f066a6986 WHIRLPOOL ae4c0297387e9d3e42ae556a5f528f9c6f1b6a75f5f90580c5b9729ccdea011962d0e891c13ed583a97167bb62d5d074ab3b695ffdd23304f72a62098ce87821
+DIST units-2.15.tar.gz 1178099 SHA256 25d6334fafc801e15b3b0388e207e1efc5d4ae88af6dc7b17d3913de6441f47c SHA512 3fd60acd12142ea3c20bf39184394f300a8284a8946beaf89a8bf2f87c77d8a1ab02189c8a2fd3f93d64517945136fe4ea671edd2d48ea9bae55f9a87b30423f WHIRLPOOL ce17241a949c32a602f1a90683a82af973d51bb2ffdea35d9e7d2f23857271aa05519ee4c22eff9c4df9db590115dfd097b1637c4ce58762eebc8afd5e493c95
diff --git a/sci-calculators/units/units-2.14-r1.ebuild b/sci-calculators/units/units-2.14-r1.ebuild
index 45559228bae3..2269d863f54e 100644
--- a/sci-calculators/units/units-2.14-r1.ebuild
+++ b/sci-calculators/units/units-2.14-r1.ebuild
@@ -45,6 +45,7 @@ src_install() {
python_is_python3 && pyver=3 || pyver=2
sed -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
"units_cur${pyver}" > units_cur || die
+ python_fix_shebang
python_doscript units_cur
fi
}
diff --git a/sci-calculators/units/units-2.15.ebuild b/sci-calculators/units/units-2.15.ebuild
new file mode 100644
index 000000000000..4d87f5164edd
--- /dev/null
+++ b/sci-calculators/units/units-2.15.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit eutils python-single-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units_cur? (
+ ${PYTHON_DEPS}
+ dev-python/future[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ use units_cur && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf ac_cv_path_PYTHON=no
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog NEWS README
+
+ # we're intentionally delaying this since 'make install' would
+ # get confused if we shove 'units_cur' there, and there is no real
+ # need to add more complexity for it
+ if use units_cur; then
+ sed \
+ -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_doscript units_cur
+ fi
+}