summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2024-04-26 16:45:05 +0530
committerMatt Jolly <kangie@gentoo.org>2024-10-14 13:54:04 +1000
commit749751c44811dc075d210f6801374235f6393a5e (patch)
tree51dc25dc57830b848feffbc932f93961606c72d5 /sci-calculators
parentwww-client/microsoft-edge-beta: remove old (diff)
downloadgentoo-749751c44811dc075d210f6801374235f6393a5e.tar.gz
gentoo-749751c44811dc075d210f6801374235f6393a5e.tar.bz2
gentoo-749751c44811dc075d210f6801374235f6393a5e.zip
sci-calculators/transcalc: Fix passing incompatible pointer type
Closes: https://bugs.gentoo.org/927899 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36432 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/transcalc/files/transcalc-0.14-gcc14-build-fix.patch15
-rw-r--r--sci-calculators/transcalc/transcalc-0.14-r3.ebuild33
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-calculators/transcalc/files/transcalc-0.14-gcc14-build-fix.patch b/sci-calculators/transcalc/files/transcalc-0.14-gcc14-build-fix.patch
new file mode 100644
index 000000000000..2da5c78df8ad
--- /dev/null
+++ b/sci-calculators/transcalc/files/transcalc-0.14-gcc14-build-fix.patch
@@ -0,0 +1,15 @@
+Bug: https://bugs.gentoo.org/927899
+--- a/src/print_trans.c
++++ b/src/print_trans.c
+@@ -61,8 +61,9 @@ get_trans_text ()
+ gchar *retval = NULL;
+ trans_label *tlabel;
+ int i;
+- const gchar *newch1=NULL, *newch2 = NULL;
+- const gchar *tmpstr=NULL;
++ gchar *newch1=NULL;
++ const gchar *newch2 = NULL;
++ gchar *tmpstr=NULL;
+ GString *s = g_string_new (NULL);
+
+
diff --git a/sci-calculators/transcalc/transcalc-0.14-r3.ebuild b/sci-calculators/transcalc/transcalc-0.14-r3.ebuild
new file mode 100644
index 000000000000..f0297d08efd1
--- /dev/null
+++ b/sci-calculators/transcalc/transcalc-0.14-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Microwave and RF transmission line calculator"
+HOMEPAGE="http://transcalc.sourceforge.net"
+SRC_URI="http://transcalc.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+
+# patch from debian
+PATCHES=(
+ "${FILESDIR}"/${P}-fd-perm.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-gcc14-build-fix.patch
+)
+
+src_prepare() {
+ default
+
+ # respect flags
+ sed -i -e 's|^CFLAGS=|#CFLAGS=|g' configure || die
+ # syntax errors
+ sed -i \
+ -e 's/ythesize/ynthesize/g' \
+ src/{setup_menu.c,help.h} docs/transcalc.sgml README || die
+}