summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-03 21:50:27 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-03 22:21:21 +0200
commit6cd0461e803e777a0b1d91569a25a91b05edc4b1 (patch)
tree31ad14e396e75e4a5a35f54ac5e707934d61e8c2 /sci-biology
parentsci-biology/consed: Remove old ebuilds (diff)
downloadgentoo-6cd0461e803e777a0b1d91569a25a91b05edc4b1.tar.gz
gentoo-6cd0461e803e777a0b1d91569a25a91b05edc4b1.tar.bz2
gentoo-6cd0461e803e777a0b1d91569a25a91b05edc4b1.zip
sci-biology/samtools: Use 'python-single-r1' instead of 'python-r1'
Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/samtools/samtools-0.1.20-r3.ebuild (renamed from sci-biology/samtools/samtools-0.1.20-r2.ebuild)38
1 files changed, 21 insertions, 17 deletions
diff --git a/sci-biology/samtools/samtools-0.1.20-r2.ebuild b/sci-biology/samtools/samtools-0.1.20-r3.ebuild
index e30ed26ca09f..787add896063 100644
--- a/sci-biology/samtools/samtools-0.1.20-r2.ebuild
+++ b/sci-biology/samtools/samtools-0.1.20-r3.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit eutils python-r1 toolchain-funcs
+inherit python-single-r1 toolchain-funcs
DESCRIPTION="Utilities for analysing and manipulating the SAM/BAM alignment formats"
HOMEPAGE="http://samtools.sourceforge.net/"
@@ -16,10 +16,10 @@ LICENSE="MIT"
SLOT="0.1-legacy"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="examples"
-
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="sys-libs/ncurses:0=
+RDEPEND="${PYTHON_DEPS}
+ sys-libs/ncurses:0=
dev-lang/perl"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -30,7 +30,8 @@ PATCHES=(
src_prepare() {
default
- sed -i 's~/software/bin/python~/usr/bin/env python~' "${S}"/misc/varfilter.py || die
+ # required, otherwise python_fix_shebang errors out
+ sed -i 's~/software/bin/python~/usr/bin/env python~' misc/varfilter.py || die
tc-export CC AR
}
@@ -41,24 +42,24 @@ src_compile() {
}
src_install() {
- dobin samtools $(find bcftools misc -type f -executable)
- mv "${ED}"/usr/{bin,${PN}-${SLOT}} || die
- mkdir "${ED}"/usr/bin || die
- mv "${ED}"/usr/{${PN}-${SLOT},bin/} || die
+ # install executables and hide them away from sight
+ dobin samtools bcftools/{bcftools,vcfutils.pl} misc/{*.py,*.pl,wgsim,ace2sam} \
+ misc/{md5sum-lite,maq2sam-short,bamcheck,maq2sam-long,md5fa,plot-bamcheck}
+ mv "${ED%/}"/usr/{bin,${PN}-${SLOT}} || die
+ mkdir "${ED%/}"/usr/bin || die
+ mv "${ED%/}"/usr/{${PN}-${SLOT},bin/} || die
- mv "${ED}"/usr/bin/${PN}-${SLOT}/varfilter{,-${SLOT}}.py || die
- python_replicate_script "${ED}"/usr/bin/${PN}-${SLOT}/varfilter-${SLOT}.py
+ # ... do the same with the python script, but also fix the shebang
+ mv "${ED%/}"/usr/bin/${PN}-${SLOT}/varfilter{,-${SLOT}}.py || die
+ python_fix_shebang "${ED%/}"/usr/bin/${PN}-${SLOT}/varfilter-${SLOT}.py
# fix perl shebangs
- pushd "${ED}"usr/bin/"${PN}-${SLOT}"/ >> /dev/null
+ pushd "${ED%/}"/usr/bin/${PN}-${SLOT} >/dev/null || die
local i
for i in plot-bamcheck *.pl; do
sed -e '1s:.*:#!/usr/bin/env perl:' -i "${i}" || die
done
-
- # remove lua scripts
- rm -f r2plot.lua vcfutils.lua || die
- popd >> /dev/null
+ popd >/dev/null || die
dolib.so libbam-${SLOT}$(get_libname 1)
dosym libbam-${SLOT}$(get_libname 1) /usr/$(get_libdir)/libbam-${SLOT}$(get_libname)
@@ -68,9 +69,12 @@ src_install() {
mv ${PN}{,-${SLOT}}.1 || die
doman ${PN}-${SLOT}.1
- dodoc AUTHORS NEWS
+ einstalldocs
- use examples && dodoc -r examples
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
}
pkg_postinst() {