summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-10-27 22:40:04 +0100
committerDavid Seifert <soap@gentoo.org>2020-10-27 22:40:04 +0100
commit45c64c3c183dc177c982882b9177abeb0df467dd (patch)
treeac40dece20c7f7a85771bc0d6ec59ca3f1640e6e /sci-biology
parentsci-biology/unafold: Port to EAPI 7 (diff)
downloadgentoo-45c64c3c183dc177c982882b9177abeb0df467dd.tar.gz
gentoo-45c64c3c183dc177c982882b9177abeb0df467dd.tar.bz2
gentoo-45c64c3c183dc177c982882b9177abeb0df467dd.zip
sci-biology/muscle: Port to EAPI 7
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/muscle/files/3.8.31-make.patch6
-rw-r--r--sci-biology/muscle/muscle-3.8.31.ebuild15
2 files changed, 9 insertions, 12 deletions
diff --git a/sci-biology/muscle/files/3.8.31-make.patch b/sci-biology/muscle/files/3.8.31-make.patch
index 7c0e7308df54..fa3f5c3a014b 100644
--- a/sci-biology/muscle/files/3.8.31-make.patch
+++ b/sci-biology/muscle/files/3.8.31-make.patch
@@ -1,7 +1,5 @@
-diff --git a/src/mk b/src/mk
-index 475d25a..d4b7e83 100755
---- a/src/mk
-+++ b/src/mk
+--- a/mk
++++ b/mk
@@ -5,17 +5,14 @@ ObjNames='aligngivenpath.o aligngivenpathsw.o aligntwomsas.o aligntwoprofs.o aln
rm -f *.o muscle.make.stdout.txt muscle.make.stderr.txt
for CPPName in $CPPNames
diff --git a/sci-biology/muscle/muscle-3.8.31.ebuild b/sci-biology/muscle/muscle-3.8.31.ebuild
index 1e62a9d28eee..72c9a2c7e178 100644
--- a/sci-biology/muscle/muscle-3.8.31.ebuild
+++ b/sci-biology/muscle/muscle-3.8.31.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_P="${PN}${PV}_src"
@@ -14,19 +14,18 @@ SRC_URI="http://www.drive5.com/muscle/downloads${PV}/${MY_P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
RDEPEND="!sci-libs/libmuscle"
-DEPEND=""
S="${WORKDIR}"/${PN}${PV}/src
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-make.patch
+PATCHES=( "${FILESDIR}"/${PV}-make.patch )
+
+src_configure() {
tc-export CXX
}
src_install() {
- dobin "${PN}"
+ dobin muscle
dodoc *.txt
}