summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/paml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/paml')
-rw-r--r--sci-biology/paml/Manifest1
-rw-r--r--sci-biology/paml/metadata.xml5
-rw-r--r--sci-biology/paml/paml-4.4c-r1.ebuild48
3 files changed, 54 insertions, 0 deletions
diff --git a/sci-biology/paml/Manifest b/sci-biology/paml/Manifest
new file mode 100644
index 000000000000..f4ddf21f97d9
--- /dev/null
+++ b/sci-biology/paml/Manifest
@@ -0,0 +1 @@
+DIST paml4.4c.tar.gz 2891715 SHA256 08aad25b6b06a359d4f2f12a60ea601c95694864d5f29f7028f67b80890974d6 SHA512 6a5f6d5baa91afa924ea392b76e59db6691fa9d6ee13a248dfe6e46d3fc83178ce41c2991de1c4cdb21952ee53771298aa0c62060f47d0dd84eaa76eb533498a WHIRLPOOL 44ae42dd6088039be1041cdce70ce9ee907b8f85d4e25f9d556df4738ea3ea91f700f96f627f20a13d226038132fd23aecbc5b452bfb6716b9499c8d2be491e4
diff --git a/sci-biology/paml/metadata.xml b/sci-biology/paml/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/paml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/paml/paml-4.4c-r1.ebuild b/sci-biology/paml/paml-4.4c-r1.ebuild
new file mode 100644
index 000000000000..7868859871b9
--- /dev/null
+++ b/sci-biology/paml/paml-4.4c-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs versionator
+
+MY_P=$(version_format_string '${PN}$1$2')
+
+DESCRIPTION="Phylogenetic Analysis by Maximum Likelihood"
+HOMEPAGE="http://abacus.gene.ucl.ac.uk/software/paml.html"
+SRC_URI="http://abacus.gene.ucl.ac.uk/software/${PN}${PV}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Notice send by mail to prof. Ziheng Yang
+ sed -i "s/\$(CC)/& \$(LDFLAGS)/" src/Makefile || die #335608
+}
+
+src_compile() {
+ emake -C src \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wno-unused-result" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dodoc README.txt doc/*
+
+ insinto /usr/share/${PN}/control
+ doins *.ctl
+
+ insinto /usr/share/${PN}/dat
+ doins stewart* *.dat dat/*
+
+ insinto /usr/share/${PN}
+ doins -r examples/
+
+ cd src || die
+ dobin baseml codeml basemlg mcmctree pamp evolver yn00 chi2
+}