summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-08-26 19:21:50 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-08-26 19:21:50 +0200
commit0db67f06dd6358a4c5294cc79450616900e9160a (patch)
treea285bedb9d72c8579d84558eb9c4378455c9d23c /sci-biology/emboss
parentx11-misc/ksuperkey: new package. (diff)
downloadgentoo-0db67f06dd6358a4c5294cc79450616900e9160a.tar.gz
gentoo-0db67f06dd6358a4c5294cc79450616900e9160a.tar.bz2
gentoo-0db67f06dd6358a4c5294cc79450616900e9160a.zip
sci-biology/emboss: Restore old version.
This commit reverts 0d040c84fbb38ead35451769d2b65a33af2fbf2a. Package-Manager: portage-2.2.20.1 RepoMan-Options: --force
Diffstat (limited to 'sci-biology/emboss')
-rw-r--r--sci-biology/emboss/Manifest1
-rw-r--r--sci-biology/emboss/emboss-6.0.1.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/sci-biology/emboss/Manifest b/sci-biology/emboss/Manifest
index 6eae2dd35ffe..c364f2c77e86 100644
--- a/sci-biology/emboss/Manifest
+++ b/sci-biology/emboss/Manifest
@@ -1,3 +1,4 @@
+DIST EMBOSS-6.0.1.tar.gz 20204153 SHA256 3e352902aa9dab88bf486457ff23794f19398dfc6b550c4bf175dfcad34c233d
DIST EMBOSS-6.3.1.tar.gz 23572243 SHA256 4f3290600a970c2a23a7e47f884d1fc8156ec40538f7191a6e83e23680d27a8d
DIST EMBOSS-6.6.0.tar.gz 117962028 SHA256 7184a763d39ad96bb598bfd531628a34aa53e474db9e7cac4416c2a40ab10c6e SHA512 2d28a03381f7dc98d205aa50202fbbac02ad218fc775d86579d310296be124403623484b1907154d915f15cd32a9f8cf16ecfaa6c4a28b362e24dc8e6380b75a WHIRLPOOL 25241e865b1ad4e5459f84a2b0def7cd00a6e2904db714838dfe0533e01f8373cfdd4c78df225f9d2a77ead4cb9998791bd19f46b32e220810ad950fa288b9fe
DIST emboss-6.3.1_p4.patch.gz 4070 SHA256 61d1b62e3148541d496103711db6526ba76488a0899af2c98264b03bf8d6e24c
diff --git a/sci-biology/emboss/emboss-6.0.1.ebuild b/sci-biology/emboss/emboss-6.0.1.ebuild
new file mode 100644
index 000000000000..0edfd7a639d0
--- /dev/null
+++ b/sci-biology/emboss/emboss-6.0.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+
+inherit eutils
+
+DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
+HOMEPAGE="http://emboss.sourceforge.net/"
+SRC_URI="ftp://${PN}.open-bio.org/pub/EMBOSS/old/${PV}/EMBOSS-${PV}.tar.gz"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="X png minimal"
+
+DEPEND="
+ X? ( x11-libs/libXt )
+ png? (
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/gd
+ )
+ !minimal? (
+ sci-biology/primer3
+ sci-biology/clustalw
+ )"
+
+RDEPEND="${DEPEND}
+ !sys-devel/cons"
+
+PDEPEND="
+ !minimal? (
+ sci-biology/aaindex
+ sci-biology/cutg
+ sci-biology/prints
+ sci-biology/prosite
+ sci-biology/rebase
+ sci-biology/transfac
+ )"
+
+S="${WORKDIR}/EMBOSS-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-5.0.0-as-needed.patch
+
+ local link_string="$(pkg-config --libs x11)"
+ if use png; then
+ link_string="${link_string} -lgd $(pkg-config --libs libpng)"
+ fi
+ sed -e "s:PATCH_PLPLOT:${link_string}:" -i plplot/Makefile.in \
+ || die "Failed to patch ajax Makefile"
+}
+
+src_compile() {
+ local myconf
+ myconf="--includedir=${D}/usr/include/emboss"
+ use X || myconf="${EXTRA_CONF} --without-x"
+ use png || myconf="${EXTRA_CONF} --without-pngdriver"
+
+ econf ${myconf}
+ # Do not install the JEMBOSS component (the --without-java configure option
+ # does not work). JEMBOSS will eventually be available as a separate package.
+ sed -i -e "s/SUBDIRS = plplot ajax nucleus emboss test doc jemboss/SUBDIRS = plplot ajax nucleus emboss test doc/" \
+ Makefile || die
+ emake || die
+}
+
+src_install() {
+ einstall || die "Failed to install program files."
+
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS \
+ || die "Failed to install documentation."
+ newdoc "${FILESDIR}"/${PN}-README.Gentoo-1 README.Gentoo \
+ || die "Failed to install Gentoo readme file."
+
+ # Install env file for setting libplplot and acd files path.
+ cat <<- EOF > 22emboss
+ # plplot libs dir
+ PLPLOT_LIB="/usr/share/EMBOSS/"
+ # ACD files location
+ EMBOSS_ACDROOT="/usr/share/EMBOSS/acd"
+ EOF
+ doenvd 22emboss || die "Failed to install environment file."
+
+ # Symlink preinstalled docs to "/usr/share/doc".
+ dosym /usr/share/EMBOSS/doc/manuals /usr/share/doc/${PF}/manuals || die
+ dosym /usr/share/EMBOSS/doc/programs /usr/share/doc/${PF}/programs || die
+ dosym /usr/share/EMBOSS/doc/tutorials /usr/share/doc/${PF}/tutorials || die
+ dosym /usr/share/EMBOSS/doc/html /usr/share/doc/${PF}/html || die
+
+ # Clashes #330507
+ mv "${D}"/usr/bin/{digest,pepdigest} || die
+
+ # Remove useless dummy files from the image.
+ find emboss/data -name dummyfile -delete || die "Failed to remove dummy files."
+
+ # Move the provided codon files to a different directory. This will avoid
+ # user confusion and file collisions on case-insensitive file systems (see
+ # bug #115446). This change is documented in "README.Gentoo".
+ mv "${D}"/usr/share/EMBOSS/data/CODONS{,.orig} || \
+ die "Failed to move CODON directory."
+
+ # Move the provided restriction enzyme prototypes file to a different name.
+ # This avoids file collisions with versions of rebase that install their
+ # own enzyme prototypes file (see bug #118832).
+ mv "${D}"/usr/share/EMBOSS/data/embossre.equ{,.orig} || \
+ die "Failed to move enzyme equivalence file."
+}