summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/consed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/consed')
-rw-r--r--sci-biology/consed/Manifest4
-rw-r--r--sci-biology/consed/consed-19-r2.ebuild71
-rw-r--r--sci-biology/consed/consed-27.ebuild90
-rw-r--r--sci-biology/consed/metadata.xml5
4 files changed, 170 insertions, 0 deletions
diff --git a/sci-biology/consed/Manifest b/sci-biology/consed/Manifest
new file mode 100644
index 000000000000..e9cd6b128266
--- /dev/null
+++ b/sci-biology/consed/Manifest
@@ -0,0 +1,4 @@
+DIST consed-19-linux.tar.gz 29835559 SHA256 27501d714e4cd7ea04def6a7f985b674bc454ed8bd7d1e86b41b0283e2b9e089
+DIST consed-19-sources.tar.gz 6867357 SHA256 1db37b17608e49470926dae261c76d400cf3f9eb5feea52cd732e0bfa4cadee3
+DIST consed-27-linux.tar.gz 1604 SHA256 d7baafcbcdbf1b25262578511da8a51758f48d97d9109b334978acd150461855 SHA512 dbafb8c8f40dbed82a0000314549452c372e447467ccd8ec1004f44946dd09fcffa065c36bcca4f3c0fd55a137e570c135f4f79820e3e6d98626f92413b2731b WHIRLPOOL ae319734572558dd0047dad085c9f907386be6f7f0041bac0df9e1ce5b7558c750d92ea747cc3e74c594c83bed4cd73f4b37b4d6b9e39fd7caa2a733d67d6e21
+DIST consed-27-sources.tar.gz 1604 SHA256 d7baafcbcdbf1b25262578511da8a51758f48d97d9109b334978acd150461855 SHA512 dbafb8c8f40dbed82a0000314549452c372e447467ccd8ec1004f44946dd09fcffa065c36bcca4f3c0fd55a137e570c135f4f79820e3e6d98626f92413b2731b WHIRLPOOL ae319734572558dd0047dad085c9f907386be6f7f0041bac0df9e1ce5b7558c750d92ea747cc3e74c594c83bed4cd73f4b37b4d6b9e39fd7caa2a733d67d6e21
diff --git a/sci-biology/consed/consed-19-r2.ebuild b/sci-biology/consed/consed-19-r2.ebuild
new file mode 100644
index 000000000000..3ce704e8792f
--- /dev/null
+++ b/sci-biology/consed/consed-19-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs
+
+DESCRIPTION="A genome sequence finishing program"
+HOMEPAGE="http://bozeman.mbt.washington.edu/consed/consed.html"
+SRC_URI="${P}-sources.tar.gz
+ ${P}-linux.tar.gz"
+
+LICENSE="phrap"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/motif-2.3:0"
+RDEPEND="${DEPEND}
+ >=sci-biology/phred-000925
+ >=sci-biology/phrap-1.080721"
+
+S="${WORKDIR}"
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE} and obtain the file"
+ einfo "\"sources.tar.gz\", then rename it to \"${P}-sources.tar.gz\""
+ einfo "and place it in ${DISTDIR},"
+ einfo "obtain the file"
+ einfo "\"consed_linux.tar.gz\", then rename it to \"${P}-linux.tar.gz\""
+ einfo "and place it in ${DISTDIR}"
+}
+
+src_prepare() {
+ sed -i '/#include/ s/<new.h>/<new>/' "${S}/main.cpp" || die
+ sed -i \
+ -e '/CLIBS=/ s/$/ -lXm -lXt -lSM -lICE -lXext -lXmu -lXp -lm/' \
+ -e 's/ARCHIVES=/ARCHIVES=\n_ARCHIVES=/' \
+ -e 's/CFLGS=/CFLGS= ${CFLAGS} /' "${S}/makefile" || die
+ sed -i -e 's/CFLAGS=/CFLAGS += /' "${S}"/misc/*/Makefile || die
+ sed -i 's!\($szPhredParameterFile =\).*!\1 $ENV{PHRED_PARAMETER_FILE} || "'${EPREFIX}'/usr/share/phred/phredpar.dat";!' "${S}/scripts/"* || die
+}
+
+src_compile() {
+ emake || die
+ emake -C misc/mktrace || die
+ emake -C misc/phd2fasta || die
+ (cd misc/454; $(tc-getCC) ${CFLAGS} sff2scf.c -o sff2scf) || die
+}
+
+src_install() {
+ dobin consed misc/{mktrace/mktrace,phd2fasta/phd2fasta,454/sff2scf} || die
+ dobin scripts/* contributions/* || die
+ insinto /usr/lib/screenLibs
+ doins misc/*.{fa*,seq} || die
+ insinto /usr/share/${PN}/examples
+ doins -r standard polyphred autofinish assembly_view 454_newbler \
+ align454reads align454reads_answer solexa_example \
+ solexa_example_answer selectRegions selectRegionsAnswer || die
+ echo 'CONSED_HOME='${EPREFIX}'/usr' > "${S}/99consed"
+ doenvd "${S}/99consed" || die
+ dodoc README.txt *_announcement.txt || die
+}
+
+pkg_postinst() {
+ einfo "Package documentation is available at"
+ einfo "http://www.phrap.org/consed/distributions/README.${PV}.0.txt"
+}
diff --git a/sci-biology/consed/consed-27.ebuild b/sci-biology/consed/consed-27.ebuild
new file mode 100644
index 000000000000..0bf33a7278cf
--- /dev/null
+++ b/sci-biology/consed/consed-27.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A genome sequence finishing program"
+HOMEPAGE="http://bozeman.mbt.washington.edu/consed/consed.html"
+SRC_URI="
+ ${P}-sources.tar.gz
+ ${P}-linux.tar.gz"
+
+LICENSE="phrap"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/motif-2.3:0"
+RDEPEND="${DEPEND}
+ sci-biology/samtools
+ >=sci-biology/phred-000925
+ >=sci-biology/phrap-1.080721
+ dev-lang/perl"
+
+S="${WORKDIR}"
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE} and obtain the file"
+ einfo "\"sources.tar.gz\", then rename it to \"${P}-sources.tar.gz\""
+ einfo "and place it in ${DISTDIR},"
+ einfo "obtain the file"
+ einfo "\"consed_linux.tar.gz\", then rename it to \"${P}-linux.tar.gz\""
+ einfo "and place it in ${DISTDIR}"
+}
+
+src_prepare() {
+ sed -i '/#include/ s/<new.h>/<new>/' "${S}/main.cpp" || die
+ sed -i \
+ -e '/CLIBS=/ s/$/ -lXm -lXt -lSM -lICE -lXext -lXmu -lXp -lm -lbam -lz/' \
+ -e 's/ARCHIVES=/ARCHIVES=\n_ARCHIVES=/' \
+ -e 's/CFLGS=/CFLGS= ${CFLAGS} /' \
+ -e 's#/me1/gordon/samtools/samtools-0.1.18#/usr/include/bam/#' "${S}/makefile" || die
+ sed -i -e 's/CFLAGS=/CFLAGS += /' "${S}"/misc/*/Makefile || die
+ sed \
+ -e 's!\($szPhredParameterFile =\).*!\1 $ENV{PHRED_PARAMETER_FILE} || "'${EPREFIX}'/usr/share/phred/phredpar.dat";!' \
+ -i "${S}"/scripts/* || die
+}
+
+src_compile() {
+ emake
+ emake -C misc/mktrace
+ emake -C misc/phd2fasta
+ (cd misc/454; $(tc-getCC) ${CFLAGS} ${LDFLAGS} sff2scf.c -o sff2scf) || die
+}
+
+src_install() {
+ dobin consed misc/{mktrace/mktrace,phd2fasta/phd2fasta,454/sff2scf}
+ dobin scripts/* contributions/*
+ insinto /usr/lib/screenLibs
+ doins misc/*.{fa*,seq}
+ insinto /usr/share/${PN}/examples
+ doins -r \
+ standard polyphred autofinish assembly_view 454_newbler \
+ align454reads align454reads_answer solexa_example \
+ solexa_example_answer selectRegions selectRegionsAnswer
+ echo 'CONSED_HOME="${EPREFIX}/usr"' > "${S}"/99consed || die
+ echo 'CONSED_PARAMETERS="${EPREFIX}/etc/consedrc"' >> "${S}"/99consed || die
+ mkdir -p "${ED}"/etc/consedrc || die
+ touch "${ED}"/etc/consedrc || die
+ doenvd "${S}/99consed" || die
+ sed \
+ -e "s#/usr/local/genome#${EPREFIX}/usr#" \
+ -i "${ED}"/usr/bin/{*.perl,phredPhrap,phredPhrapWithPhdBalls} || die
+ sed \
+ -e 's#niceExe = "/bin/nice"#niceExe = "/usr/bin/nice"#' \
+ -i "${ED}"/usr/bin/phredPhrap || die
+ sed \
+ -e 's#/wt1/gordon/genome#/usr/bin#' \
+ -i "${ED}"/usr/bin/fastq2Phrap.perl || die
+ dodoc README.txt *_announcement.txt || die
+}
+
+pkg_postinst() {
+ einfo "Package documentation is available at"
+ einfo "http://www.phrap.org/consed/distributions/README.${PV}.0.txt"
+}
diff --git a/sci-biology/consed/metadata.xml b/sci-biology/consed/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/consed/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>