summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <droman@ifae.es>2022-09-12 16:21:27 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-14 10:44:45 +0200
commit1e3cef2a3da16d9bf9d739ec4d98820d14b4fe0d (patch)
tree50a04f0c29b0e1ffd784da00b6c9d5669053eec6 /sci-astronomy/wcslib
parentsci-astronomy/wcslib: drop 7.9 (diff)
downloadgentoo-1e3cef2a3da16d9bf9d739ec4d98820d14b4fe0d.tar.gz
gentoo-1e3cef2a3da16d9bf9d739ec4d98820d14b4fe0d.tar.bz2
gentoo-1e3cef2a3da16d9bf9d739ec4d98820d14b4fe0d.zip
sci-astronomy/wcslib: add 7.12
Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27223 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-astronomy/wcslib')
-rw-r--r--sci-astronomy/wcslib/Manifest1
-rw-r--r--sci-astronomy/wcslib/wcslib-7.12.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sci-astronomy/wcslib/Manifest b/sci-astronomy/wcslib/Manifest
index f99ebebcd724..b4f348e45772 100644
--- a/sci-astronomy/wcslib/Manifest
+++ b/sci-astronomy/wcslib/Manifest
@@ -1,3 +1,4 @@
DIST wcslib-7.11.tar.bz2 2946962 BLAKE2B 7c812f50e3c539da3d58a70acd9128bd957fccd463b0c404c4a55740fb6d7df88f9992d1a2c5c303091dfce91943a6e5bcca73b553354f67c2d522ebb77d6dc3 SHA512 28aa67edad31a8fe27bc8b04e060a17ee75d8fa5e9ec82ccbdb72136558e03d1196151214c9ce4026df88cb807ce2645f5df80bbc479ec91cfa749bf8b9477ec
+DIST wcslib-7.12.tar.bz2 2989693 BLAKE2B 8070cdddb9e89478464443411d165706d44593e33290149da11d2c2857bad202f5dd6ad98b5840167f618eceb9ec47e35f3ee332a8c6e1719fc2b20fe2f31ef2 SHA512 7f38f725992d3c4bd3c1b908d494ac361c17f6b60f091d987fda596211423bb7396b3a5e2f1f6dd6215835016d302083472a7ad0822f17cdfe230c8f556b3e23
DIST wcslib-7.3.1.tar.bz2 2434274 BLAKE2B 9789a8eb34fe37c96b52e20efe3c14368499058e5c46aad4853b2be5f32a31df26525ec2c38d0ce87bcb7891b91a3ec3ac537e3c662c716a7c4381f26cd715e4 SHA512 753e0e202fb4250d321c36a0df9cd45ed88697111a06e108bc3e5397ddecc60d460cda2b4d45b5311dd72b88b66d4c70ff150b03e2da46c834b024f15304779b
DIST wcslib-7.3.tar.bz2 2435669 BLAKE2B c0f641b4c2fdd9d332816195f399eb2ab3c5aa585f08c4857af77bd5ed4074e653663f7cbddc6d7678cd85bed2c0bd95719cd83a5138d21ad24841396d4c11b9 SHA512 8c98c4b575056e2d966b77a4bc951256d02ecee3a11847e140fd38d93afd0f76b3e906d590c952dc9fc58ceeb1ba062b19d8e1e676ee0032f5b7ed13a9dfa892
diff --git a/sci-astronomy/wcslib/wcslib-7.12.ebuild b/sci-astronomy/wcslib/wcslib-7.12.ebuild
new file mode 100644
index 000000000000..758e7d330da6
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-7.12.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+
+inherit flag-o-matic fortran-2
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/7"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs +tools"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/flex-2.6.0
+ virtual/pkgconfig"
+
+src_configure() {
+ # workaround until upstream fix it properly
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable fortran)
+ $(use_enable tools utils)
+ )
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf "${myconf[@]}"
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_install () {
+ default
+ # static libs share the same symbols as shared (i.e. compiled with PIC)
+ # so they are not compiled twice
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/lib*.a || die
+ fi
+
+ if ! use doc; then
+ rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf || die
+ fi
+}