summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-12 20:32:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-12 21:08:38 +0200
commit0d341a7dc72b809b0ea2e2c0a889b887bd9b899d (patch)
tree4449b35ce0f887648de41bf582220bdbbe1b37b0 /ros-meta
parentdev-ros/voxel_grid: Bump to 1.17.1. (diff)
downloadgentoo-0d341a7dc72b809b0ea2e2c0a889b887bd9b899d.tar.gz
gentoo-0d341a7dc72b809b0ea2e2c0a889b887bd9b899d.tar.bz2
gentoo-0d341a7dc72b809b0ea2e2c0a889b887bd9b899d.zip
ros-meta/navigation: Bump to 1.17.1.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'ros-meta')
-rw-r--r--ros-meta/navigation/Manifest1
-rw-r--r--ros-meta/navigation/navigation-1.17.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/ros-meta/navigation/Manifest b/ros-meta/navigation/Manifest
index a4fee98c8c5a..494e2eda7805 100644
--- a/ros-meta/navigation/Manifest
+++ b/ros-meta/navigation/Manifest
@@ -1 +1,2 @@
DIST navigation-1.17.0.tar.gz 347660 BLAKE2B 8345dccf8ac5e24d1017631bb621ebaa472cc492d6361f29938501a149555771e03a6a46e16fdcc508bbe5c206ead80e9b79e9168b873685fca50a78ea7a7e13 SHA512 a536c8826bd88151ff8f51f83661282f8ccf1b19872bd91ed32987ef372797b94489380262e79ee2560ecb4d9e290c5b4f8d52c17721e2a41126eaea909bce26
+DIST navigation-1.17.1.tar.gz 349192 BLAKE2B 4cb946a296ab53d7196a70c66cc1dda0cf62f5f279fe020ca7c39781ecb5402af6addcd6164ab6e0a9bcfe3ba26e42f647546280f03b572202f0f4df8d6ed3cf SHA512 23178adaef9b720c644f621c67ed579be312101e70a7d12b527164c5cc55286982c99149a521a76c6dda05248e859435e51f9a0f09e582b89aed3b7c2173cfaa
diff --git a/ros-meta/navigation/navigation-1.17.1.ebuild b/ros-meta/navigation/navigation-1.17.1.ebuild
new file mode 100644
index 000000000000..56e500c6e9fc
--- /dev/null
+++ b/ros-meta/navigation/navigation-1.17.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="2D navigation stack"
+LICENSE="BSD LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/amcl
+ dev-ros/base_local_planner
+ dev-ros/carrot_planner
+ dev-ros/clear_costmap_recovery
+ dev-ros/costmap_2d
+ dev-ros/dwa_local_planner
+ dev-ros/fake_localization
+ dev-ros/global_planner
+ dev-ros/map_server
+ dev-ros/move_base
+ dev-ros/move_slow_and_clear
+ dev-ros/nav_core
+ dev-ros/navfn
+ dev-ros/rotate_recovery
+ dev-ros/voxel_grid
+"
+DEPEND="${RDEPEND}"