summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:42:56 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:43:09 +0200
commit39242f787cace0156ea912c144af8cb3f8c88d61 (patch)
tree36f3434080b286646acec28435783e15b05d803f /ros-meta/vision_visp/vision_visp-9999.ebuild
parentdev-ros/visp_hand2eye_calibration: Initial import. Ebuild by me. (diff)
downloadgentoo-39242f787cace0156ea912c144af8cb3f8c88d61.tar.gz
gentoo-39242f787cace0156ea912c144af8cb3f8c88d61.tar.bz2
gentoo-39242f787cace0156ea912c144af8cb3f8c88d61.zip
ros-meta/vision_visp: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/vision_visp/vision_visp-9999.ebuild')
-rw-r--r--ros-meta/vision_visp/vision_visp-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/ros-meta/vision_visp/vision_visp-9999.ebuild b/ros-meta/vision_visp/vision_visp-9999.ebuild
new file mode 100644
index 000000000000..ed46d3fd3696
--- /dev/null
+++ b/ros-meta/vision_visp/vision_visp-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="jade-"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Virtual package providing ViSP related packages"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visp_auto_tracker
+ dev-ros/visp_bridge
+ dev-ros/visp_camera_calibration
+ dev-ros/visp_hand2eye_calibration
+ dev-ros/visp_tracker
+"
+DEPEND=""
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+fi