summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /perl-core/libnet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'perl-core/libnet')
-rw-r--r--perl-core/libnet/Manifest1
-rw-r--r--perl-core/libnet/files/1.22-hostname.patch25
-rw-r--r--perl-core/libnet/files/libnet.cfg14
-rw-r--r--perl-core/libnet/libnet-1.270.0.ebuild24
-rw-r--r--perl-core/libnet/metadata.xml23
5 files changed, 87 insertions, 0 deletions
diff --git a/perl-core/libnet/Manifest b/perl-core/libnet/Manifest
new file mode 100644
index 000000000000..6bf3d8213b3c
--- /dev/null
+++ b/perl-core/libnet/Manifest
@@ -0,0 +1 @@
+DIST libnet-1.27.tar.gz 68615 SHA256 a6c8660844df64cd8389d2afddd596c9a5afb0cda8434b0b9313a53496cee803 SHA512 a81a4640f55212402dd741316991413a16f4e05781320abbd18eb9f450282275489a45167faecf587af66cabcb8f7f23653834081bf9fe0b490d419392b85b1b WHIRLPOOL 44fd5332bcc2f1fe8ef19453ffad927f1ef62e637807ddbcef831165be4f0e7991f6aa020e3911b1c2bb684e9001292bb9adcc00cbab43ff8ba3839e6cf50618
diff --git a/perl-core/libnet/files/1.22-hostname.patch b/perl-core/libnet/files/1.22-hostname.patch
new file mode 100644
index 000000000000..60440e287977
--- /dev/null
+++ b/perl-core/libnet/files/1.22-hostname.patch
@@ -0,0 +1,25 @@
+commit adeb94125ab7de8d20c129a905a5159972ad9fd1
+Author: Ricardo SIGNES <rjbs@cpan.org>
+Date: Mon Oct 22 05:01:09 2007 -0400
+
+ hostname.t busted
+ Message-ID: <20071022130109.GA16748@knight>
+
+ p4raw-id: //depot/perl@32180
+
+diff --git a/lib/Net/t/hostname.t b/lib/Net/t/hostname.t
+index 758d304..4013d74 100644
+--- a/lib/Net/t/hostname.t
++++ b/lib/Net/t/hostname.t
+@@ -26,7 +26,10 @@ print "1..5\n";
+ $domain = domainname();
+
+ if(defined $domain && $domain ne "") {
+- print "ok 1\n";
++ print "ok 1 - defined, non-empty domainname\n";
++}
++elsif (not defined $domain) {
++ print "ok 1 # SKIP domain not fully defined\n";
+ }
+ else {
+ print "not ok 1\n";
diff --git a/perl-core/libnet/files/libnet.cfg b/perl-core/libnet/files/libnet.cfg
new file mode 100644
index 000000000000..87de762fb028
--- /dev/null
+++ b/perl-core/libnet/files/libnet.cfg
@@ -0,0 +1,14 @@
+{
+ 'ftp_int_passive' => 0,
+ 'snpp_hosts' => [],
+ 'inet_domain' => undef,
+ 'test_exist' => 1,
+ 'ftp_testhost' => undef,
+ 'daytime_hosts' => [],
+ 'ph_hosts' => [],
+ 'time_hosts' => [],
+ 'smtp_hosts' => [],
+ 'test_hosts' => 1,
+ 'nntp_hosts' => [],
+ 'pop3_hosts' => [],
+}
diff --git a/perl-core/libnet/libnet-1.270.0.ebuild b/perl-core/libnet/libnet-1.270.0.ebuild
new file mode 100644
index 000000000000..b2452f65ec55
--- /dev/null
+++ b/perl-core/libnet/libnet-1.270.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SHAY
+MODULE_VERSION=1.27
+inherit eutils perl-module
+
+DESCRIPTION="A URI Perl Module"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="sasl"
+
+RDEPEND="sasl? ( dev-perl/Authen-SASL )"
+DEPEND=""
+
+SRC_TEST="do"
+
+src_prepare() {
+ cp "${FILESDIR}"/libnet.cfg "${S}"
+}
diff --git a/perl-core/libnet/metadata.xml b/perl-core/libnet/metadata.xml
new file mode 100644
index 000000000000..84daf2b67a7e
--- /dev/null
+++ b/perl-core/libnet/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <longdescription>dev-perl/libnet provides the suite of basic Net:: modules (Net::Cmd, Net::Config, Net::Domain, Net::FTP, Net::NNTP, Net::Netrc, Net::POP3, Net::SMTP, and Net::Time as the key ones)</longdescription>
+ <upstream>
+ <remote-id type="cpan">libnet</remote-id>
+ <remote-id type="cpan-module">Net::Cmd</remote-id>
+ <remote-id type="cpan-module">Net::Config</remote-id>
+ <remote-id type="cpan-module">Net::Domain</remote-id>
+ <remote-id type="cpan-module">Net::FTP</remote-id>
+ <remote-id type="cpan-module">Net::FTP::A</remote-id>
+ <remote-id type="cpan-module">Net::FTP::E</remote-id>
+ <remote-id type="cpan-module">Net::FTP::I</remote-id>
+ <remote-id type="cpan-module">Net::FTP::L</remote-id>
+ <remote-id type="cpan-module">Net::FTP::dataconn</remote-id>
+ <remote-id type="cpan-module">Net::NNTP</remote-id>
+ <remote-id type="cpan-module">Net::Netrc</remote-id>
+ <remote-id type="cpan-module">Net::POP3</remote-id>
+ <remote-id type="cpan-module">Net::SMTP</remote-id>
+ <remote-id type="cpan-module">Net::Time</remote-id>
+ </upstream>
+</pkgmetadata>