summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-29 19:41:27 -0500
committerSam James <sam@gentoo.org>2024-03-01 00:48:29 +0000
commite6988357743d4db2556673e90357017d2e230206 (patch)
tree9322e676fc5340c79c19896fec0682b3d6451778 /net-wireless
parentmedia-gfx/meshlab: remove various totally erroneous dependencies (diff)
downloadgentoo-e6988357743d4db2556673e90357017d2e230206.tar.gz
gentoo-e6988357743d4db2556673e90357017d2e230206.tar.bz2
gentoo-e6988357743d4db2556673e90357017d2e230206.zip
net-wireless/gnuradio: remove erroneous dependency on mpir
mpir is an ancient fork of gmp from 2017. It claims to be focused on speed. It doesn't build with modern compilers due to Modern C issues, and it fails to build with LTO as well. Unlike gmp, this will never be fixed. gnuradio checks for "MPLIB", which is internally implemented by first checking for gmp, and if gmp cannot be found, checking for mpir. mpir was never required, and if gmp happened to be installed, it would be an automagic dependency. Furthermore, there was a USE-conditional dependency on gmp for wavelets, which I am not sure makes sense but when triggered, resulted in a forced gmp dependency that then guaranteed mpir wouldn't be used. Bug: https://bugs.gentoo.org/812950 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gnuradio/gnuradio-3.10.9.2-r2.ebuild (renamed from net-wireless/gnuradio/gnuradio-3.10.9.2-r1.ebuild)3
-rw-r--r--net-wireless/gnuradio/gnuradio-9999.ebuild3
2 files changed, 2 insertions, 4 deletions
diff --git a/net-wireless/gnuradio/gnuradio-3.10.9.2-r1.ebuild b/net-wireless/gnuradio/gnuradio-3.10.9.2-r2.ebuild
index bbbc55d8c42e..407afc6b82ff 100644
--- a/net-wireless/gnuradio/gnuradio-3.10.9.2-r1.ebuild
+++ b/net-wireless/gnuradio/gnuradio-3.10.9.2-r2.ebuild
@@ -45,12 +45,12 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep 'dev-libs/boost:=[python,${PYTHON_USEDEP}]')
+ dev-libs/gmp:=
dev-libs/log4cpp:=
$(python_gen_cond_dep 'dev-python/jsonschema[${PYTHON_USEDEP}]')
dev-libs/spdlog:=
dev-libs/libfmt:=
sci-libs/fftw:3.0=
- sci-libs/mpir:=
sci-libs/volk:=
media-libs/libsndfile
sys-libs/libunwind
@@ -108,7 +108,6 @@ RDEPEND="${PYTHON_DEPS}
)
wavelet? (
sci-libs/gsl:=
- dev-libs/gmp:=
sci-libs/lapack
)
zeromq? ( >=net-libs/zeromq-2.1.11:= )
diff --git a/net-wireless/gnuradio/gnuradio-9999.ebuild b/net-wireless/gnuradio/gnuradio-9999.ebuild
index 6270b80fb9f0..04191082fbfe 100644
--- a/net-wireless/gnuradio/gnuradio-9999.ebuild
+++ b/net-wireless/gnuradio/gnuradio-9999.ebuild
@@ -45,12 +45,12 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep 'dev-libs/boost:=[python,${PYTHON_USEDEP}]')
+ dev-libs/gmp:=
dev-libs/log4cpp:=
$(python_gen_cond_dep 'dev-python/jsonschema[${PYTHON_USEDEP}]')
dev-libs/spdlog:=
dev-libs/libfmt:=
sci-libs/fftw:3.0=
- sci-libs/mpir:=
sci-libs/volk:=
media-libs/libsndfile
sys-libs/libunwind
@@ -108,7 +108,6 @@ RDEPEND="${PYTHON_DEPS}
)
wavelet? (
sci-libs/gsl:=
- dev-libs/gmp:=
sci-libs/lapack
)
zeromq? ( >=net-libs/zeromq-2.1.11:= )