summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-11-22 17:28:42 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2022-11-22 17:41:33 +0100
commitaa4e68f1b6114d2941cae1932ddc63d85ed03ab3 (patch)
tree663c4723d6f9226360fd0cc8132f36190aae6384 /net-wireless
parentsci-geosciences/gpxsee: bump to 11.9 (diff)
downloadgentoo-aa4e68f1b6114d2941cae1932ddc63d85ed03ab3.tar.gz
gentoo-aa4e68f1b6114d2941cae1932ddc63d85ed03ab3.tar.bz2
gentoo-aa4e68f1b6114d2941cae1932ddc63d85ed03ab3.zip
net-wireless/gr-iqbal: Drop old, update -9999
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gr-iqbal/Manifest1
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild41
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-9999.ebuild8
3 files changed, 6 insertions, 44 deletions
diff --git a/net-wireless/gr-iqbal/Manifest b/net-wireless/gr-iqbal/Manifest
index d41286bd8cbf..3b9786696d0a 100644
--- a/net-wireless/gr-iqbal/Manifest
+++ b/net-wireless/gr-iqbal/Manifest
@@ -1,2 +1 @@
-DIST gr-iqbal-0.38.2.tar.gz 106408 BLAKE2B 8c9eb0880f527708cb304d9b70d0ab46c1f430aecf520366f85f3b74e1e1e2b612360cebc0dc9d6431f42adf2602baaaf1ebbe3b58ad08791d30f9604c96fd6c SHA512 39ca96769c3d7910c6ca7da973fdfbab816b45ec339adb5bbf32d07d2e967fb3e7265e907f9abbdf4e2b754dc03e9eac970c0cef3df4f07470ec4ba947900cb6
DIST gr-iqbal-0.38.2_p20210108.tar.gz 84577 BLAKE2B f12ab4965e5f896698843c9ef8907cd8263f6fba3365ea26420750ab221106a3fbbee6750cf587299a9528cecbb504c23d4f2085596683cb85eb6f6fb7ab814b SHA512 b9866f6ff3d6dba1e94428efed029356e436059fa1d6cb7f4c3da0b37842c025161f1532da6048c9b9cc5ce426eea14622ac6680176cff52f85bc0b2fda8c698
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild
deleted file mode 100644
index ae04e944ba3b..000000000000
--- a/net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake python-single-r1
-
-DESCRIPTION="gnuradio I/Q balancing"
-HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/osmocom/gr-iqbal.git"
-else
- SRC_URI="https://github.com/osmocom/gr-iqbal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~riscv ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0/${PV}"
-IUSE="doc"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="=net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
- net-libs/libosmo-dsp:=
- dev-libs/boost:=
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_DOXYGEN="$(usex doc)"
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- python_optimize
-}
diff --git a/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild b/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
index ae04e944ba3b..b13d37508ebc 100644
--- a/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
+++ b/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
@@ -13,7 +13,9 @@ if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/osmocom/gr-iqbal.git"
else
- SRC_URI="https://github.com/osmocom/gr-iqbal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ COMMIT="fbee239a6fb36dd2fb564f6e6a0d393c4bc844db"
+ SRC_URI="https://github.com/osmocom/gr-iqbal/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64 ~arm ~riscv ~x86"
fi
@@ -22,7 +24,7 @@ SLOT="0/${PV}"
IUSE="doc"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="=net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
+RDEPEND=">=net-wireless/gnuradio-3.9.0.0:0=[${PYTHON_SINGLE_USEDEP}]
net-libs/libosmo-dsp:=
dev-libs/boost:=
${PYTHON_DEPS}"
@@ -37,5 +39,7 @@ src_configure() {
src_install() {
cmake_src_install
+ find "${D}" -name '__init__.py[co]' -delete || die
python_optimize
+ mv "${ED}/usr/share/doc/gr-iqbalance" "${ED}/usr/share/doc/${P}"
}