summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/portapack-firmware
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/portapack-firmware')
-rw-r--r--net-wireless/portapack-firmware/Manifest1
-rw-r--r--net-wireless/portapack-firmware/metadata.xml9
-rw-r--r--net-wireless/portapack-firmware/portapack-firmware-20150722.ebuild50
3 files changed, 60 insertions, 0 deletions
diff --git a/net-wireless/portapack-firmware/Manifest b/net-wireless/portapack-firmware/Manifest
new file mode 100644
index 000000000000..8413aa9a22dc
--- /dev/null
+++ b/net-wireless/portapack-firmware/Manifest
@@ -0,0 +1 @@
+DIST portapack-h1-firmware-20150722.tar.bz2 86962 SHA256 9692b9a4b3cc1fa1ed5192b594c21ef1fd14e0b7a3d9a61086e4660b14dd4698 SHA512 b5647f8ad5d954d91e087ce281585b0e9d5c0ba459fb16068ac93adfa130a50df0b3ac7111c742ac33bb9df5ab4fb30da55a265504e0c55e9b80726fd51da6c8 WHIRLPOOL 2c9c77b65678f06b083ca5f815b335f101facc64c96dd3d9cad2629f5969881a4ba6964b00696033621ae76a6b8c2db62198f1c8f0c9d23de90c45cf3e6aa82d
diff --git a/net-wireless/portapack-firmware/metadata.xml b/net-wireless/portapack-firmware/metadata.xml
new file mode 100644
index 000000000000..4b7209f1850c
--- /dev/null
+++ b/net-wireless/portapack-firmware/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">sharebrained/portapack-hackrf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/portapack-firmware/portapack-firmware-20150722.ebuild b/net-wireless/portapack-firmware/portapack-firmware-20150722.ebuild
new file mode 100644
index 000000000000..1f9450476754
--- /dev/null
+++ b/net-wireless/portapack-firmware/portapack-firmware-20150722.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Firmware and scripts for controlling the Portapack from Sharebrained"
+HOMEPAGE="https://github.com/sharebrained/portapack-hackrf/releases"
+SRC_URI="https://github.com/sharebrained/portapack-hackrf/releases/download/20150722/portapack-h1-firmware-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PDEPEND=">=net-wireless/hackrf-tools-2015.07.2-r1
+ =app-mobilephone/dfu-util-0.7"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/hackrf
+ newins portapack-h1-firmware.bin portapack-h1-firmware-${PV}.bin
+ ln -s portapack-h1-firmware-${PV}.bin "${ED}/usr/share/hackrf/portapack-h1-firmware.bin"
+
+ cat << EOF > switch_to_portapack
+#!/bin/sh
+printf "Hold down the HackRF's DFU button (the button closest to the antenna jack)\n"
+printf "then plug the HackRF into a USB port on your computer.\n"
+printf "After the HackRF is plugged in, you may release the DFU button.\n"
+printf "Press any key to continue or ^c to abort\n"
+read
+dfu-util --device 1fc9:000c --download /usr/share/hackrf/hackrf_one_usb_ram.dfu --reset
+sleep 2s
+hackrf_spiflash -w /usr/share/hackrf/portapack-h1-firmware.bin
+EOF
+ dobin switch_to_portapack
+ cat << EOF > switch_to_hackrf
+#!/bin/sh
+printf "Hold down the HackRF's DFU button (the button closest to the antenna jack)\n"
+printf "then plug the HackRF into a USB port on your computer.\n"
+printf "After the HackRF is plugged in, you may release the DFU button.\n"
+printf "Press any key to continue or ^c to abort\n"
+read
+dfu-util --device 1fc9:000c --download /usr/share/hackrf/hackrf_one_usb_ram.dfu --reset
+sleep 2s
+hackrf_spiflash -w /usr/share/hackrf/hackrf_one_usb_rom_to_ram.bin
+EOF
+ dobin switch_to_hackrf
+}