summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-09-12 14:41:59 -0400
committerRick Farina <zerochaos@gentoo.org>2019-09-12 14:42:43 -0400
commit042c8175b3d8578729f5f5b03fe878191549f62a (patch)
tree8d4f88068142b77f23e8353438a158b9c7662a10 /net-wireless/gr-scan/gr-scan-20160211.ebuild
parentpackage.mask: Last rite dev-libs/libhome (diff)
downloadgentoo-042c8175b3d8578729f5f5b03fe878191549f62a.tar.gz
gentoo-042c8175b3d8578729f5f5b03fe878191549f62a.tar.bz2
gentoo-042c8175b3d8578729f5f5b03fe878191549f62a.zip
net-wireless/gr-scan: bump and fix minor qa issue
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/gr-scan/gr-scan-20160211.ebuild')
-rw-r--r--net-wireless/gr-scan/gr-scan-20160211.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-wireless/gr-scan/gr-scan-20160211.ebuild b/net-wireless/gr-scan/gr-scan-20160211.ebuild
new file mode 100644
index 000000000000..8ac634e2728f
--- /dev/null
+++ b/net-wireless/gr-scan/gr-scan-20160211.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Frequency scanner for GNU Radio"
+HOMEPAGE="http://git.zx2c4.com/gr-scan/about"
+#SRC_URI="http://git.zx2c4.com/${PN}/snapshot/${P}.tar.xz"
+COMMIT="25030f6063e796e5cb048ffc1ec7e1914192146b"
+SRC_URI="https://git.zx2c4.com/${PN}/snapshot/${PN}-${COMMIT}.tar.xz -> ${P}.tar.xz"
+LICENSE="GPL-3"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-wireless/gnuradio:=
+ net-wireless/gr-osmosdr:=
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ sed -i 's#install -s#install#' Makefile
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}