summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-04-03 12:02:25 +0200
committerPacho Ramos <pacho@gentoo.org>2016-04-03 14:40:01 +0200
commitf5d1cc056f7a5b1b7cdb65540e6ea9f8a26ae26d (patch)
tree4f2e79f42f9d4c99ebe997f205a9590f3f384629 /net-wireless/gnome-bluetooth
parentnet-wireless/gnome-bluetooth: Drop old (diff)
downloadgentoo-f5d1cc056f7a5b1b7cdb65540e6ea9f8a26ae26d.tar.gz
gentoo-f5d1cc056f7a5b1b7cdb65540e6ea9f8a26ae26d.tar.bz2
gentoo-f5d1cc056f7a5b1b7cdb65540e6ea9f8a26ae26d.zip
net-wireless/gnome-bluetooth: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-wireless/gnome-bluetooth')
-rw-r--r--net-wireless/gnome-bluetooth/Manifest1
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.18.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index eac9c6f927fd..68bf8873908f 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1 +1,2 @@
DIST gnome-bluetooth-3.18.2.tar.xz 793096 SHA256 d8df073c331df0f97261869fb77ffcdbf4e3e4eaf460d3c3ed2b16e03d9c5398 SHA512 4c0f23ad59a81fb7dd626da9ebaf0c7d671402a41ff6665d6b3e5f9e75a76e307c656759425972b7a00ceb71b4be28cf141fb5727ed59f4cec326cad615ca896 WHIRLPOOL b5147dda96951e1fe428a77a448514dbbf225a94fd2b582e5b20823a0adc7a4bd816eb709fbe4847bc8f070fe80a94380dafee1dade58bc492df20cff598df24
+DIST gnome-bluetooth-3.18.3.tar.xz 793460 SHA256 e481b70423e52adc3c3aa919eeb033b47f9cd1598d6c0c7f384c0bd10f4e8ce3 SHA512 8d0c6d6d1344d297723607de2770ec31544e910e91a9e927ac5ee5eb41862d3b961b225a0fb37b929c5167863d352e54cbbb48a762a94146528fee8a8ebd16f2 WHIRLPOOL 4b071104f825d9fd50b5f8941e7555929682b730ed11b1626a62879c42b4e9b4e7309feb88d33d9f4ee9c4727f338308e63248367888bc033926ec66e52cd918
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.18.3.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.18.3.ebuild
new file mode 100644
index 000000000000..e4819fdf8013
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.18.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2 udev user
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="2/13" # subslot = libgnome-bluetooth soname version
+IUSE="+introspection"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.38:2
+ media-libs/libcanberra[gtk3]
+ >=x11-libs/gtk+-3.12:3[introspection?]
+ x11-libs/libnotify
+ virtual/udev
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=net-wireless/bluez-5
+"
+DEPEND="${COMMON_DEPEND}
+ !net-wireless/bluez-gnome
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40.0
+ dev-util/itstool
+ virtual/libudev
+ virtual/pkgconfig
+ x11-proto/xproto
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # Regenerate gdbus-codegen files to allow using any glib version; bug #436236
+ # https://bugzilla.gnome.org/show_bug.cgi?id=758096
+ rm -v lib/bluetooth-client-glue.{c,h} || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-documentation \
+ --disable-desktop-update \
+ --disable-icon-update \
+ --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+ udev_dorules "${FILESDIR}"/61-${PN}.rules
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version sys-auth/consolekit[acl] && ! has_version sys-apps/systemd[acl] ; then
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+ fi
+}