summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Korepanov <kaikaikai@yandex.ru>2024-12-31 18:53:17 +0000
committerSam James <sam@gentoo.org>2025-01-06 01:56:41 +0000
commitf052f9c4611d6e5f747c71e2632f3257915700a0 (patch)
treebaaec29f87899241ae808b5141778e9ea3fc9ed2 /net-vpn
parentmedia-libs/partio: #947569 (diff)
downloadgentoo-f052f9c4611d6e5f747c71e2632f3257915700a0.tar.gz
gentoo-f052f9c4611d6e5f747c71e2632f3257915700a0.tar.bz2
gentoo-f052f9c4611d6e5f747c71e2632f3257915700a0.zip
net-vpn/i2pd: version bump 2.55.0
Closes: https://bugs.gentoo.org/946514 Signed-off-by: Alexey Korepanov <kaikaikai@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/39923 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/i2pd/Manifest1
-rw-r--r--net-vpn/i2pd/i2pd-2.55.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-vpn/i2pd/Manifest b/net-vpn/i2pd/Manifest
index 11359c29680a..b798283f621c 100644
--- a/net-vpn/i2pd/Manifest
+++ b/net-vpn/i2pd/Manifest
@@ -1,2 +1,3 @@
DIST i2pd-2.53.1.tar.gz 677029 BLAKE2B 5b84a3833b3a71c88dc7bf319f802c7c326f045eeee1c5062d51f3b9aa9fb76627c075baf6c6aa8ed9bac3b2fd35ea16d33396332c7b7b21ea15117564f037e0 SHA512 9226fbab7f260e6d84738db4fe9d729eedc8104ed09b191331760b1d77debb6bc05e6558861c1cd304ffdc8661e893f9ac5950e47a38facad51038769b478c64
DIST i2pd-2.54.0.tar.gz 686135 BLAKE2B 48e3caed26c8ed5725952a5c21df98b70224d39327b1b95d67924c9ccde2bf687f819a5956f6d8181b44f394464918a8c126b3e5c1052ff6dd22ba3baa3c2215 SHA512 edb1f6d74411754f20475386c40df68579e062716c9344f5d006d40e882dd2a2aaa10d48acdf399c0f9f2db9dcd0c7c466d077dfd9854085db0e1a4a28b57f89
+DIST i2pd-2.55.0.tar.gz 690979 BLAKE2B 51d36971ff4aac1a30a07c39f2a9d424d83f01cf978591642c2a28dfa772a7f24e02f04900cbeec639e37be1c5ffb2cef06d9b681ac1ca91abed100e998eb228 SHA512 b7eedf116f7282f0825395a3ecca25789e6b09279ac9da4c5146f7202302f9b07fad8cfd6ac7c5f5f1b4299851e78a4923807a370e1cad7d435ce13535cfa6be
diff --git a/net-vpn/i2pd/i2pd-2.55.0.ebuild b/net-vpn/i2pd/i2pd-2.55.0.ebuild
new file mode 100644
index 000000000000..6cd51ebacee2
--- /dev/null
+++ b/net-vpn/i2pd/i2pd-2.55.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd
+
+DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
+HOMEPAGE="https://github.com/PurpleI2P/i2pd"
+SRC_URI="https://github.com/PurpleI2P/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_x86_aes +upnp"
+
+DEPEND="
+ dev-libs/boost:=
+ dev-libs/openssl:0=[-bindist(-)]
+ sys-libs/zlib
+ upnp? ( net-libs/miniupnpc:= )
+"
+RDEPEND="
+ acct-user/i2pd
+ acct-group/i2pd
+ ${DEPEND}
+"
+
+CMAKE_USE_DIR="${WORKDIR}/${P}/build"
+
+DOCS=( ../README.md ../contrib/i2pd.conf ../contrib/tunnels.conf )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)
+ -DWITH_HARDENING=OFF # worsens or matches the non-hardened profiles
+ -DWITH_STATIC=OFF
+ -DWITH_UPNP=$(usex upnp ON OFF)
+ -DWITH_LIBRARY=ON
+ -DWITH_BINARY=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # config
+ insinto /etc/i2pd
+ doins contrib/i2pd.conf
+ doins contrib/tunnels.conf
+
+ # working directory
+ insinto /var/lib/i2pd
+ doins -r contrib/certificates
+
+ # add /var/lib/i2pd/certificates to CONFIG_PROTECT
+ doenvd "${FILESDIR}/99i2pd"
+
+ # openrc and systemd daemon routines
+ newconfd "${FILESDIR}/i2pd-2.6.0-r3.confd" i2pd
+ newinitd "${FILESDIR}/i2pd-2.39.0.initd" i2pd
+ systemd_newunit "${FILESDIR}/i2pd-2.38.0.service" i2pd.service
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/i2pd-2.38.0-r1.logrotate" i2pd
+}
+
+pkg_postinst() {
+ if [[ -f ${EROOT}/etc/i2pd/subscriptions.txt ]]; then
+ ewarn
+ ewarn "Configuration of the subscriptions has been moved from"
+ ewarn "subscriptions.txt to i2pd.conf. We recommend updating"
+ ewarn "i2pd.conf accordingly and deleting subscriptions.txt."
+ fi
+}