summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:26:33 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:29 +0100
commitc991777eb1bfdc2599e6d76fbeb455640c4fbff1 (patch)
tree25b4bf279c4b913896b97a835f5b2f9b9b40a1f8 /net-vpn
parentnet-misc/wol: drop 0.7.1-r2 (diff)
downloadgentoo-c991777eb1bfdc2599e6d76fbeb455640c4fbff1.tar.gz
gentoo-c991777eb1bfdc2599e6d76fbeb455640c4fbff1.tar.bz2
gentoo-c991777eb1bfdc2599e6d76fbeb455640c4fbff1.zip
net-vpn/networkmanager-strongswan: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.5.2-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.5.2-r1.ebuild b/net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..7451dab00b1d
--- /dev/null
+++ b/net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.5.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="NetworkManager"
+MY_P="${P/networkmanager/${MY_PN}}"
+
+DESCRIPTION="NetworkManager StrongSwan plugin"
+HOMEPAGE="https://www.strongswan.org/"
+SRC_URI="https://download.strongswan.org/${MY_PN}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ app-crypt/libsecret
+ >=net-libs/libnma-1.1.0
+ net-misc/networkmanager
+ >=net-vpn/strongswan-5.8.3[networkmanager]
+ x11-libs/gtk+:3
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ # Don't enable all warnings, as some are treated as errors and the compilation will fail
+ --disable-more-warnings
+ --disable-static
+ --without-libnm-glib
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}