summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-09-24 06:41:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-09-24 06:42:36 -0500
commit164bdf6b9267a28b5c093ea1b4f42e864507d6db (patch)
tree4b88add70cf14c2320da746f669db0d4ddca7fb2 /net-vpn
parentx11-wm/treewm: removed Variable in wrong scope (no revbump since it was not e... (diff)
downloadgentoo-164bdf6b9267a28b5c093ea1b4f42e864507d6db.tar.gz
gentoo-164bdf6b9267a28b5c093ea1b4f42e864507d6db.tar.bz2
gentoo-164bdf6b9267a28b5c093ea1b4f42e864507d6db.zip
net-vpn/tailscale: add 1.74.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.74.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index 76f89c3f1f64..3452e52eb470 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -1,2 +1,4 @@
DIST tailscale-1.72.0-deps.tar.xz 226770144 BLAKE2B 4c23fe678a320f674cafb9e3d9f80c9a698bb6133ac8a64fe6024822e03a93ce9cdfcb0838370a8cb6da38da6d6f0241c9599f3a1b11224d1dd531ba00efa629 SHA512 848e83af5f26883cd7f56e19749cf02a489a5a7e0a0c7e23d4df6f44d59d311e7f28ddd4e67c29626c6d7d8232d867d249a6f8287177bddab59c5279a3cf776d
DIST tailscale-1.72.0.tar.gz 3031783 BLAKE2B 58e7609a8481ee0bbf58ad3b3d924d88192c201ea32d4efbf015201d2d67a8a330ee93452bdd23c902065bcd924f18e793ac531348c2c34591fab15c2c2eb01b SHA512 ed1b853bde7a5aadc469e2d2e810db8b800514d8278b24d3f2453ecc3e89b4198999e52f3bbc7743302ab60ad78432d5222808ce7e7739befd9bd15ad2eda20a
+DIST tailscale-1.74.1-deps.tar.xz 254129372 BLAKE2B e9e0fea2ba83d3ad23e4b26c0e86149c321d6f236f0ff30a019ed0aab6ed1568f3516832cd6af0ef904359308fefdfd7a9394af3859e503a0afc6e0cc28b7cd7 SHA512 32b3829c79733a4d86b0a40a09a5c8236604608bf490756f7a76c835d0688e79318837d2db9a1459afd7186b326c924c01d0431376ab76a6a0fbcfdd11c15811
+DIST tailscale-1.74.1.tar.gz 3237654 BLAKE2B c54eb1338b2d017607213ef810d3accc64adc82efa60839c37c1298b79e61e56f472e329b237e32d270c8725fde678214b6c1290901d7fad1563451904a38bca SHA512 795aa53b4681a9e5f8316651d33bc9a0724fb75cba99847db01e3b0f29d6957b3588fea77347ce9d53d28154883458cac8d54ccd08ebbb31cc00294158d7780f
diff --git a/net-vpn/tailscale/tailscale-1.74.1.ebuild b/net-vpn/tailscale/tailscale-1.74.1.ebuild
new file mode 100644
index 000000000000..9b1ab59a551a
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.74.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module linux-info systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+VERSION_MINOR="74"
+VERSION_SHORT="1.74.1"
+VERSION_LONG="1.74.1-t0ca17be4a"
+VERSION_GIT_HASH="0ca17be4a2d5f5c54c9a2c74e3003de8d779c4f0"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+CONFIG_CHECK="~TUN"
+
+RDEPEND="net-firewall/iptables"
+BDEPEND=">=dev-lang/go-1.22"
+
+RESTRICT="test"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.longStamp=${VERSION_LONG}
+ -X tailscale.com/version.shortStamp=${VERSION_SHORT}
+ -X tailscale.com/version.gitCommitStamp=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}