diff options
author | David Seifert <soap@gentoo.org> | 2020-03-21 15:26:47 +0100 |
---|---|---|
committer | David Seifert <soap@gentoo.org> | 2020-03-21 15:26:47 +0100 |
commit | b9c18b4845d32fd64aa8d155bd37587790ec8fb4 (patch) | |
tree | 03bf5534280d6dbdd9266c8d6294ab84bd3d6b04 /net-proxy/pingtunnel | |
parent | sys-libs/uid_wrapper: Use cmake.eclass (diff) | |
download | gentoo-b9c18b4845d32fd64aa8d155bd37587790ec8fb4.tar.gz gentoo-b9c18b4845d32fd64aa8d155bd37587790ec8fb4.tar.bz2 gentoo-b9c18b4845d32fd64aa8d155bd37587790ec8fb4.zip |
net-proxy/pingtunnel: Port to EAPI 7
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-proxy/pingtunnel')
-rw-r--r-- | net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch | 4 | ||||
-rw-r--r-- | net-proxy/pingtunnel/pingtunnel-0.72.ebuild | 26 |
2 files changed, 13 insertions, 17 deletions
diff --git a/net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch b/net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch index 9dce0992cbda..27576bfd434f 100644 --- a/net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch +++ b/net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch @@ -1,5 +1,5 @@ ---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -2,11 +2,26 @@
# (c) 2004-2009 Daniel Stoedle, daniels@cs.uit.no
# ptunnel.exe target added by Mike Miller, mike@mikeage.net
diff --git a/net-proxy/pingtunnel/pingtunnel-0.72.ebuild b/net-proxy/pingtunnel/pingtunnel-0.72.ebuild index 9f41ef3c3154..cc137990d138 100644 --- a/net-proxy/pingtunnel/pingtunnel-0.72.ebuild +++ b/net-proxy/pingtunnel/pingtunnel-0.72.ebuild @@ -1,9 +1,9 @@ # Copyright 1999-2020 Gentoo Authors # Distributed under the terms of the GNU General Public License v2 -EAPI=5 +EAPI=7 -inherit eutils toolchain-funcs +inherit toolchain-funcs DESCRIPTION="Tunnel TCP over ICMP" HOMEPAGE="https://www.cs.uit.no/~daniels/PingTunnel" @@ -12,26 +12,22 @@ SRC_URI="https://www.cs.uit.no/~daniels/PingTunnel/PingTunnel-${PV}.tar.gz" LICENSE="BSD" SLOT="0" KEYWORDS="~amd64 ~arm ~ppc ~sh ~x86" -IUSE="doc selinux" +IUSE="selinux" -DEPEND=" +RDEPEND=" net-libs/libpcap - selinux? ( sys-libs/libselinux ) -" -RDEPEND="${DEPEND}" + selinux? ( sys-libs/libselinux )" +DEPEND="${RDEPEND}" S="${WORKDIR}"/PingTunnel -src_prepare() { - epatch "${FILESDIR}"/${P}_makefile.patch -} +PATCHES=( "${FILESDIR}"/${P}_makefile.patch ) +HTML_DOCS=( web/. ) -src_compile() { +src_configure() { tc-export CC - emake $(usex selinux "SELINUX=1" "SELINUX=0") } -src_install() { - default - use doc && dohtml web/* +src_compile() { + emake SELINUX=$(usex selinux 1 0) } |