summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-05-08 03:01:18 +0000
committerMatt Turner <mattst88@gentoo.org>2020-05-23 12:19:17 -0700
commit510215752be59ccf102d6ec51bf54d23de27d476 (patch)
treefc6874bcb44b343f4d848ed28171ba495fdcca1d /net-proxy/haproxy
parentgnome-python-common-r1.eclass: Mark as DEAD (diff)
downloadgentoo-510215752be59ccf102d6ec51bf54d23de27d476.tar.gz
gentoo-510215752be59ccf102d6ec51bf54d23de27d476.tar.bz2
gentoo-510215752be59ccf102d6ec51bf54d23de27d476.zip
net-proxy/haproxy: Fix 32-bit build
Links against libatomic on 32-bit non-x86 arches. Closes: https://bugs.gentoo.org/668002 Closes: https://github.com/gentoo/gentoo/pull/15704 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-proxy/haproxy')
-rw-r--r--net-proxy/haproxy/haproxy-2.0.14-r1.ebuild7
-rw-r--r--net-proxy/haproxy/haproxy-2.1.4-r1.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/net-proxy/haproxy/haproxy-2.0.14-r1.ebuild b/net-proxy/haproxy/haproxy-2.0.14-r1.ebuild
index 7e2cb38725c6..d1c45681b560 100644
--- a/net-proxy/haproxy/haproxy-2.0.14-r1.ebuild
+++ b/net-proxy/haproxy/haproxy-2.0.14-r1.ebuild
@@ -97,12 +97,17 @@ src_compile() {
# For now, until the strict-aliasing breakage will be fixed
append-cflags -fno-strict-aliasing
+ # Bug #668002
+ if use ppc || use arm || use hppa; then
+ TARGET_LDFLAGS=-latomic
+ fi
+
if use prometheus-exporter; then
EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
fi
# HAProxy really needs some of those "SPEC_CFLAGS", like -fno-strict-aliasing
- emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" ${args[@]}
+ emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" TARGET_LDFLAGS="${TARGET_LDFLAGS}" ${args[@]}
emake -C contrib/systemd SBINDIR=/usr/sbin
if use tools ; then
diff --git a/net-proxy/haproxy/haproxy-2.1.4-r1.ebuild b/net-proxy/haproxy/haproxy-2.1.4-r1.ebuild
index 7e2cb38725c6..d1c45681b560 100644
--- a/net-proxy/haproxy/haproxy-2.1.4-r1.ebuild
+++ b/net-proxy/haproxy/haproxy-2.1.4-r1.ebuild
@@ -97,12 +97,17 @@ src_compile() {
# For now, until the strict-aliasing breakage will be fixed
append-cflags -fno-strict-aliasing
+ # Bug #668002
+ if use ppc || use arm || use hppa; then
+ TARGET_LDFLAGS=-latomic
+ fi
+
if use prometheus-exporter; then
EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
fi
# HAProxy really needs some of those "SPEC_CFLAGS", like -fno-strict-aliasing
- emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" ${args[@]}
+ emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" TARGET_LDFLAGS="${TARGET_LDFLAGS}" ${args[@]}
emake -C contrib/systemd SBINDIR=/usr/sbin
if use tools ; then