summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2024-07-18 02:08:57 +0200
committerLouis Sautier <sbraz@gentoo.org>2024-07-20 03:56:42 +0200
commit960ca10a6b94c205cd57b77e612b369b7e2f589b (patch)
tree6383d17b9062dcbb09a2363a86cefc03a295807d /net-p2p
parentapp-misc/lcd4linux: drop dmalloc (diff)
downloadgentoo-960ca10a6b94c205cd57b77e612b369b7e2f589b.tar.gz
gentoo-960ca10a6b94c205cd57b77e612b369b7e2f589b.tar.bz2
gentoo-960ca10a6b94c205cd57b77e612b369b7e2f589b.zip
net-p2p/airdcpp-webclient: add 2.12.2
* Update license (upstream changed it for this release). * Introduce new build dependency (dev-cpp/nlohmann_json). * Fix CMake build type to use cmake.eclass's default. Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 69c843fdfa1f..be8c4be7a72a 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-2.11.4.tar.gz 958611 BLAKE2B f0ff3a39c8615edbc541a952460b831eefd37f1825da4881da147c54a00612479382a9d69d4399f55fbdd77c77ab6716097594c8d10c6a3839db5ae14d11cc87 SHA512 0ab8fbdc6d1b815546724bfdcd436aa2e07ffdb499b91a3506db18c2f494f76bc1203d0d9d3cfd3ae6ad9d0f2fb4038df46aada0515747e2477c7f6595a05436
DIST airdcpp-webclient-2.12.1.tar.gz 961603 BLAKE2B bc17fb3b3643b1d699f7c0ef958616759d87cd96467318a592c1460e355d512a3efc0e793a3098f8074f02d5af47b1ef33b65fbe7a6c9a955bbdc472d323f637 SHA512 0f662311d208b937c946b41a617c82a0e72442fb7c2bef09d56ec71931bde35bd1024ce53cb3bf7deda3eaaac31ecbe8fa2c66c337c0833db655f80f5e5156be
+DIST airdcpp-webclient-2.12.2.tar.gz 793005 BLAKE2B 777a8aa3e5425566ae15f6ae616796953c653890aac607f8c3799c7a959335a0c7bed9380e85a9f6174d989392d909056faff582d42292174c2609de4b7451dc SHA512 29ad24d1714e86123ed0d3ef226934682001202c0197df9d83c4a225503786a5853cd4bf31f90eb30a98351fba0d246e02ca4ba9ffe71f6bda760021f095b9b2
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.2.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.2.ebuild
new file mode 100644
index 000000000000..2950bd3fec76
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit cmake python-any-r1 systemd
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="debug nat-pmp +tbb +webui"
+
+RDEPEND="
+ acct-user/airdcppd
+ acct-group/airdcppd
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist(-)]
+ net-libs/miniupnpc:=
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="
+ dev-cpp/nlohmann_json
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ -DINSTALL_WEB_UI=OFF
+ )
+ CMAKE_BUILD_TYPE=$(usex debug Debug RelWithDebInfo) cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ systemd_dounit "${FILESDIR}/airdcppd.service"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}