summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2023-06-25 11:17:57 +0300
committerSam James <sam@gentoo.org>2023-06-26 15:41:43 +0100
commit722a58cbadfca20fc9ba71ce09008a9fd7584848 (patch)
treec9aab3993266996cc2bbd658dc12776d46605978 /net-p2p
parentsys-devel/gcc: Stabilize 12.3.1_p20230526 amd64, #909176 (diff)
downloadgentoo-722a58cbadfca20fc9ba71ce09008a9fd7584848.tar.gz
gentoo-722a58cbadfca20fc9ba71ce09008a9fd7584848.tar.bz2
gentoo-722a58cbadfca20fc9ba71ce09008a9fd7584848.zip
net-p2p/amule: fix build w/ clang and boost-1.82
Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://bugs.gentoo.org/907843 Closes: https://github.com/gentoo/gentoo/pull/31517 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/amule-2.3.3-r1.ebuild153
-rw-r--r--net-p2p/amule/amule-9999.ebuild8
-rw-r--r--net-p2p/amule/files/amule-2.3.3-autoconf-2.70.patch28
-rw-r--r--net-p2p/amule/metadata.xml1
4 files changed, 189 insertions, 1 deletions
diff --git a/net-p2p/amule/amule-2.3.3-r1.ebuild b/net-p2p/amule/amule-2.3.3-r1.ebuild
new file mode 100644
index 000000000000..e5e37d05e9dc
--- /dev/null
+++ b/net-p2p/amule/amule-2.3.3-r1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg-utils
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/amule-project/amule"
+ inherit autotools git-r3
+else
+ MY_P="${PN/m/M}-${PV}"
+ SRC_URI="https://download.sourceforge.net/${PN}/${MY_P}.tar.xz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="aMule, the all-platform eMule p2p client"
+HOMEPAGE="http://www.amule.org/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="daemon debug geoip nls remote stats upnp +X"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/crypto++:=
+ sys-libs/binutils-libs:0=
+ sys-libs/readline:0=
+ sys-libs/zlib
+ >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X?]
+ daemon? ( acct-user/amule )
+ geoip? ( dev-libs/geoip )
+ nls? ( virtual/libintl )
+ remote? (
+ acct-user/amule
+ media-libs/libpng:0=
+ )
+ stats? ( media-libs/gd:=[jpeg,png] )
+ upnp? ( net-libs/libupnp:0 )
+"
+DEPEND="${RDEPEND}
+ X? ( dev-util/desktop-file-utils )
+"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/boost-m4-0.4_p20221019
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.2-disable-version-check.patch"
+ "${FILESDIR}/${PN}-2.3.3-fix-exception.patch"
+ "${FILESDIR}/${P}-autoconf-2.70.patch"
+)
+
+pkg_setup() {
+ setup-wxwidgets
+}
+
+src_prepare() {
+ default
+ rm m4/boost.m4 || die
+
+ if [[ ${PV} == 9999 ]]; then
+ ./autogen.sh || die
+ else
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ append-cxxflags -std=gnu++14
+
+ local myconf=(
+ --with-denoise-level=0
+ --with-wx-config="${WX_CONFIG}"
+ --enable-amulecmd
+ --with-boost
+ $(use_enable debug)
+ $(use_enable daemon amule-daemon)
+ $(use_enable geoip)
+ $(use_enable nls)
+ $(use_enable remote webserver)
+ $(use_enable stats cas)
+ $(use_enable stats alcc)
+ $(use_enable upnp)
+ )
+
+ if use X; then
+ myconf+=(
+ $(use_enable remote amule-gui)
+ $(use_enable stats alc)
+ $(use_enable stats wxcas)
+ )
+ else
+ myconf+=(
+ --disable-monolithic
+ --disable-amule-gui
+ --disable-alc
+ --disable-wxcas
+ )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ if use daemon; then
+ newconfd "${FILESDIR}"/amuled.confd-r1 amuled
+ newinitd "${FILESDIR}"/amuled.initd amuled
+ fi
+ if use remote; then
+ newconfd "${FILESDIR}"/amuleweb.confd-r1 amuleweb
+ newinitd "${FILESDIR}"/amuleweb.initd amuleweb
+ fi
+
+ if use daemon || use remote; then
+ keepdir /var/lib/${PN}
+ fowners amule:amule /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+ fi
+}
+
+pkg_postinst() {
+ local ver
+
+ if use daemon || use remote; then
+ for ver in ${REPLACING_VERSIONS}; do
+ if ver_test ${ver} -lt "2.3.2-r4"; then
+ elog "Default user under which amuled and amuleweb daemons are started"
+ elog "have been changed from p2p to amule. Default home directory have been"
+ elog "changed as well."
+ echo
+ elog "If you want to preserve old download/share location, you can create"
+ elog "symlink /var/lib/amule/.aMule pointing to the old location and adjust"
+ elog "files ownership *or* restore AMULEUSER and AMULEHOME variables in"
+ elog "/etc/conf.d/{amuled,amuleweb} to the old values."
+
+ break
+ fi
+ done
+ fi
+
+ use X && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ use X && xdg_desktop_database_update
+}
diff --git a/net-p2p/amule/amule-9999.ebuild b/net-p2p/amule/amule-9999.ebuild
index 392ddb148410..7decbd246b1d 100644
--- a/net-p2p/amule/amule-9999.ebuild
+++ b/net-p2p/amule/amule-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
WX_GTK_VER="3.0-gtk3"
-inherit wxwidgets xdg-utils
+inherit flag-o-matic wxwidgets xdg-utils
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/amule-project/amule"
@@ -45,6 +45,7 @@ DEPEND="${RDEPEND}
"
BDEPEND="
virtual/pkgconfig
+ >=sys-devel/boost-m4-0.4_p20221019
nls? ( sys-devel/gettext )
"
@@ -59,13 +60,18 @@ pkg_setup() {
src_prepare() {
default
+ rm m4/boost.m4 || die
if [[ ${PV} == 9999 ]]; then
./autogen.sh || die
+ else
+ eautoreconf
fi
}
src_configure() {
+ append-cxxflags -std=gnu++14
+
local myconf=(
--with-denoise-level=0
--with-wx-config="${WX_CONFIG}"
diff --git a/net-p2p/amule/files/amule-2.3.3-autoconf-2.70.patch b/net-p2p/amule/files/amule-2.3.3-autoconf-2.70.patch
new file mode 100644
index 000000000000..e52cfd6ae545
--- /dev/null
+++ b/net-p2p/amule/files/amule-2.3.3-autoconf-2.70.patch
@@ -0,0 +1,28 @@
+From 0d3e85ea46b52685c5b198fbade3a82f38071ca4 Mon Sep 17 00:00:00 2001
+From: Pablo Barciela <scow@riseup.net>
+Date: Sun, 19 Sep 2021 13:55:07 +0200
+Subject: [PATCH] allow to build with autoconf 2.70 and later
+
+Closes https://github.com/amule-project/amule/issues/232
+---
+ configure.ac | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 93a918c03..9c57668c6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,10 +30,6 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
+
+ AC_PREREQ(2.62)
+
+-# autoconf 2.70 introduced some incompatibilities that will make the build fail
+-# As a "workaround" reject 2.70 and above for now.
+-m4_if(m4_version_compare(m4_defn([AC_AUTOCONF_VERSION]), [2.70]), [-1],, [m4_fatal([autoconf ]m4_defn([AC_AUTOCONF_VERSION])[ is known to not work with aMule. Please use 2.69 instead.])])
+-
+ AC_CONFIG_SRCDIR([src/amule.cpp])
+ AC_CONFIG_HEADERS([config.h])
+ AC_CONFIG_MACRO_DIR([m4])
+--
+2.39.3
+
diff --git a/net-p2p/amule/metadata.xml b/net-p2p/amule/metadata.xml
index 32fc55855071..8d9b90c9f6f6 100644
--- a/net-p2p/amule/metadata.xml
+++ b/net-p2p/amule/metadata.xml
@@ -11,6 +11,7 @@
</maintainer>
<upstream>
<remote-id type="github">amule-project/amule</remote-id>
+ <remote-id type="sourceforge">amule</remote-id>
</upstream>
<use>
<flag name="daemon">Enable amule daemon</flag>