summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgentoo-setan <gentoo-setan@protonmail.com>2024-05-31 21:21:19 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-06-20 10:02:50 +0200
commit53b34d6375e2eaf1ae8c65c7bd90a5e1e7984479 (patch)
tree3213a4e0d74877c66773b33e39cbbb06f61e74d4 /net-p2p
parentdev-ruby/term-ansicolor: Stabilize 1.8.0 arm, #934584 (diff)
downloadgentoo-53b34d6375e2eaf1ae8c65c7bd90a5e1e7984479.tar.gz
gentoo-53b34d6375e2eaf1ae8c65c7bd90a5e1e7984479.tar.bz2
gentoo-53b34d6375e2eaf1ae8c65c7bd90a5e1e7984479.zip
net-p2p/biglybt: update to 3.6.0.0, add icon, and more changes
1. Improved src_install() 2. Removed issue template from DOC 3. Introduced more ${PN} 4. Swapped src_prepare's sed for a patch 5. Removed JAVA_ENCODING="8859_1" from src_compile 6. Modernized Javadoc (thanks vaukai!) Signed-off-by: gentoo-setan <gentoo-setan@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/36929 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/biglybt/Manifest1
-rw-r--r--net-p2p/biglybt/biglybt-3.6.0.0.ebuild102
-rw-r--r--net-p2p/biglybt/files/biglybt-3.6.0.0-disable-PluginUpdatePlugin.patch32
3 files changed, 135 insertions, 0 deletions
diff --git a/net-p2p/biglybt/Manifest b/net-p2p/biglybt/Manifest
index 648c013cd649..3390d228d952 100644
--- a/net-p2p/biglybt/Manifest
+++ b/net-p2p/biglybt/Manifest
@@ -1 +1,2 @@
DIST biglybt-3.5.0.0.tar.gz 41499459 BLAKE2B a08bfa560a72297a6ef21aed1bf4dc278e6c1e8b28b7adfb9bd880d8a6bcec1875b2ff8f3c95e9a05a41be5f14ba7ec66d775f53b78ee4a6bb88a295906f75e2 SHA512 1345ca1b49615be6d7e4ffb883ac5a60ed31af1dbf29a45d5d03ab56fb37d3f47d36abdffe990d264bda5fe5d3f90a3e2ad64373f1fe16fa23feb1ba8b70dd15
+DIST biglybt-3.6.0.0.tar.gz 43972902 BLAKE2B 76995d3d5f24f054690e609d2be7bd822f6c8573b6627bcf380c3a93be86265f4ca827c2991db65ef39c9f3f79b0cd8e0aebce492571a36bf237c95fc3d6cc54 SHA512 b56beb006ab813efa2ab2aff8563a04675e677ea70fe6ef72062e2d38ec753749b36740ae87f851739cb1389948a916273cb6ffb65758e651d0701a7f6237afd
diff --git a/net-p2p/biglybt/biglybt-3.6.0.0.ebuild b/net-p2p/biglybt/biglybt-3.6.0.0.ebuild
new file mode 100644
index 000000000000..9cacc9c9454c
--- /dev/null
+++ b/net-p2p/biglybt/biglybt-3.6.0.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# No tests, #839681
+JAVA_PKG_IUSE="doc source"
+MAVEN_PROVIDES="com.${PN}:${PN}-core:${PV} com.${PN}:${PN}-ui:${PV}"
+
+inherit desktop java-pkg-2 java-pkg-simple xdg
+
+DESCRIPTION="Feature-filled Bittorrent client based on the Azureus open source project"
+HOMEPAGE="https://www.biglybt.com"
+SRC_URI="https://github.com/BiglySoftware/BiglyBT/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/BiglyBT-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+CP_DEPEND="
+ dev-java/commons-cli:1
+ dev-java/swt:4.27
+"
+
+# Due to removal of AENameServiceDescriptor it would fail to start under jdk:1.8
+# StartServer ERROR: unable to bind to 127.0.0.1:6880 listening for passed torrent info: \
+# sun.net.spi.nameservice.NameServiceDescriptor: Provider com.biglybt.core.util.spi.AENameServiceDescriptor not found
+# Restricting to jdk:11 for https://bugs.gentoo.org/888859
+DEPEND="${CP_DEPEND}
+ >=virtual/jdk-11:*"
+
+RDEPEND="${CP_DEPEND}
+ >=virtual/jre-1.8:*"
+
+DOCS=(
+ CODING_GUIDELINES.md
+ CONTRIBUTING.md
+ ChangeLog.txt
+ README.md
+ TRANSLATE.md
+)
+
+JAVADOC_SRC_DIRS=( {core,uis}/src )
+
+PATCHES=(
+ "${FILESDIR}/biglybt-3.2.0.0-disable-SWTUpdateChecker.patch"
+ "${FILESDIR}/biglybt-3.2.0.0-disable-shared-plugins.patch"
+ "${FILESDIR}/biglybt-3.5.0.0-Entities.javadoc.patch"
+ "${FILESDIR}/biglybt-3.6.0.0-disable-PluginUpdatePlugin.patch"
+)
+
+src_prepare() {
+ default #780585
+ java-pkg-2_src_prepare
+ # AENameServiceDescriptor fails to compile with jdk >= 11
+ # "error: package sun.net.spi.nameservice does not exist"
+ # https://github.com/BiglySoftware/BiglyBT/pull/2611
+ rm -r core/src/com/biglybt/core/util/spi || die
+# rm -r core/src/META-INF || die
+
+ cp -r core/{src,resources} || die
+ find core/resources -type f -name '*.java' -exec rm -rf {} + || die "deleting classes failed"
+
+ cp -r uis/{src,resources} || die
+ find uis/resources -type f -name '*.java' -exec rm -rf {} + || die "deleting classes failed"
+}
+
+src_compile() {
+ einfo "Compiling module \"core\""
+ JAVA_JAR_FILENAME="${PN}-core.jar"
+ JAVA_RESOURCE_DIRS="core/resources"
+ JAVA_SRC_DIR="core/src"
+ java-pkg-simple_src_compile
+ JAVA_GENTOO_CLASSPATH_EXTRA="${PN}-core.jar"
+
+ einfo "Compiling module \"uis\""
+ JAVA_JAR_FILENAME="BiglyBT.jar"
+ JAVA_LAUNCHER_FILENAME="${PN}"
+ JAVA_MAIN_CLASS="com.${PN}.ui.Main"
+ JAVA_RESOURCE_DIRS="uis/resources"
+ JAVA_SRC_DIR="uis/src"
+ java-pkg-simple_src_compile
+
+ if use doc; then
+ einfo "Creating javadoc"
+ JAVADOC_CLASSPATH="${JAVA_GENTOO_CLASSPATH}"
+ ejavadoc
+ fi
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ make_desktop_entry "${PN}" BiglyBT "${PN}" "Network;FileTransfer"
+
+ if use source; then
+ java-pkg_dosrc "core/src/*"
+ java-pkg_dosrc "uis/src/*"
+ fi
+ default
+}
diff --git a/net-p2p/biglybt/files/biglybt-3.6.0.0-disable-PluginUpdatePlugin.patch b/net-p2p/biglybt/files/biglybt-3.6.0.0-disable-PluginUpdatePlugin.patch
new file mode 100644
index 000000000000..a736a191b129
--- /dev/null
+++ b/net-p2p/biglybt/files/biglybt-3.6.0.0-disable-PluginUpdatePlugin.patch
@@ -0,0 +1,32 @@
+--- a/core/src/com/biglybt/pifimpl/update/PluginUpdatePlugin.java
++++ b/core/src/com/biglybt/pifimpl/update/PluginUpdatePlugin.java
+@@ -99,7 +99,7 @@ PluginUpdatePlugin
+
+ final PluginConfig plugin_config = plugin_interface.getPluginconfig();
+
+- boolean enabled = plugin_config.getPluginBooleanParameter( "enable.update", true );
++ boolean enabled = plugin_config.getPluginBooleanParameter( "enable.update", false );
+
+ model.setConfigSectionID(PLUGIN_CONFIGSECTION_ID);
+ model.getStatus().setText( enabled?"Running":"Optional checks disabled" );
+@@ -130,7 +130,7 @@ PluginUpdatePlugin
+
+ BasicPluginConfigModel config = ui_manager.createBasicPluginConfigModel(ConfigSection.SECTION_PLUGINS, PLUGIN_CONFIGSECTION_ID);
+
+- config.addBooleanParameter2( "enable.update", "Plugin.pluginupdate.enablecheck", true );
++ config.addBooleanParameter2( "enable.update", "Plugin.pluginupdate.enablecheck", false );
+
+ plugin_interface.addEventListener(
+ new PluginEventListener()
+@@ -563,7 +563,7 @@ PluginUpdatePlugin
+ try{
+ if ( (!mandatory) &&
+ (ids_to_check == null ) && // allow custom actions through
+- (!plugin_interface.getPluginconfig().getPluginBooleanParameter( "enable.update", true ))){
++ (!plugin_interface.getPluginconfig().getPluginBooleanParameter( "enable.update", false ))){
+
+ return( num_updates_found );
+ }
+--
+2.44.2
+