summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-01-19 10:00:41 +0000
committerMarek Szuba <marecki@gentoo.org>2023-01-19 10:38:45 +0000
commit2e9def0bf12cf714e5804ee5199bfd597e67199a (patch)
tree57aeaad9d596f43cbfb111f841ef68389b00b1fb /net-p2p
parentprofiles: add riscv-linux to arches.desc (diff)
downloadgentoo-2e9def0bf12cf714e5804ee5199bfd597e67199a.tar.gz
gentoo-2e9def0bf12cf714e5804ee5199bfd597e67199a.tar.bz2
gentoo-2e9def0bf12cf714e5804ee5199bfd597e67199a.zip
net-p2p/syncthing: add 1.23.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/syncthing/Manifest2
-rw-r--r--net-p2p/syncthing/syncthing-1.23.0.ebuild111
2 files changed, 113 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index e97fbacd4aa8..7da9131d05eb 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -2,3 +2,5 @@ DIST syncthing-1.21.0-deps.tar.xz 96707392 BLAKE2B 3cbf6d98758a453f16717ec974cb1
DIST syncthing-1.21.0.tar.gz 6319691 BLAKE2B 390a06ff41ed1b023941d958d8112f9c503c296cc47a5bb6d6baa55d81f6cbd431c725cc6493b041a96734e56c9a267c6a3b4c564b67ab320cd7f9d46e173320 SHA512 ad613da2c3aaa4792703e69dde0ab3ace3a92f20b968a2d7c02d6ec3b6ce2d53a6c3d6b64c41c58ca8296bf722e689cd8ca34c05fd0dd32d8005d31b5f860d58
DIST syncthing-1.22.2-deps.tar.xz 101162440 BLAKE2B 74e846b191ca7aefdaca4784d2c4c3ed3d412695820dff2280c13c8c2c498a746b54210ca3bbc310fbd8693c8dedbab5bf51078ff01e345bd0ced54559b76106 SHA512 b9e23e1d50bc27ffab1e66f08a67b910fa3c869e514f68c17cae73d717f4a0452b93ad7d0a6ec475f4e1055a6d4d85bcd8e7f85692a6088baa96e2af710739c0
DIST syncthing-1.22.2.tar.gz 6339424 BLAKE2B 69a6350a5166af8cd670090b440fb9b932a6d1169fc649588277d90aff305604302bc368b61f542252b06b5212c1c094f720e39c1be6f8375fc7e8f8d2f7bdef SHA512 5b724beb139ec2701222cf77c540cb3f4525db3b1102ccc9ac55829dda668e7fe4b962c7263fbe6bc4efa813d0e783486a7b329f903ded1cef47be585c1e8787
+DIST syncthing-1.23.0-deps.tar.xz 101340488 BLAKE2B 00dc20c5b2aee91bb84a9014ac7ff38828aa8faa396a3567dbb3469409f22566a36bf50a6dc20ddd38803e3f0a1d7229a1e685328cc4a6e4285a808f29f14eb8 SHA512 2fcdc7dd29c75d2f1ee0e385f2d1728021acd32e06f7e48013ba54615b4793ae033e1f05e607925618b095388bb48b78f14561e5866a285a9e7e7659c26caff1
+DIST syncthing-1.23.0.tar.gz 6342650 BLAKE2B 165b7bceb88a5ba8443b1393c50b28c6c4dbc7cdd74383ff7718d5594050703e2f6bd66c41c00cd7bf35fe54ff85c9837fb9f59c578eb71acb588b078faa074d SHA512 b0122923ad3ed4cc50aafe89bb94e13b44998483db0b1df795e05ff17bcbc029a17ed3af187b615154cf88d4c964cb5bdb84e25b6f5548ccf29545b6d2a1cd4f
diff --git a/net-p2p/syncthing/syncthing-1.23.0.ebuild b/net-p2p/syncthing/syncthing-1.23.0.ebuild
new file mode 100644
index 000000000000..31dc10e28ac6
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-1.23.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop go-module systemd xdg-utils
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~x86"
+IUSE="selinux tools"
+
+RDEPEND="acct-group/syncthing
+ acct-user/syncthing
+ tools? ( >=acct-user/stdiscosrv-1
+ >=acct-user/strelaysrv-1 )
+ selinux? ( sec-policy/selinux-syncthing )"
+
+DOCS=( README.md AUTHORS CONTRIBUTING.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
+ "${FILESDIR}"/${PN}-1.18.4-tool_users.patch
+)
+
+src_prepare() {
+ # Bug #679280
+ xdg_environment_reset
+
+ default
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/stdiscosrv|' \
+ cmd/stdiscosrv/etc/linux-systemd/stdiscosrv.service \
+ || die
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
+ cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
+ || die
+
+ # We do not need this and it sometimes causes build failures
+ rm -rf cmd/stupgrades
+}
+
+src_compile() {
+ GOARCH= go run build.go -version "v${PV}" -no-upgrade -build-out=bin/ \
+ ${GOARCH:+-goarch="${GOARCH}"} \
+ build $(usex tools "all" "") || die "build failed"
+}
+
+src_test() {
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ local icon_size
+
+ doman man/*.[157]
+ einstalldocs
+
+ dobin bin/syncthing
+
+ domenu etc/linux-desktop/*.desktop
+ for icon_size in 32 64 128 256 512; do
+ newicon -s ${icon_size} assets/logo-${icon_size}.png ${PN}.png
+ done
+ newicon -s scalable assets/logo-only.svg ${PN}.svg
+
+ if use tools; then
+ exeinto /usr/libexec/syncthing
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
+ done
+ fi
+
+ systemd_dounit etc/linux-systemd/system/${PN}{@,-resume}.service
+ systemd_douserunit etc/linux-systemd/user/${PN}.service
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd-r2 ${PN}
+
+ keepdir /var/log/${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ if use tools; then
+ systemd_dounit cmd/stdiscosrv/etc/linux-systemd/stdiscosrv.service
+ newconfd "${FILESDIR}"/stdiscosrv.confd stdiscosrv
+ newinitd "${FILESDIR}"/stdiscosrv.initd-r1 stdiscosrv
+
+ systemd_dounit cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
+ newconfd "${FILESDIR}"/strelaysrv.confd strelaysrv
+ newinitd "${FILESDIR}"/strelaysrv.initd-r1 strelaysrv
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/stdiscosrv.logrotate strelaysrv
+ newins "${FILESDIR}"/strelaysrv.logrotate strelaysrv
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}