summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /net-p2p
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild3
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.17.1.ebuild1
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.18.0.ebuild1
-rw-r--r--net-p2p/bitcoind/bitcoind-0.16.3.ebuild3
-rw-r--r--net-p2p/bitcoind/bitcoind-0.17.1.ebuild1
-rw-r--r--net-p2p/bitcoind/bitcoind-0.18.0.ebuild1
-rw-r--r--net-p2p/bittornado/bittornado-0.4.1_p20160925-r1.ebuild1
-rw-r--r--net-p2p/classified-ads/classified-ads-0.11.ebuild3
-rw-r--r--net-p2p/classified-ads/classified-ads-0.12.ebuild3
-rw-r--r--net-p2p/classified-ads/classified-ads-0.13.ebuild3
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild3
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.7.ebuild3
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.8.ebuild1
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6-r1.ebuild1
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild1
15 files changed, 22 insertions, 7 deletions
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild
index 20571065eed0..e6d5e30a9323 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2010-2018 Gentoo Authors
+# Copyright 2010-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,6 +22,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc x86 ~amd64-linux ~x86-linux"
IUSE="+asm +bip70 +bitcoin_policy_rbf dbus kde +libevent knots libressl +qrcode test upnp +wallet zeromq"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/boost-1.52.0:=[threads(+)]
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.17.1.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.17.1.ebuild
index f13ca6f859b7..28c1e57132f0 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.17.1.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.17.1.ebuild
@@ -22,6 +22,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+asm +bip70 +bitcoin_policy_rbf dbus kde knots libressl +qrcode +system-leveldb test upnp +wallet zeromq"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/boost-1.52.0:=[threads(+)]
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.18.0.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.18.0.ebuild
index f682896336f2..0aa8b5e10796 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.18.0.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.18.0.ebuild
@@ -22,6 +22,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+asm +bip70 +bitcoin_policy_rbf dbus kde knots libressl +qrcode +system-leveldb test upnp +wallet zeromq"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/boost-1.52.0:=[threads(+)]
diff --git a/net-p2p/bitcoind/bitcoind-0.16.3.ebuild b/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
index 2d55b6d0cf6c..9147db4d3e08 100644
--- a/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2010-2018 Gentoo Authors
+# Copyright 2010-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,6 +21,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc x86 ~amd64-linux ~x86-linux"
IUSE="+asm +bitcoin_policy_rbf examples knots libressl test upnp +wallet zeromq"
+RESTRICT="!test? ( test )"
DEPEND="
>=dev-libs/boost-1.52.0:=[threads(+)]
diff --git a/net-p2p/bitcoind/bitcoind-0.17.1.ebuild b/net-p2p/bitcoind/bitcoind-0.17.1.ebuild
index f37df43a5244..2f1df22dec83 100644
--- a/net-p2p/bitcoind/bitcoind-0.17.1.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.17.1.ebuild
@@ -21,6 +21,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+asm +bitcoin_policy_rbf examples knots libressl +system-leveldb test upnp +wallet zeromq"
+RESTRICT="!test? ( test )"
DEPEND="
>=dev-libs/boost-1.52.0:=[threads(+)]
diff --git a/net-p2p/bitcoind/bitcoind-0.18.0.ebuild b/net-p2p/bitcoind/bitcoind-0.18.0.ebuild
index 813f80934912..d758ec041969 100644
--- a/net-p2p/bitcoind/bitcoind-0.18.0.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.18.0.ebuild
@@ -21,6 +21,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+asm +bitcoin_policy_rbf examples knots libressl +system-leveldb test upnp +wallet zeromq"
+RESTRICT="!test? ( test )"
DEPEND="
>=dev-libs/boost-1.52.0:=[threads(+)]
diff --git a/net-p2p/bittornado/bittornado-0.4.1_p20160925-r1.ebuild b/net-p2p/bittornado/bittornado-0.4.1_p20160925-r1.ebuild
index 9b2dcca61fdc..b364a4eed64d 100644
--- a/net-p2p/bittornado/bittornado-0.4.1_p20160925-r1.ebuild
+++ b/net-p2p/bittornado/bittornado-0.4.1_p20160925-r1.ebuild
@@ -20,6 +20,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
|| (
diff --git a/net-p2p/classified-ads/classified-ads-0.11.ebuild b/net-p2p/classified-ads/classified-ads-0.11.ebuild
index 295a08b90280..6db06105c774 100644
--- a/net-p2p/classified-ads/classified-ads-0.11.ebuild
+++ b/net-p2p/classified-ads/classified-ads-0.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,6 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/openssl:0
>=net-libs/libnatpmp-20130911
diff --git a/net-p2p/classified-ads/classified-ads-0.12.ebuild b/net-p2p/classified-ads/classified-ads-0.12.ebuild
index 083c75d23ab6..097ecec21e57 100644
--- a/net-p2p/classified-ads/classified-ads-0.12.ebuild
+++ b/net-p2p/classified-ads/classified-ads-0.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,6 +18,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/openssl:0
>=net-libs/libnatpmp-20130911
diff --git a/net-p2p/classified-ads/classified-ads-0.13.ebuild b/net-p2p/classified-ads/classified-ads-0.13.ebuild
index ecb91cfc86f0..14e24e219fb6 100644
--- a/net-p2p/classified-ads/classified-ads-0.13.ebuild
+++ b/net-p2p/classified-ads/classified-ads-0.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,6 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="app-arch/bzip2
dev-lang/tcl:=
diff --git a/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild b/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild
index 7ca9f998eb11..d399917e251f 100644
--- a/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="daemon debug selinux test xmlrpc"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
>=dev-libs/libsigc++-2.2.2:2
diff --git a/net-p2p/rtorrent/rtorrent-0.9.7.ebuild b/net-p2p/rtorrent/rtorrent-0.9.7.ebuild
index 4a6d9d7c3572..065a33969032 100644
--- a/net-p2p/rtorrent/rtorrent-0.9.7.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.9.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="daemon debug selinux test xmlrpc"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
>=dev-libs/libsigc++-2.2.2:2
diff --git a/net-p2p/rtorrent/rtorrent-0.9.8.ebuild b/net-p2p/rtorrent/rtorrent-0.9.8.ebuild
index bce8766397aa..3567aac75ea3 100644
--- a/net-p2p/rtorrent/rtorrent-0.9.8.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.9.8.ebuild
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="daemon debug selinux test xmlrpc"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
>=net-misc/curl-7.19.1
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6-r1.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6-r1.ebuild
index e98af8499989..4b8f21ae7e10 100644
--- a/net-p2p/torrentinfo/torrentinfo-1.8.6-r1.ebuild
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6-r1.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
index 0863b06ad861..a556d16e24e2 100644
--- a/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]