summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-12-19 18:34:36 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-12-19 18:34:36 +0300
commit6cffbbd700b7a8605f34281c0ef3c7bd31065ca9 (patch)
tree88464e3f1e1397c33db9b4c2d869428410fe07e4 /net-p2p/qbittorrent
parentmedia-sound/mpd: Version bump (v0.21.17) (diff)
downloadgentoo-6cffbbd700b7a8605f34281c0ef3c7bd31065ca9.tar.gz
gentoo-6cffbbd700b7a8605f34281c0ef3c7bd31065ca9.tar.bz2
gentoo-6cffbbd700b7a8605f34281c0ef3c7bd31065ca9.zip
net-p2p/qbittorrent: Version bump (v4.2.1)
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.2.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index ce6e51f656fb..0b6d201fa527 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -2,3 +2,4 @@ DIST qbittorrent-4.1.7.tar.gz 7803389 BLAKE2B 6a8cf01c2bd86b63b629877fd3446db4ae
DIST qbittorrent-4.1.8.tar.gz 7803739 BLAKE2B ee56e004945025f06b179b08e938c6a3182f252c3bed6990158634ea1fdfd525fd67d105fd7ecdf0217a4bd73d847c5007d1e95f492f4f4e41c32d22dd6b7523 SHA512 8920e98f8db5dd738caab8815cc4a10950c34ba2eaa19b50479bb2ab548f6f297534759d71791caa4c8bfbea92d4b71d223a27fae150e00cc0a262eb3370a1e3
DIST qbittorrent-4.1.9.1.tar.gz 7804066 BLAKE2B b5fddfdef8773318991ee5a3a818101b46fd0f258c24eebe2a9dde3f9e806544159c373406f609a911b330e32257b3d58a7d81e830ed91cce205182cde16052a SHA512 2a132202762461293ee8e4248bf7d512b3c33ec73670bf4c5c22261be546a69a69775b6c4baacd97a3f9055145cdb4153de17704b6b574b33370f3b454b1def9
DIST qbittorrent-4.2.0.tar.gz 7797615 BLAKE2B 55c891e9d255c295eb2dc53e3cccaa50ceeae6623ddc016bf5e30fb117b849f35def462bbee598e754a2672e771465b93fa751b047efeb6326e8bc2619a58cb4 SHA512 507e548ea7b5ee25e412bdca6751e3e1b65130f16bbb2c92bd8f80cb86d824bfdcdf40ec49af6a8e111a36d7970430e8b9a6e29a6af1165563c9cb16c4bc2741
+DIST qbittorrent-4.2.1.tar.gz 7824636 BLAKE2B 06aa493b4e59f8e064955c604846cd4e4d404988819aa4f0b7a555cd3d8c74f42d4b40b581bc5c2360e5b75f0ce33f77882051360453176a9540d03d4d5de82d SHA512 345c702a49d284fe28b45e52719a79195a784ba07339ea49c340d10d387482d3ba59335b2e41616de97e3813531e808c41239e597ef4b710fcebceb0c837483c
diff --git a/net-p2p/qbittorrent/qbittorrent-4.2.1.ebuild b/net-p2p/qbittorrent/qbittorrent-4.2.1.ebuild
new file mode 100644
index 000000000000..22b2a5ad4a47
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.2.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5(+),X?]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.2.0:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}