summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-08-22 12:06:43 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-08-22 12:08:12 -0400
commitea5f26b45f442d0f9900bb78c94fae8b28bcafe6 (patch)
tree73f52edb95555dd6c96c1252f4f47b2b72fbb2df /net-p2p/litecoind
parentnet-p2p/litecoin-qt: restrict version of leveldb. (diff)
downloadgentoo-ea5f26b45f442d0f9900bb78c94fae8b28bcafe6.tar.gz
gentoo-ea5f26b45f442d0f9900bb78c94fae8b28bcafe6.tar.bz2
gentoo-ea5f26b45f442d0f9900bb78c94fae8b28bcafe6.zip
net-p2p/litecoind: remove older unstable version.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-p2p/litecoind')
-rw-r--r--net-p2p/litecoind/Manifest1
-rw-r--r--net-p2p/litecoind/litecoind-0.8.7.4.ebuild123
2 files changed, 0 insertions, 124 deletions
diff --git a/net-p2p/litecoind/Manifest b/net-p2p/litecoind/Manifest
index 1ead5112eb41..992235cce43b 100644
--- a/net-p2p/litecoind/Manifest
+++ b/net-p2p/litecoind/Manifest
@@ -1,2 +1 @@
DIST litecoin-0.10.2.2.tar.gz 4700783 SHA256 952c84b181323db17a8fa23217f59b576ad3ebad92c158b3a7c29d458a1130dc SHA512 46e4c014ae8527dd58af073bab96ea4fd55c69fcc63eaa4fd600bf3c1fc2102500151b49431a72b55334a409d4f5226937cd0c5337feaa4ad49e6ef9e9728aba WHIRLPOOL 5c1d5605d4afb16744fcf0b09dd52eb574aea0cdd9754f94d4cfd9ac064491a0e192d8c4b1a3324e355d71758735265b272dfa41f938212e17badb9f8a70698b
-DIST litecoin-0.8.7.4.tar.gz 4808429 SHA256 032d1eb2ffb06ce467f514e08a66f42bcd507df2d8f1cf2c0541f2906288931a SHA512 14588dab6450bee439c3af16e277afc1f2ff562c93463d9767da27cf724cd6bb4a1c64100806d61dc1d062a39f440e4878e19b425f29e866562acc56c893cca5 WHIRLPOOL 1329d7c234c75b5083f58f5edf69b6ea9acc13f48a9734cd839001dcd3e52c10d3ade55ac853e196deca8b149aba00a3590e52cf766f62b941bd4e4828f10b96
diff --git a/net-p2p/litecoind/litecoind-0.8.7.4.ebuild b/net-p2p/litecoind/litecoind-0.8.7.4.ebuild
deleted file mode 100644
index 26d0a7f2dfef..000000000000
--- a/net-p2p/litecoind/litecoind-0.8.7.4.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-DB_VER="4.8"
-
-inherit bash-completion-r1 db-use eutils systemd user
-
-MyPV="${PV/_/-}"
-MyPN="litecoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="P2P Internet currency based on Bitcoin but easier to mine"
-HOMEPAGE="https://litecoin.org/"
-SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyP}.tar.gz"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples ipv6 logrotate upnp"
-
-RDEPEND="
- dev-libs/boost[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? (
- app-admin/logrotate
- )
- upnp? (
- net-libs/miniupnpc
- )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.12.0[-snappy]
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
- sys-apps/sed
-"
-
-S="${WORKDIR}/${MyP}"
-
-pkg_setup() {
- local UG='litecoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/litecoin "${UG}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${MyPN}-sys_leveldb.patch
- rm -r src/leveldb
-
- if has_version '>=dev-libs/boost-1.52'; then
- sed -i 's/\(-l db_cxx\)/-l boost_chrono$(BOOST_LIB_SUFFIX) \1/' src/makefile.unix
- fi
-}
-
-src_configure() {
- OPTS=()
-
- OPTS+=("DEBUGFLAGS=")
- OPTS+=("CXXFLAGS=${CXXFLAGS}")
- OPTS+=("LDFLAGS=${LDFLAGS}")
-
- if use upnp; then
- OPTS+=("USE_UPNP=1")
- else
- OPTS+=("USE_UPNP=-")
- fi
-
- use ipv6 || OPTS+=("USE_IPV6=-")
-
- OPTS+=("USE_SYSTEM_LEVELDB=1")
- OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
- OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
-
- cd src || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
-}
-
-#Tests are broken with and without our litecoin-sys_leveldb.patch.
-#When tests work, make sure to inherit toolchain-funcs
-#src_test() {
-# cd src || die
-# emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_litecoin
-# ./test_litecoin || die 'Tests failed'
-#}
-
-src_install() {
- dobin src/${PN}
-
- insinto /etc/litecoin
- doins "${FILESDIR}/litecoin.conf"
- fowners litecoin:litecoin /etc/litecoin/litecoin.conf
- fperms 600 /etc/litecoin/litecoin.conf
-
- newconfd "${FILESDIR}/litecoin.confd" ${PN}
- newinitd "${FILESDIR}/litecoin.initd-r1" ${PN}
- systemd_dounit "${FILESDIR}/litecoin.service"
-
- keepdir /var/lib/litecoin/.litecoin
- fperms 700 /var/lib/litecoin
- fowners litecoin:litecoin /var/lib/litecoin/
- fowners litecoin:litecoin /var/lib/litecoin/.litecoin
- dosym /etc/litecoin/litecoin.conf /var/lib/litecoin/.litecoin/litecoin.conf
-
- dodoc doc/README.md doc/release-notes.md
- newman contrib/debian/manpages/bitcoind.1 litecoind.1
- newman contrib/debian/manpages/bitcoin.conf.5 litecoin.conf.5
-
- sed -i -e 's/bitcoin/litecoin/g' contrib/bitcoind.bash-completion
- newbashcomp contrib/bitcoind.bash-completion ${PN}.bash-completion
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,spendfrom,tidy_datadir.sh,wallettools}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/litecoind.logrotate" litecoind
- fi
-}