summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber+gentoo@sysrq.in>2021-09-09 14:20:24 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-09-09 14:24:42 +0300
commitad8caec2d7ff6a6a6c2e02b0bea68b4af39e3dbb (patch)
treeea8e16e1a0212022e67712a188bad805260cc035 /net-nntp/slrn/slrn-1.0.3-r1.ebuild
parentnet-libs/canlock: add 3.2.2 (diff)
downloadgentoo-ad8caec2d7ff6a6a6c2e02b0bea68b4af39e3dbb.tar.gz
gentoo-ad8caec2d7ff6a6a6c2e02b0bea68b4af39e3dbb.tar.bz2
gentoo-ad8caec2d7ff6a6a6c2e02b0bea68b4af39e3dbb.zip
net-nntp/slrn: revbump to support canlock v3.x
canlock v2 is still supported by this ebuild EAPI 7 -> 8 Signed-off-by: Anna Vyalkova <cyber+gentoo@sysrq.in> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-nntp/slrn/slrn-1.0.3-r1.ebuild')
-rw-r--r--net-nntp/slrn/slrn-1.0.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-nntp/slrn/slrn-1.0.3-r1.ebuild b/net-nntp/slrn/slrn-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..ea2f93eec04e
--- /dev/null
+++ b/net-nntp/slrn/slrn-1.0.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${P}a"
+
+DESCRIPTION="A s-lang based newsreader"
+HOMEPAGE="http://slrn.sourceforge.net/"
+SRC_URI="https://jedsoft.org/releases/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="canlock nls ssl uudeview"
+
+RDEPEND="app-arch/sharutils
+ >=sys-libs/slang-2.2.3
+ virtual/mta
+ canlock? ( net-libs/canlock:=[legacy(+)] )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+ uudeview? ( dev-libs/uulib )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.2-make.patch )
+
+src_configure() {
+ econf \
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --with-slrnpull \
+ $(use_with canlock canlock /usr) \
+ $(use_enable nls) \
+ $(use_with ssl) \
+ $(use_with uudeview uu)
+}