summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gnome.org>2024-01-30 22:36:29 +0400
committerSam James <sam@gentoo.org>2024-01-30 19:28:04 +0000
commit9c2d8289bdc0fec7d870d0c28f4e6aef0c1255ff (patch)
treef7e0648ef835ce4814af8bc982c08a9a498188f9 /net-news/liferea
parentx11-misc/copyq: fix plugin dir envvar patch (diff)
downloadgentoo-9c2d8289bdc0fec7d870d0c28f4e6aef0c1255ff.tar.gz
gentoo-9c2d8289bdc0fec7d870d0c28f4e6aef0c1255ff.tar.bz2
gentoo-9c2d8289bdc0fec7d870d0c28f4e6aef0c1255ff.zip
net-news/liferea: fix build with libxml2-2.12
Closes: https://bugs.gentoo.org/923304 See-Also: https://github.com/lwindolf/liferea/pull/1329 Signed-off-by: Yuri Konotopov <ykonotopov@gnome.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-news/liferea')
-rw-r--r--net-news/liferea/files/liferea-1.15.5-libxml2.patch28
-rw-r--r--net-news/liferea/liferea-1.15.5-r1.ebuild73
2 files changed, 101 insertions, 0 deletions
diff --git a/net-news/liferea/files/liferea-1.15.5-libxml2.patch b/net-news/liferea/files/liferea-1.15.5-libxml2.patch
new file mode 100644
index 000000000000..abe1fb137669
--- /dev/null
+++ b/net-news/liferea/files/liferea-1.15.5-libxml2.patch
@@ -0,0 +1,28 @@
+From be8ef494586d9ef73c04ec4ca058a9a158ae3562 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Sun, 31 Dec 2023 22:26:31 +0000
+Subject: [PATCH] src/node_type.h: add `#include <libxml/tree.h>` for
+ `xmlNodePtr` type
+
+Without the change build fails on `libxml2-2.12.3` as:
+
+ ../../src/node_type.h:62:64: error: unknown type name 'xmlNodePtr'; did you mean 'nodePtr'?
+ 62 | void (*export) (nodePtr node, xmlNodePtr cur, gboolean trusted);
+ | ^~~~~~~~~~
+ | nodePtr
+---
+ src/node_type.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/node_type.h b/src/node_type.h
+index fcd3e7223..a41ff52fc 100644
+--- a/src/node_type.h
++++ b/src/node_type.h
+@@ -23,6 +23,7 @@
+
+ #include "node.h"
+
++#include <libxml/tree.h>
+ #include <libxml/xmlmemory.h>
+ #include <gtk/gtk.h>
+
diff --git a/net-news/liferea/liferea-1.15.5-r1.ebuild b/net-news/liferea/liferea-1.15.5-r1.ebuild
new file mode 100644
index 000000000000..8d08ccd2633b
--- /dev/null
+++ b/net-news/liferea/liferea-1.15.5-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools gnome2-utils optfeature python-single-r1 xdg
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo feeds"
+HOMEPAGE="https://lzone.de/liferea/"
+SRC_URI="https://github.com/lwindolf/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-db/sqlite:3
+ dev-libs/fribidi
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-libs/json-glib
+ dev-libs/libpeas:0[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ gnome-base/gsettings-desktop-schemas
+ net-libs/libsoup:3.0
+ net-libs/webkit-gtk:4.1=
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-libxml2.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_compile() {
+ # Workaround crash in libwebkit2gtk-4.0.so
+ # https://bugs.gentoo.org/704594
+ WEBKIT_DISABLE_COMPOSITING_MODE=1 \
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ optfeature "Libsecret Support plugin" app-crypt/libsecret[introspection]
+ optfeature "Tray Icon (AppIndicator and GNOME Classic) plugin" \
+ "dev-libs/libayatana-appindicator dev-python/pycairo x11-libs/gdk-pixbuf[introspection]"
+ optfeature "Media Player plugin" media-libs/gstreamer[introspection]
+ optfeature "monitoring network status" net-misc/networkmanager
+ optfeature "Popup Notifications plugin" x11-libs/libnotify[introspection]
+}