summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-17 19:00:23 -0400
committerSam James <sam@gentoo.org>2024-03-18 05:29:51 +0000
commite8bd24dd0c50c65f5b343afaeab04cfeb4183ab2 (patch)
treeea122112d7ac25a10e48b4b0f5c45b8744ed468a /net-misc
parentgames-util/wit: add 3.05a (diff)
downloadgentoo-e8bd24dd0c50c65f5b343afaeab04cfeb4183ab2.tar.gz
gentoo-e8bd24dd0c50c65f5b343afaeab04cfeb4183ab2.tar.bz2
gentoo-e8bd24dd0c50c65f5b343afaeab04cfeb4183ab2.zip
net-misc/omnisync: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/861683 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/omnisync/omnisync-1.0_p20200130.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-misc/omnisync/omnisync-1.0_p20200130.ebuild b/net-misc/omnisync/omnisync-1.0_p20200130.ebuild
index c0a9f2f3dae6..13ad5096ab1c 100644
--- a/net-misc/omnisync/omnisync-1.0_p20200130.ebuild
+++ b/net-misc/omnisync/omnisync-1.0_p20200130.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake vcs-snapshot
+inherit cmake flag-o-matic vcs-snapshot
SNAPSHOT="c55215330b1e8a61af6d34d57d3d8236c8cc7d5b"
@@ -20,6 +20,15 @@ RDEPEND="net-libs/gnutls:= net-analyzer/net-snmp:="
DEPEND="${RDEPEND}"
DOCS=( readme.txt Changes )
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/861683
+ # appears to be terminally dead
+ filter-lto
+
+ cmake_src_configure
+}
+
src_install() {
cmake_src_install
newinitd "${FILESDIR}/${PN}.initd" ${PN}