summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2019-08-28 21:54:38 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-08-28 21:55:19 -0700
commite59d3db09e943fd24403d4313d76c8f586a55b07 (patch)
tree56d6372400c4a46ffbd5bcbdc0d3f1ec8fa82b4f /net-misc
parentgames-rpg/eternal-lands-{bloodsucker,data}: last rites (diff)
downloadgentoo-e59d3db09e943fd24403d4313d76c8f586a55b07.tar.gz
gentoo-e59d3db09e943fd24403d4313d76c8f586a55b07.tar.bz2
gentoo-e59d3db09e943fd24403d4313d76c8f586a55b07.zip
net-misc/AQtion: New package
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/AQtion/AQtion-2.2.7.ebuild49
-rw-r--r--net-misc/AQtion/Manifest1
-rw-r--r--net-misc/AQtion/metadata.xml24
3 files changed, 74 insertions, 0 deletions
diff --git a/net-misc/AQtion/AQtion-2.2.7.ebuild b/net-misc/AQtion/AQtion-2.2.7.ebuild
new file mode 100644
index 000000000000..157bb239defb
--- /dev/null
+++ b/net-misc/AQtion/AQtion-2.2.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+DESCRIPTION="Aquantia AQC multigigabit NIC linux driver (atlantic) - development preview"
+HOMEPAGE="https://github.com/Aquantia/AQtion"
+
+COMMIT_ID="e024a859ea828ced78db310328db90dbedea837a"
+SRC_URI="https://github.com/Aquantia/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="lro"
+
+DEPEND="virtual/linux-sources"
+
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+MODULE_NAMES="atlantic(drivers/net/ethernet/aquantia/atlantic:${S})"
+BUILD_TARGETS="all"
+CONFIG_CHECK="~!AQTION ~PTP_1588_CLOCK ~CRC_ITU_T"
+
+DOCS=(
+ README.md
+ README.txt
+)
+
+pkg_setup() {
+ use lro && CONFIG_CHECK+=" ~!CONFIG_BRIDGE"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if ! use lro; then
+ sed -r -i -e 's/(#define AQ_CFG_IS_LRO_DEF[[:space:]]+)[[:digit:]]+([[:alpha:]]*)/\10\2/' \
+ aq_cfg.h || die
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc "${DOCS[@]}"
+}
diff --git a/net-misc/AQtion/Manifest b/net-misc/AQtion/Manifest
new file mode 100644
index 000000000000..78d41b07f85b
--- /dev/null
+++ b/net-misc/AQtion/Manifest
@@ -0,0 +1 @@
+DIST AQtion-2.2.7.tar.gz 122679 BLAKE2B 9d4e2d4d4b26a191551e2cfd30c2a8ce4e4bde01b7ab1e9beb9564abdfd1093b63f94713570fe2c949943037b649c55a9f448b0333fcdcc7227849330d466f92 SHA512 d3ba78acbe5d85d1017d5460fa7d916ffa59eeb137aa1817da215f08b994a10336a9f865c9b84a16b8cef7238d4fd87785bc17d6e3eac577210bf321538cbda3
diff --git a/net-misc/AQtion/metadata.xml b/net-misc/AQtion/metadata.xml
new file mode 100644
index 000000000000..62085b44d7b0
--- /dev/null
+++ b/net-misc/AQtion/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Aquantia/AQtion</remote-id>
+ </upstream>
+ <use>
+ <flag name="lro">
+ Enable/disable Large Receive Offload. This MUST be disabled for
+ bridging or forwarding.
+ </flag>
+ </use>
+ <longdescription>
+ Latest development preview of aquantia's atlantic linux kernel
+ driver for AQtion family of multigigabit adapters.
+
+ These drivers are UNSUPPORTED by the vendor, use at your own
+ risk.
+ </longdescription>
+</pkgmetadata>