summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-08-06 00:43:47 +0300
committerStefan Strogin <steils@gentoo.org>2020-08-06 00:47:12 +0300
commitbf87bbf6fb6364de9da61a716c3c5535968766bf (patch)
tree0676c5468cc9b3c9cc5a09b92c94944479b5c7d9 /net-misc
parentsys-fs/udev: fix indentation (diff)
downloadgentoo-bf87bbf6fb6364de9da61a716c3c5535968766bf.tar.gz
gentoo-bf87bbf6fb6364de9da61a716c3c5535968766bf.tar.bz2
gentoo-bf87bbf6fb6364de9da61a716c3c5535968766bf.zip
net-misc/curl: fix USE=libressl logic, remove it from REQUIRED_USE
USE=libressl must not be mutually exclusive to USE=openssl or any other USE flag. Also USE=openssl must be enabled when using USE=libressl, so that dependencies are checked correctly. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/curl-7.71.1-r1.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/net-misc/curl/curl-7.71.1-r1.ebuild b/net-misc/curl/curl-7.71.1-r1.ebuild
index 5b747bdf2ceb..628e487a4f18 100644
--- a/net-misc/curl/curl-7.71.1-r1.ebuild
+++ b/net-misc/curl/curl-7.71.1-r1.ebuild
@@ -29,15 +29,13 @@ RDEPEND="ldap? ( net-nds/openldap[${MULTILIB_USEDEP}] )
dev-libs/nettle:0=[${MULTILIB_USEDEP}]
app-misc/ca-certificates
)
- libressl? (
- dev-libs/libressl:0=[static-libs?,${MULTILIB_USEDEP}]
- )
mbedtls? (
net-libs/mbedtls:0=[${MULTILIB_USEDEP}]
app-misc/ca-certificates
)
openssl? (
- dev-libs/openssl:0=[static-libs?,${MULTILIB_USEDEP}]
+ !libressl? ( dev-libs/openssl:0=[static-libs?,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[static-libs?,${MULTILIB_USEDEP}] )
)
nss? (
dev-libs/nss:0[${MULTILIB_USEDEP}]
@@ -76,13 +74,11 @@ BDEPEND="virtual/pkgconfig
)"
# c-ares must be disabled for threads
-# only one of libressl or openssl can be enabled
# only one default ssl provider can be enabled
REQUIRED_USE="
winssl? ( elibc_Winnt )
threads? ( !adns )
ssl? (
- libressl? ( !openssl )
^^ (
curl_ssl_gnutls
curl_ssl_libressl
@@ -131,10 +127,6 @@ multilib_src_configure() {
einfo "SSL provided by gnutls"
myconf+=( --with-gnutls --with-nettle )
fi
- if use libressl || use curl_ssl_libressl; then
- einfo "SSL provided by LibreSSL"
- myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
- fi
if use mbedtls || use curl_ssl_mbedtls; then
einfo "SSL provided by mbedtls"
myconf+=( --with-mbedtls )
@@ -143,7 +135,7 @@ multilib_src_configure() {
einfo "SSL provided by nss"
myconf+=( --with-nss )
fi
- if use openssl || use curl_ssl_openssl; then
+ if use openssl || use curl_ssl_openssl || use curl_ssl_libressl; then
einfo "SSL provided by openssl"
myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
fi