summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-10 05:18:50 +0100
committerSam James <sam@gentoo.org>2023-10-10 05:18:50 +0100
commitbc14f573bbad57c04aa01420fdb439e49e0c065f (patch)
treeadfd8434929f399693d610eeb3f9eaec74a8ae35 /net-misc
parentnet-misc/curl: Stabilize 8.2.1 arm64, #913543 (diff)
downloadgentoo-bc14f573bbad57c04aa01420fdb439e49e0c065f.tar.gz
gentoo-bc14f573bbad57c04aa01420fdb439e49e0c065f.tar.bz2
gentoo-bc14f573bbad57c04aa01420fdb439e49e0c065f.zip
net-misc/curl: reduce parallelism for tests
On jiji, with nproc=80, we end up with the runner being very confused and aborting early with 7*$(nproc). just do 2*(nproc) for now to reduce flakiness. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/curl-8.2.1.ebuild5
-rw-r--r--net-misc/curl/curl-8.3.0.ebuild5
-rw-r--r--net-misc/curl/curl-9999.ebuild5
3 files changed, 9 insertions, 6 deletions
diff --git a/net-misc/curl/curl-8.2.1.ebuild b/net-misc/curl/curl-8.2.1.ebuild
index 0a5bcacf533f..8faabb628ae1 100644
--- a/net-misc/curl/curl-8.2.1.ebuild
+++ b/net-misc/curl/curl-8.2.1.ebuild
@@ -338,10 +338,11 @@ multilib_src_test() {
# Note: if needed, we can skip specific tests. See e.g. Fedora's packaging
# or just read https://github.com/curl/curl/tree/master/tests#run.
# Note: we don't run the testsuite for cross-compilation.
- # Upstream recommend 7*nproc as a starting point for parallel tests.
+ # Upstream recommend 7*nproc as a starting point for parallel tests, but
+ # this ends up breaking when nproc is huge (like -j80).
# The network sandbox causes tests 241 and 1083 to fail; these are typically skipped
# as most gentoo users don't have an 'ip6-localhost'
- multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p -j$((7*$(makeopts_jobs))) !241 !1083"
+ multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p -j$((2*$(makeopts_jobs))) !241 !1083"
}
multilib_src_install() {
diff --git a/net-misc/curl/curl-8.3.0.ebuild b/net-misc/curl/curl-8.3.0.ebuild
index 2761514f73e0..6f07f5578572 100644
--- a/net-misc/curl/curl-8.3.0.ebuild
+++ b/net-misc/curl/curl-8.3.0.ebuild
@@ -337,10 +337,11 @@ multilib_src_test() {
# Note: if needed, we can skip specific tests. See e.g. Fedora's packaging
# or just read https://github.com/curl/curl/tree/master/tests#run.
# Note: we don't run the testsuite for cross-compilation.
- # Upstream recommend 7*nproc as a starting point for parallel tests.
+ # Upstream recommend 7*nproc as a starting point for parallel tests, but
+ # this ends up breaking when nproc is huge (like -j80).
# The network sandbox causes tests 241 and 1083 to fail; these are typically skipped
# as most gentoo users don't have an 'ip6-localhost'
- multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p -j$((7*$(makeopts_jobs))) !241 !1083"
+ multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p -j$((2*$(makeopts_jobs))) !241 !1083"
}
multilib_src_install() {
diff --git a/net-misc/curl/curl-9999.ebuild b/net-misc/curl/curl-9999.ebuild
index 2761514f73e0..6f07f5578572 100644
--- a/net-misc/curl/curl-9999.ebuild
+++ b/net-misc/curl/curl-9999.ebuild
@@ -337,10 +337,11 @@ multilib_src_test() {
# Note: if needed, we can skip specific tests. See e.g. Fedora's packaging
# or just read https://github.com/curl/curl/tree/master/tests#run.
# Note: we don't run the testsuite for cross-compilation.
- # Upstream recommend 7*nproc as a starting point for parallel tests.
+ # Upstream recommend 7*nproc as a starting point for parallel tests, but
+ # this ends up breaking when nproc is huge (like -j80).
# The network sandbox causes tests 241 and 1083 to fail; these are typically skipped
# as most gentoo users don't have an 'ip6-localhost'
- multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p -j$((7*$(makeopts_jobs))) !241 !1083"
+ multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p -j$((2*$(makeopts_jobs))) !241 !1083"
}
multilib_src_install() {