summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-02-08 10:43:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-02-08 10:43:45 +0000
commit94ff9f52078f6942cdd3b833f4dc980307ccd698 (patch)
tree530335b6b7804faf5d764acc8a78b7c4762a38e8 /net-misc
parentdev-haskell/derive: remove package and it's app-forensics/quickfuzz revdep (diff)
downloadgentoo-94ff9f52078f6942cdd3b833f4dc980307ccd698.tar.gz
gentoo-94ff9f52078f6942cdd3b833f4dc980307ccd698.tar.bz2
gentoo-94ff9f52078f6942cdd3b833f4dc980307ccd698.zip
net-misc/kafka-bin: Bump
Adds kafka-connect init script Thanks to Julien Surloppe Incorporates most changes from https://github.com/gentoo/gentoo/pull/18224/ Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/kafka-bin/Manifest2
-rw-r--r--net-misc/kafka-bin/files/kafka-connect-distributed.init.d28
-rw-r--r--net-misc/kafka-bin/files/kafka.init.d.528
-rw-r--r--net-misc/kafka-bin/kafka-bin-2.6.1.ebuild71
-rw-r--r--net-misc/kafka-bin/kafka-bin-2.7.0.ebuild71
-rw-r--r--net-misc/kafka-bin/metadata.xml1
6 files changed, 201 insertions, 0 deletions
diff --git a/net-misc/kafka-bin/Manifest b/net-misc/kafka-bin/Manifest
index 002925f4a6fd..3a3894125429 100644
--- a/net-misc/kafka-bin/Manifest
+++ b/net-misc/kafka-bin/Manifest
@@ -7,3 +7,5 @@ DIST kafka_2.12-2.4.1.tgz 62358954 BLAKE2B 333b4a1d34c6249efb9984e90c314f4b39bbd
DIST kafka_2.12-2.5.0.tgz 61604633 BLAKE2B f73f3a03f245aa82b9ce5a895e7875d5ad9c4006b84c3152cac72322eb18283a1a87d81f255160ff062883737ae9862e160fec0d85160ed3a64f45e47b26db53 SHA512 447a7057bcd9faca98b6f4807bd6019ef73eee90efdc1e7b10005f669e2537a8a190cb8b9c9f4c20db1d95b13d0f0487e9cc560d0759532058439ce7f722c7cd
DIST kafka_2.12-2.5.1.tgz 61709988 BLAKE2B 4e6943058fe25da0cc9285e1e8dbe2be2ad2be5ef52d7c12f9007607e34ba1834d192c45e01275e893dca2e8968bdba07510dbd30ccd106e80edaabc0f7c6dba SHA512 91f96f28c016bdaa3fe025f87ace188417a1e594c8e32b7d23a104aa390bc25f5db5897e23cccf00ea7ede3ac20b3028c10363ebe99dcbd7db2cf6237ee7553a
DIST kafka_2.13-2.6.0.tgz 65537909 BLAKE2B 883bc22f53ae7882ff2e27a3b9b62967f4718718f8e2ee222debd5f5b36636e00b35ceb60c3fd6924905b88ef96442439198255bb8329cee1cc722364ff0810f SHA512 d884e4df7d85b4fff54ca9cd987811c58506ad7871b9ed7114bbafa6fee2e79f43d04c550eea471f508b08ea34b4316ea1e529996066fd9b93fcf912f41f6165
+DIST kafka_2.13-2.6.1.tgz 65585925 BLAKE2B 639cc9ec9a3b630d01387b1fe4aa12f5e6ba66b751689d48f17af3759fbfc079616a21534eb72bb647cfee0d14ff86757d73e2ee0733d0f69548efceb90be3e3 SHA512 09ec7a39d0e11494ede7d92cf7dfec5b95c6b0218e3b096b731d85ee8c442469e66aaf369a9c6750399719e515ee1bd372d609d6b232e3358e18aa2b57c90e29
+DIST kafka_2.13-2.7.0.tgz 68583422 BLAKE2B 68925221e025c2f380808da672f9ac08c19c21eaf4d3fe732051e02143dbc735082fce55cd40388b980159bfbe8b06666922852492564927c5fcc237bb3f74dc SHA512 f3dd1fd88766d9150d3d395b285bfa75f5b89a835822381490c8428e6e568889054ddb5fada1eb63613a6441989151bc7c7d6cde16a871c6674b909c4edd4e28
diff --git a/net-misc/kafka-bin/files/kafka-connect-distributed.init.d b/net-misc/kafka-bin/files/kafka-connect-distributed.init.d
new file mode 100644
index 000000000000..0a61c7d017eb
--- /dev/null
+++ b/net-misc/kafka-bin/files/kafka-connect-distributed.init.d
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Kafka Connect of Kafka distributed messaging system"
+
+logfile="/var/log/kafka/connect-distributed.log"
+
+command="/opt/kafka/bin/connect-distributed.sh"
+command_args="/etc/kafka/connect-distributed.properties"
+command_background=yes
+command_user="kafka:kafka"
+
+pidfile=/run/kafka-connect-distributed.pid
+
+start_stop_daemon_args="--stdout $logfile --stderr $logfile
+--env CLASSPATH=\"${CLASSPATH}\"
+--env KAFKA_LOG4J_OPTS=\"${KAFKA_LOG4J_OPTS}\"
+--env KAFKA_OPTS=\"${KAFKA_OPTS}\"
+--env KAFKA_JMX_OPTS=\"${KAFKA_JMX_OPTS}\"
+--env JMX_PORT=\"${JMX_PORT}\"
+--env KAFKA_HEAP_OPTS=\"${KAFKA_HEAP_OPTS}\"
+--env KAFKA_JVM_PERFORMANCE_OPTS=\"${KAFKA_JVM_PERFORMANCE_OPTS}\"
+"
+
+depend() {
+ after kafka
+} \ No newline at end of file
diff --git a/net-misc/kafka-bin/files/kafka.init.d.5 b/net-misc/kafka-bin/files/kafka.init.d.5
new file mode 100644
index 000000000000..3ee2aa9797ee
--- /dev/null
+++ b/net-misc/kafka-bin/files/kafka.init.d.5
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Kafka distributed messaging system"
+
+logfile="/var/log/kafka/kafka.log"
+
+command="/opt/kafka/bin/kafka-server-start.sh"
+command_args="/etc/kafka/server.properties"
+command_background=yes
+command_user="kafka:kafka"
+
+pidfile=/run/kafka.pid
+
+start_stop_daemon_args="--stdout $logfile --stderr $logfile
+--env CLASSPATH=\"${CLASSPATH}\"
+--env KAFKA_LOG4J_OPTS=\"${KAFKA_LOG4J_OPTS}\"
+--env KAFKA_OPTS=\"${KAFKA_OPTS}\"
+--env KAFKA_JMX_OPTS=\"${KAFKA_JMX_OPTS}\"
+--env JMX_PORT=\"${JMX_PORT}\"
+--env KAFKA_HEAP_OPTS=\"${KAFKA_HEAP_OPTS}\"
+--env KAFKA_JVM_PERFORMANCE_OPTS=\"${KAFKA_JVM_PERFORMANCE_OPTS}\"
+"
+
+depend() {
+ after zookeeper kafka-zookeeper
+}
diff --git a/net-misc/kafka-bin/kafka-bin-2.6.1.ebuild b/net-misc/kafka-bin/kafka-bin-2.6.1.ebuild
new file mode 100644
index 000000000000..1e719f68e498
--- /dev/null
+++ b/net-misc/kafka-bin/kafka-bin-2.6.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="A high-throughput distributed messaging system"
+HOMEPAGE="https://kafka.apache.org/"
+
+# pick recommended scala version
+SCALA_VERSION=2.13
+MY_PN="kafka"
+MY_P="${MY_PN}_${SCALA_VERSION}-${PV}"
+SRC_URI="mirror://apache/kafka/${PV}/${MY_P}.tgz"
+
+RESTRICT="mirror"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="internal-zookeeper connect"
+
+COMMON_DEPEND="acct-group/kafka
+ acct-user/kafka
+ virtual/jre:1.8"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+INSTALL_DIR="/opt/${MY_PN}"
+
+src_prepare() {
+ sed -i -e 's:/tmp/zookeeper:/var/lib/kafka/zookeeper:' "config/zookeeper.properties" || die
+ sed -i -e 's:/tmp/kafka-logs:/var/lib/kafka/logs:' "config/server.properties" || die
+ sed -i -e 's:/tmp/connect.offsets:/var/lib/kafka/connect.offsets:' "config/connect-standalone.properties" || die
+ eapply_user
+}
+
+src_install() {
+ insinto /etc/kafka
+ doins config/zookeeper.properties config/server.properties
+ if use "internal-zookeeper"; then
+ keepdir /var/lib/kafka/zookeeper
+ newinitd "${FILESDIR}/${MY_PN}-zookeeper.init.d" "${MY_PN}-zookeeper"
+
+ ewarn "Zookeeper owner has been changed to kafka:kafka"
+ ewarn "you might want to run chown -R kafka:kafka /var/lib/kafka/zookeeper"
+ ewarn "or set COMMAND_USER=\"root:root\" in /etc/conf.d/kafka-zookeeper"
+ ewarn "to keep the previous behavior."
+ ewarn "All logs files have been move to /var/log/kafka/"
+ fi
+
+ if use "connect"; then
+ doins config/connect-distributed.properties config/connect-standalone.properties
+ newinitd "${FILESDIR}/${MY_PN}-connect-distributed.init.d" "${MY_PN}-connect-distributed"
+ fi
+
+ keepdir /var/lib/kafka
+ fowners -R kafka:kafka /var/lib/kafka
+
+ keepdir /var/log/kafka
+ fowners -R kafka:kafka /var/log/kafka
+
+ newinitd "${FILESDIR}/${MY_PN}.init.d.5" "${MY_PN}"
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP bin config libs "${ED}/${INSTALL_DIR}" || die
+ keepdir "${INSTALL_DIR}/logs"
+ fowners -R kafka:kafka "${INSTALL_DIR}"
+}
diff --git a/net-misc/kafka-bin/kafka-bin-2.7.0.ebuild b/net-misc/kafka-bin/kafka-bin-2.7.0.ebuild
new file mode 100644
index 000000000000..1e719f68e498
--- /dev/null
+++ b/net-misc/kafka-bin/kafka-bin-2.7.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="A high-throughput distributed messaging system"
+HOMEPAGE="https://kafka.apache.org/"
+
+# pick recommended scala version
+SCALA_VERSION=2.13
+MY_PN="kafka"
+MY_P="${MY_PN}_${SCALA_VERSION}-${PV}"
+SRC_URI="mirror://apache/kafka/${PV}/${MY_P}.tgz"
+
+RESTRICT="mirror"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="internal-zookeeper connect"
+
+COMMON_DEPEND="acct-group/kafka
+ acct-user/kafka
+ virtual/jre:1.8"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+INSTALL_DIR="/opt/${MY_PN}"
+
+src_prepare() {
+ sed -i -e 's:/tmp/zookeeper:/var/lib/kafka/zookeeper:' "config/zookeeper.properties" || die
+ sed -i -e 's:/tmp/kafka-logs:/var/lib/kafka/logs:' "config/server.properties" || die
+ sed -i -e 's:/tmp/connect.offsets:/var/lib/kafka/connect.offsets:' "config/connect-standalone.properties" || die
+ eapply_user
+}
+
+src_install() {
+ insinto /etc/kafka
+ doins config/zookeeper.properties config/server.properties
+ if use "internal-zookeeper"; then
+ keepdir /var/lib/kafka/zookeeper
+ newinitd "${FILESDIR}/${MY_PN}-zookeeper.init.d" "${MY_PN}-zookeeper"
+
+ ewarn "Zookeeper owner has been changed to kafka:kafka"
+ ewarn "you might want to run chown -R kafka:kafka /var/lib/kafka/zookeeper"
+ ewarn "or set COMMAND_USER=\"root:root\" in /etc/conf.d/kafka-zookeeper"
+ ewarn "to keep the previous behavior."
+ ewarn "All logs files have been move to /var/log/kafka/"
+ fi
+
+ if use "connect"; then
+ doins config/connect-distributed.properties config/connect-standalone.properties
+ newinitd "${FILESDIR}/${MY_PN}-connect-distributed.init.d" "${MY_PN}-connect-distributed"
+ fi
+
+ keepdir /var/lib/kafka
+ fowners -R kafka:kafka /var/lib/kafka
+
+ keepdir /var/log/kafka
+ fowners -R kafka:kafka /var/log/kafka
+
+ newinitd "${FILESDIR}/${MY_PN}.init.d.5" "${MY_PN}"
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP bin config libs "${ED}/${INSTALL_DIR}" || die
+ keepdir "${INSTALL_DIR}/logs"
+ fowners -R kafka:kafka "${INSTALL_DIR}"
+}
diff --git a/net-misc/kafka-bin/metadata.xml b/net-misc/kafka-bin/metadata.xml
index 136eb2b1d753..7be657c43f70 100644
--- a/net-misc/kafka-bin/metadata.xml
+++ b/net-misc/kafka-bin/metadata.xml
@@ -6,5 +6,6 @@
</maintainer>
<use>
<flag name="internal-zookeeper">Use bundled local zookeeper instance</flag>
+ <flag name="connect">Install init for Kafka Connect Distributed mode</flag>
</use>
</pkgmetadata>