summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-11-29 10:57:06 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-11-29 10:57:19 +0100
commit8d949faba62e8cd70888e4aee386a257e958a7d6 (patch)
tree7f1a764ef166a287e07958e7f4e6ef7f32539a77 /net-misc
parentnet-misc/pyhoca-gui: drop old (diff)
downloadgentoo-8d949faba62e8cd70888e4aee386a257e958a7d6.tar.gz
gentoo-8d949faba62e8cd70888e4aee386a257e958a7d6.tar.bz2
gentoo-8d949faba62e8cd70888e4aee386a257e958a7d6.zip
net-misc/pyhoca-gui: 0.5.1.0 bump
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/pyhoca-gui/Manifest1
-rw-r--r--net-misc/pyhoca-gui/pyhoca-gui-0.5.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/pyhoca-gui/Manifest b/net-misc/pyhoca-gui/Manifest
index 7882bd5aa187..3e929f31203d 100644
--- a/net-misc/pyhoca-gui/Manifest
+++ b/net-misc/pyhoca-gui/Manifest
@@ -1 +1,2 @@
DIST pyhoca-gui-0.5.0.8.tar.gz 2064483 BLAKE2B 63bca5be8673ef4e274caf4e0813b73f5dc8af7818b7638b2ac7411bb1598272bab573bc55c6c5e48fc45cc185bad907594b99ee0c96546683ecd8dd1ef1e3f1 SHA512 35bcbe35056d718ec5b58733b8569fd40cd6843a6661cc19deed02287cf65e03b4812fc82bdb0d54b12a78d5547456463e8adf236d4a7f04e11d0d462fe3eded
+DIST pyhoca-gui-0.5.1.0.tar.gz 2098593 BLAKE2B 942caadb43654dbd65cfb50722f17b93b2becd410b90fb888a5133974b66ae377ab568204288e3a72441b74ad3e08a31190d67452a41086802177cc6a8f01406 SHA512 ae4287ccf2aadc4a6557c3bf37d01eb2cdfa542803ece41df02b7b816ba5b0be918231b40dba3c39a850064ae39907befdef1b80180649446b49fc975abbe312
diff --git a/net-misc/pyhoca-gui/pyhoca-gui-0.5.1.0.ebuild b/net-misc/pyhoca-gui/pyhoca-gui-0.5.1.0.ebuild
new file mode 100644
index 000000000000..fe06961e4d65
--- /dev/null
+++ b/net-misc/pyhoca-gui/pyhoca-gui-0.5.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="X2Go graphical client applet"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.6.1.0[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+}