summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-28 12:10:57 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-28 19:01:57 -0400
commit80847bf92f393178bf48a906f31a9786bc8b7bed (patch)
tree5f10e7d6287ce01d9c38f467e89eb8b3407f3bd2 /net-misc
parentnet-mail/nmzmail: bump EAPI (diff)
downloadgentoo-80847bf92f393178bf48a906f31a9786bc8b7bed.tar.gz
gentoo-80847bf92f393178bf48a906f31a9786bc8b7bed.tar.bz2
gentoo-80847bf92f393178bf48a906f31a9786bc8b7bed.zip
net-misc/gofish: bump EAPI and drop eutils
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gofish/gofish-1.2.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-misc/gofish/gofish-1.2.ebuild b/net-misc/gofish/gofish-1.2.ebuild
index 68b0fe7e5df9..64d6f162b85c 100644
--- a/net-misc/gofish/gofish-1.2.ebuild
+++ b/net-misc/gofish/gofish-1.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
+EAPI=6
-inherit eutils user
+inherit user
DESCRIPTION="Gofish gopher server"
HOMEPAGE="http://gofish.sourceforge.net"
@@ -19,6 +19,8 @@ RDEPEND=""
S=${WORKDIR}/${PN}
+DOCS=( AUTHORS ChangeLog Configure_GoFish README TODO )
+
pkg_setup() {
enewgroup gopher
enewuser gopher -1 -1 -1 gopher
@@ -27,14 +29,12 @@ pkg_setup() {
src_configure() {
econf \
--localstatedir=/var \
- --disable-mmap-cache || die
+ --disable-mmap-cache
}
src_install () {
- make DESTDIR="${D}" install || die
-
- newinitd "${FILESDIR}"/gofish.rc gofish || die
- newconfd "${FILESDIR}"/gofish.confd gofish || die
+ default
- dodoc AUTHORS ChangeLog Configure_GoFish README TODO || die
+ newinitd "${FILESDIR}"/gofish.rc gofish
+ newconfd "${FILESDIR}"/gofish.confd gofish
}