summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-12-17 12:47:58 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-12-17 12:47:58 -0500
commit58c9307789b014f2cad84a2f9726e1525fe294d5 (patch)
tree3dde2666eddadaf1d2c091bad21df08f65ec8e46 /net-misc
parentnet-libs/libmicrohttpd: remove older versions (diff)
downloadgentoo-58c9307789b014f2cad84a2f9726e1525fe294d5.tar.gz
gentoo-58c9307789b014f2cad84a2f9726e1525fe294d5.tar.bz2
gentoo-58c9307789b014f2cad84a2f9726e1525fe294d5.zip
net-misc/ipv6calc: version bump to 2.1.1
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ipv6calc/Manifest1
-rw-r--r--net-misc/ipv6calc/ipv6calc-2.1.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/ipv6calc/Manifest b/net-misc/ipv6calc/Manifest
index c3e71c187322..664b6102c536 100644
--- a/net-misc/ipv6calc/Manifest
+++ b/net-misc/ipv6calc/Manifest
@@ -1,2 +1,3 @@
DIST ipv6calc-1.0.0.tar.gz 1342987 BLAKE2B 0c5a28b8431a82669870c475c5a73c239368f3486c9d16e66918a110937ec134d79f9b3ce79edffe65ab2789b36b7ac9ecd90e57f891759ba4542d608bcc5380 SHA512 46e33697551c4bf0a472c7f2dd51c11ae21d49c7d78fe5213bce60c1d11f9230491c328e425f36733c7262a369644bcedb8392ffe2279031eb2552092a5ac209
DIST ipv6calc-2.1.0.tar.gz 1452903 BLAKE2B 52221e0ff08f6cffbf37900a750359b3e89fc7711ec0fc15b1dd974aa06a4e093ca53fb59e8d75e12824c60079bcefd9df5092365a375825fa9e2e583f0af6dd SHA512 b2ff8557a4af99e1d08b617b2d0a20652d23d80fb532104aefe3708c90fd42ed1309dc9697c7f405715140a2efdb460f4915b797fddf4a7966d165e74224695e
+DIST ipv6calc-2.1.1.tar.gz 1453854 BLAKE2B c95f66c2f99cb4953a0c9a8416e294a08d4907e0c5df53616fd0d26c31070ca4727fcb6ebe3d9d84b147d8f24bc69a5c789564ef8e0f5e2fedb1af31a664ed85 SHA512 99dfc87c33c48722d75c98d7a4417b68b23da3d691629ebec65a18992d82a09fd01e55f829f4db4440e0becb746907669cb0bcab4a9ecb477bdcf8ecab675dac
diff --git a/net-misc/ipv6calc/ipv6calc-2.1.1.ebuild b/net-misc/ipv6calc/ipv6calc-2.1.1.ebuild
new file mode 100644
index 000000000000..65630c1080ec
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-2.1.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="https://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="https://github.com/pbiering/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="geoip libressl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl:= )
+ geoip? ( >=dev-libs/geoip-1.4.7 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Digest-SHA1 )
+"
+
+#dev-perl/URI is needed for web interface, that is not installed now
+
+src_configure() {
+ # These options are broken. You can't disable them. That's
+ # okay because we want then force enabled.
+ # --disable-db-as-registry
+ # --disable-db-cc-registry
+ if use geoip; then
+ myconf=$(use_enable geoip)
+ myconf+=" --with-geoip-db=${EPREFIX}/usr/share/GeoIP"
+ fi
+ econf \
+ --disable-bundled-getopt \
+ --disable-bundled-md5 \
+ --enable-shared \
+ --enable-dynamic-load \
+ --enable-db-ieee \
+ --enable-db-ipv4 \
+ --enable-db-ipv6 \
+ --disable-dbip \
+ --disable-dbip2 \
+ --disable-external \
+ --disable-ip2location \
+ ${myconf}
+}
+
+src_compile() {
+ emake distclean
+ # Disable default CFLAGS (-O2 and -g)
+ emake DEFAULT_CFLAGS=""
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ # Disable tests that fail as root
+ echo true > ipv6logstats/test_ipv6logstats.sh
+ fi
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog CREDITS README TODO USAGE
+}