summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-19 12:15:30 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-19 20:16:36 +0200
commit56b9c37e01b51c02eea8e6993b99c137b683b46b (patch)
treeb414da7ab3c948bd3ff4947125cf912f11152e5a /net-misc
parentnet-libs/webkit-gtk: fix ruby check for cross-compilation (diff)
downloadgentoo-56b9c37e01b51c02eea8e6993b99c137b683b46b.tar.gz
gentoo-56b9c37e01b51c02eea8e6993b99c137b683b46b.tar.bz2
gentoo-56b9c37e01b51c02eea8e6993b99c137b683b46b.zip
net-misc/streamlink-9999: make copyable to release versions
Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 7e262bddb1a8..976c7ea53a20 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -3,17 +3,25 @@
EAPI=6
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ GIT_ECLASS="git-r3"
+fi
+
PYTHON_COMPAT=( python{2_7,3_6} )
PYTHON_REQ_USE='xml(+),threads(+)'
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 git-r3
+inherit distutils-r1 $GIT_ECLASS
DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
HOMEPAGE="https://streamlink.github.io/"
-EGIT_REPO_URI="https://github.com/${PN}/${PN}"
-KEYWORDS=""
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
LICENSE="BSD-2 Apache-2.0"
SLOT="0"
IUSE="doc test"