summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/yaydl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/yaydl')
-rw-r--r--net-misc/yaydl/Manifest1
-rw-r--r--net-misc/yaydl/metadata.xml11
-rw-r--r--net-misc/yaydl/yaydl-1.5.2.ebuild47
3 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/yaydl/Manifest b/net-misc/yaydl/Manifest
new file mode 100644
index 000000000000..1737a3be20a8
--- /dev/null
+++ b/net-misc/yaydl/Manifest
@@ -0,0 +1 @@
+DIST yaydl-1.5.2.tar.gz 13933 SHA256 f2ee58aad1b6ab458fb3e9ff21f195af17dbfea4237642a998d89996b0449cc0
diff --git a/net-misc/yaydl/metadata.xml b/net-misc/yaydl/metadata.xml
new file mode 100644
index 000000000000..9db41b280b87
--- /dev/null
+++ b/net-misc/yaydl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="soundextract">Extract the soundtracks of the downloaded videos</flag>
+ </use>
+</pkgmetadata>
+
diff --git a/net-misc/yaydl/yaydl-1.5.2.ebuild b/net-misc/yaydl/yaydl-1.5.2.ebuild
new file mode 100644
index 000000000000..0b99a27632f3
--- /dev/null
+++ b/net-misc/yaydl/yaydl-1.5.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Yet Another Youtube DownLoader which is downloading more than youtube"
+HOMEPAGE="http://pdes-net.org/x-haui/"
+SRC_URI="http://pdes-net.org/x-haui/scripts/perl/yaydl_youtubedownloader/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="encode soundextract"
+
+DEPEND=""
+RDEPEND="
+ dev-lang/perl
+ dev-perl/LWP-UserAgent-Determined
+ dev-perl/MP3-Info
+ dev-perl/Term-ProgressBar
+ dev-perl/URI
+ encode? (
+ || (
+ virtual/ffmpeg[encode]
+ media-video/mplayer[encode,mp3,xvid]
+ )
+ )
+ soundextract? (
+ || (
+ virtual/ffmpeg[encode,mp3]
+ (
+ media-video/mplayer
+ media-sound/lame
+ )
+ )
+ )"
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ dodoc changelog README
+}
+
+pkg_postinst() {
+ elog "${PN} is supporting a lot of video websites."
+ elog "Look at ${HOMEPAGE} for more information."
+}