summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/vinagre
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/vinagre')
-rw-r--r--net-misc/vinagre/Manifest2
-rw-r--r--net-misc/vinagre/files/vinagre-3.14.3-freerdp.patch39
-rw-r--r--net-misc/vinagre/files/vinagre-3.14.3-freerdp2.patch35
-rw-r--r--net-misc/vinagre/files/vinagre-3.16.1-freerdp.patch38
-rw-r--r--net-misc/vinagre/metadata.xml13
-rw-r--r--net-misc/vinagre/vinagre-3.14.3-r1.ebuild74
-rw-r--r--net-misc/vinagre/vinagre-3.14.3.ebuild67
-rw-r--r--net-misc/vinagre/vinagre-3.16.1.ebuild73
8 files changed, 341 insertions, 0 deletions
diff --git a/net-misc/vinagre/Manifest b/net-misc/vinagre/Manifest
new file mode 100644
index 000000000000..dd3ab388e5ca
--- /dev/null
+++ b/net-misc/vinagre/Manifest
@@ -0,0 +1,2 @@
+DIST vinagre-3.14.3.tar.xz 1101544 SHA256 f82d8c66684a00a79422724b0e1efad28ba35ba21a92dc7dcb867ed7b64659f0 SHA512 80d87d3aab0e11c2990e6f8f369095e7587a3d2def0afe1e0be2cae31e376bc40c902180b92d84c196ded8c1973dca8421dd5d66ecda5d6d1e41e3fe0aa02ccd WHIRLPOOL 9a38f134b27e1064b186df2c53daacc268e719458fc13fab81a7013972966c107d30c9041082578c4fd0ca037b4285bf9df69ed0f2b900f77ec54fe633539c04
+DIST vinagre-3.16.1.tar.xz 812964 SHA256 d77c0057e8525efeef8b35839bce07e5451d99f3ef9d156c7f549a4c1ad6483f SHA512 60b83a7eb8f4d49e8825a4116d2de4579373cb4fbcde70c241b43f079debc30f0b5ce38da39ed4a3841724a70798338a7c319c72be0e991b97f70cdc264dfacf WHIRLPOOL 24828f91d545fd8da63f14002b1988a677c37ffc3abd10678467cfe5223ec4adbd4c9cec39e1ad7c4d46e2beb7369109445f7e1c19e5d10b7be6b79533c99a50
diff --git a/net-misc/vinagre/files/vinagre-3.14.3-freerdp.patch b/net-misc/vinagre/files/vinagre-3.14.3-freerdp.patch
new file mode 100644
index 000000000000..36cabca8a7ce
--- /dev/null
+++ b/net-misc/vinagre/files/vinagre-3.14.3-freerdp.patch
@@ -0,0 +1,39 @@
+From 2fd545b77c3a2c5f0bc1b0fc5f851857127cc2f3 Mon Sep 17 00:00:00 2001
+From: Jean-Philippe Menil <jpmenil@gmail.com>
+Date: Fri, 28 Nov 2014 17:08:16 +0000
+Subject: [PATCH] Fix RDP initialization with recent FreeRDP
+
+https://bugzilla.gnome.org/show_bug.cgi?id=740868
+---
+ plugins/rdp/vinagre-rdp-tab.c | 11 +++++++++--
+ 1 file changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/plugins/rdp/vinagre-rdp-tab.c b/plugins/rdp/vinagre-rdp-tab.c
+index 02f5e4e..770fe99 100644
+--- a/plugins/rdp/vinagre-rdp-tab.c
++++ b/plugins/rdp/vinagre-rdp-tab.c
+@@ -27,7 +27,6 @@
+ #include <freerdp/api.h>
+ #include <freerdp/types.h>
+ #include <freerdp/freerdp.h>
+-#include <freerdp/utils/event.h>
+ #include <freerdp/gdi/gdi.h>
+ #if HAVE_FREERDP_1_1
+ #include <freerdp/locale/keyboard.h>
+@@ -363,7 +362,15 @@ frdp_post_connect (freerdp *instance)
+ rdpGdi *gdi;
+ int stride;
+
+- gdi_init (instance, CLRBUF_24BPP, NULL);
++ gdi_init (instance,
++#if defined(FREERDP_VERSION_MAJOR) && defined(FREERDP_VERSION_MINOR) && \
++ !(FREERDP_VERSION_MAJOR > 1 || (FREERDP_VERSION_MAJOR == 1 && \
++ FREERDP_VERSION_MINOR >= 2))
++ CLRBUF_24BPP,
++#else
++ CLRBUF_32BPP,
++#endif
++ NULL);
+ gdi = instance->context->gdi;
+
+ instance->update->BeginPaint = frdp_begin_paint;
diff --git a/net-misc/vinagre/files/vinagre-3.14.3-freerdp2.patch b/net-misc/vinagre/files/vinagre-3.14.3-freerdp2.patch
new file mode 100644
index 000000000000..5620fcd9920e
--- /dev/null
+++ b/net-misc/vinagre/files/vinagre-3.14.3-freerdp2.patch
@@ -0,0 +1,35 @@
+From c819f3e06363faa3e0c1503d7bbcf3ac88c6dedd Mon Sep 17 00:00:00 2001
+From: Nick Andrade <SDNick484@gmail.com>
+Date: Sat, 16 May 2015 08:03:29 +0100
+Subject: Fix building against newer FreeRDP versions
+
+https://bugzilla.gnome.org/show_bug.cgi?id=749124
+
+diff --git a/plugins/rdp/vinagre-rdp-tab.c b/plugins/rdp/vinagre-rdp-tab.c
+index c4c11f8..690a580 100644
+--- a/plugins/rdp/vinagre-rdp-tab.c
++++ b/plugins/rdp/vinagre-rdp-tab.c
+@@ -887,7 +887,6 @@ open_freerdp (VinagreRdpTab *rdp_tab)
+ settings->RdpSecurity = TRUE;
+ settings->TlsSecurity = TRUE;
+ settings->NlaSecurity = TRUE;
+- settings->DisableEncryption = FALSE;
+ settings->EncryptionMethods = ENCRYPTION_METHOD_40BIT | ENCRYPTION_METHOD_128BIT | ENCRYPTION_METHOD_FIPS;
+ settings->EncryptionLevel = ENCRYPTION_LEVEL_CLIENT_COMPATIBLE;
+ #else
+@@ -898,6 +897,12 @@ open_freerdp (VinagreRdpTab *rdp_tab)
+ settings->encryption_method = ENCRYPTION_METHOD_40BIT | ENCRYPTION_METHOD_128BIT | ENCRYPTION_METHOD_FIPS;
+ settings->encryption_level = ENCRYPTION_LEVEL_CLIENT_COMPATIBLE;
+ #endif
++#include <freerdp/version.h>
++#if (FREERDP_VERSION_MAJOR == 1 && FREERDP_VERSION_MINOR >= 2 && FREERDP_VERSION_REVISION >= 1)
++ settings->UseRdpSecurityLayer = FALSE;
++#else
++ settings->DisableEncryption = FALSE;
++#endif
+
+ /* Set display size */
+ #if HAVE_FREERDP_1_1
+--
+cgit v0.10.2
+
diff --git a/net-misc/vinagre/files/vinagre-3.16.1-freerdp.patch b/net-misc/vinagre/files/vinagre-3.16.1-freerdp.patch
new file mode 100644
index 000000000000..dacce43a8e82
--- /dev/null
+++ b/net-misc/vinagre/files/vinagre-3.16.1-freerdp.patch
@@ -0,0 +1,38 @@
+From 89cc8bfeaf47a24c57616021915b30bbc4d12d53 Mon Sep 17 00:00:00 2001
+From: Nick Andrade <SDNick484@gmail.com>
+Date: Sat, 16 May 2015 08:03:29 +0100
+Subject: [PATCH] Fix building against newer FreeRDP versions
+
+https://bugzilla.gnome.org/show_bug.cgi?id=749124
+---
+ plugins/rdp/vinagre-rdp-tab.c | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/plugins/rdp/vinagre-rdp-tab.c b/plugins/rdp/vinagre-rdp-tab.c
+index c4c11f8..690a580 100644
+--- a/plugins/rdp/vinagre-rdp-tab.c
++++ b/plugins/rdp/vinagre-rdp-tab.c
+@@ -887,7 +887,6 @@ open_freerdp (VinagreRdpTab *rdp_tab)
+ settings->RdpSecurity = TRUE;
+ settings->TlsSecurity = TRUE;
+ settings->NlaSecurity = TRUE;
+- settings->DisableEncryption = FALSE;
+ settings->EncryptionMethods = ENCRYPTION_METHOD_40BIT | ENCRYPTION_METHOD_128BIT | ENCRYPTION_METHOD_FIPS;
+ settings->EncryptionLevel = ENCRYPTION_LEVEL_CLIENT_COMPATIBLE;
+ #else
+@@ -898,6 +897,12 @@ open_freerdp (VinagreRdpTab *rdp_tab)
+ settings->encryption_method = ENCRYPTION_METHOD_40BIT | ENCRYPTION_METHOD_128BIT | ENCRYPTION_METHOD_FIPS;
+ settings->encryption_level = ENCRYPTION_LEVEL_CLIENT_COMPATIBLE;
+ #endif
++#include <freerdp/version.h>
++#if (FREERDP_VERSION_MAJOR == 1 && FREERDP_VERSION_MINOR >= 2 && FREERDP_VERSION_REVISION >= 1)
++ settings->UseRdpSecurityLayer = FALSE;
++#else
++ settings->DisableEncryption = FALSE;
++#endif
+
+ /* Set display size */
+ #if HAVE_FREERDP_1_1
+--
+2.4.0
+
diff --git a/net-misc/vinagre/metadata.xml b/net-misc/vinagre/metadata.xml
new file mode 100644
index 000000000000..4708913096e3
--- /dev/null
+++ b/net-misc/vinagre/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="rdp">Enable access to Windows RDP protocol using
+ <pkg>net-misc/rdesktop</pkg></flag>
+ <flag name="ssh">Enable ssh plugin using <pkg>x11-libs/vte</pkg></flag>
+ <flag name="spice">Enable access to SPICE-enabled virtual machines</flag>
+ <flag name="telepathy">Enable access to remote desktop via a
+ <pkg>net-libs/telepathy-glib</pkg> client</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/vinagre/vinagre-3.14.3-r1.ebuild b/net-misc/vinagre/vinagre-3.14.3-r1.ebuild
new file mode 100644
index 000000000000..a6056927479f
--- /dev/null
+++ b/net-misc/vinagre/vinagre-3.14.3-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION=0.18
+
+inherit gnome2 linux-info vala
+
+DESCRIPTION="VNC client for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Vinagre"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ~ppc ~ppc64 x86"
+IUSE="rdp +ssh spice +telepathy zeroconf"
+
+# cairo used in vinagre-tab
+# gdk-pixbuf used all over the place
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.9.6:3
+ app-crypt/libsecret
+ >=dev-libs/libxml2-2.6.31:2
+ >=net-libs/gtk-vnc-0.4.3[gtk3]
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ x11-themes/hicolor-icon-theme
+
+ rdp? ( net-misc/freerdp )
+ ssh? ( >=x11-libs/vte-0.20:2.91 )
+ spice? (
+ app-emulation/spice-protocol
+ >=net-misc/spice-gtk-0.5[gtk3] )
+ telepathy? (
+ dev-libs/dbus-glib
+ >=net-libs/telepathy-glib-0.11.6 )
+ zeroconf? ( >=net-dns/avahi-0.6.26[dbus,gtk3] )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+pkg_pretend() {
+ # Needed for VNC ssh tunnel, bug #518574
+ CONFIG_CHECK="~IPV6"
+ check_extra_config
+}
+
+src_prepare() {
+ # Fix RDP initialization with recent FreeRDP (from 'master')
+ epatch "${FILESDIR}"/${PN}-3.14.3-freerdp.patch
+ epatch "${FILESDIR}"/${PN}-3.14.3-freerdp2.patch
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog ChangeLog.pre-git NEWS README"
+ gnome2_src_configure \
+ $(use_enable rdp) \
+ $(use_enable ssh) \
+ $(use_enable spice) \
+ $(use_with telepathy) \
+ $(use_with zeroconf avahi) \
+ ITSTOOL=$(type -P true)
+}
diff --git a/net-misc/vinagre/vinagre-3.14.3.ebuild b/net-misc/vinagre/vinagre-3.14.3.ebuild
new file mode 100644
index 000000000000..460496e10456
--- /dev/null
+++ b/net-misc/vinagre/vinagre-3.14.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION=0.18
+
+inherit gnome2 vala
+
+DESCRIPTION="VNC client for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Vinagre"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ~ppc ~ppc64 x86"
+IUSE="avahi rdp +ssh spice +telepathy"
+
+# cairo used in vinagre-tab
+# gdk-pixbuf used all over the place
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.9.6:3
+ app-crypt/libsecret
+ >=dev-libs/libxml2-2.6.31:2
+ >=net-libs/gtk-vnc-0.4.3[gtk3]
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ x11-themes/hicolor-icon-theme
+
+ avahi? ( >=net-dns/avahi-0.6.26[dbus,gtk3] )
+ rdp? ( net-misc/freerdp )
+ ssh? ( >=x11-libs/vte-0.20:2.91 )
+ spice? (
+ app-emulation/spice-protocol
+ >=net-misc/spice-gtk-0.5[gtk3] )
+ telepathy? (
+ dev-libs/dbus-glib
+ >=net-libs/telepathy-glib-0.11.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ # Fix RDP initialization with recent FreeRDP (from 'master')
+ epatch "${FILESDIR}"/${PN}-3.14.3-freerdp.patch
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog ChangeLog.pre-git NEWS README"
+ gnome2_src_configure \
+ $(use_with avahi) \
+ $(use_enable rdp) \
+ $(use_enable ssh) \
+ $(use_enable spice) \
+ $(use_with telepathy) \
+ ITSTOOL=$(type -P true)
+}
diff --git a/net-misc/vinagre/vinagre-3.16.1.ebuild b/net-misc/vinagre/vinagre-3.16.1.ebuild
new file mode 100644
index 000000000000..1b4ba2972808
--- /dev/null
+++ b/net-misc/vinagre/vinagre-3.16.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+
+inherit gnome2 linux-info vala
+
+DESCRIPTION="VNC client for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Vinagre"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="rdp +ssh spice +telepathy zeroconf"
+
+# cairo used in vinagre-tab
+# gdk-pixbuf used all over the place
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.9.6:3
+ app-crypt/libsecret
+ >=dev-libs/libxml2-2.6.31:2
+ >=net-libs/gtk-vnc-0.4.3[gtk3]
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ x11-themes/hicolor-icon-theme
+
+ rdp? ( net-misc/freerdp )
+ ssh? ( >=x11-libs/vte-0.20:2.91 )
+ spice? (
+ app-emulation/spice-protocol
+ >=net-misc/spice-gtk-0.5[gtk3] )
+ telepathy? (
+ dev-libs/dbus-glib
+ >=net-libs/telepathy-glib-0.11.6 )
+ zeroconf? ( >=net-dns/avahi-0.6.26[dbus,gtk3] )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+pkg_pretend() {
+ # Needed for VNC ssh tunnel, bug #518574
+ CONFIG_CHECK="~IPV6"
+ check_extra_config
+}
+
+src_prepare() {
+ # Fix RDP initialization with recent FreeRDP (from 'master')
+ epatch "${FILESDIR}"/${PN}-3.16.1-freerdp.patch
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog ChangeLog.pre-git NEWS README"
+ gnome2_src_configure \
+ $(use_enable rdp) \
+ $(use_enable ssh) \
+ $(use_enable spice) \
+ $(use_with telepathy) \
+ $(use_with zeroconf avahi) \
+ ITSTOOL=$(type -P true)
+}