summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-09-10 08:56:30 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-09-10 08:57:49 -0500
commitba313b756eb1d6903c621702778204aa515c7618 (patch)
tree2c6bcbe10027fa47ea983e1b85c3213b2cd536d5 /net-misc/spice-gtk
parentapp-emulation/spice: Call addpredict in appropriate function, bug #593388 (diff)
downloadgentoo-ba313b756eb1d6903c621702778204aa515c7618.tar.gz
gentoo-ba313b756eb1d6903c621702778204aa515c7618.tar.bz2
gentoo-ba313b756eb1d6903c621702778204aa515c7618.zip
net-misc/spice-gtk: Call addpredict in appropriate functions, bug #593388
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.31.ebuild19
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.32-r1.ebuild18
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild18
-rw-r--r--net-misc/spice-gtk/spice-gtk-9999.ebuild18
4 files changed, 57 insertions, 16 deletions
diff --git a/net-misc/spice-gtk/spice-gtk-0.31.ebuild b/net-misc/spice-gtk/spice-gtk-0.31.ebuild
index 3682e02a36a3..cfec48ec6624 100644
--- a/net-misc/spice-gtk/spice-gtk-0.31.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.31.ebuild
@@ -85,10 +85,6 @@ DEPEND="${RDEPEND}
# dev-lang/vala:0.14
# dev-lang/perl
-# Prevent sandbox violations, bug #581836
-# https://bugzilla.gnome.org/show_bug.cgi?id=581836
-addpredict /dev
-
src_prepare() {
epatch "${FILESDIR}"/${P}-x11-libs.patch
epatch_user
@@ -99,6 +95,11 @@ src_prepare() {
}
src_configure() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
local myconf
local audio="no"
@@ -148,10 +149,20 @@ src_configure() {
}
src_compile() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
multibuild_foreach_variant run_in_build_dir default
}
src_test() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
multibuild_foreach_variant run_in_build_dir default
}
diff --git a/net-misc/spice-gtk/spice-gtk-0.32-r1.ebuild b/net-misc/spice-gtk/spice-gtk-0.32-r1.ebuild
index 0fac3468ebeb..3c026b18a144 100644
--- a/net-misc/spice-gtk/spice-gtk-0.32-r1.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.32-r1.ebuild
@@ -75,10 +75,6 @@ DEPEND="${RDEPEND}
# dev-lang/vala:0.14
# dev-lang/perl
-# Prevent sandbox violations, bug #581836
-# https://bugzilla.gnome.org/show_bug.cgi?id=581836
-addpredict /dev
-
src_prepare() {
epatch "${FILESDIR}"/${P}-x11-libs.patch
epatch_user
@@ -89,6 +85,11 @@ src_prepare() {
}
src_configure() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
local myconf
if use vala ; then
@@ -121,6 +122,15 @@ src_configure() {
econf ${myconf}
}
+src_compile() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
+ default
+}
+
src_install() {
default
diff --git a/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild b/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
index ea87c5ac53e0..7477ddfe6cce 100644
--- a/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
@@ -79,10 +79,6 @@ DEPEND="${RDEPEND}
# dev-lang/vala:0.14
# dev-lang/perl
-# Prevent sandbox violations, bug #581836
-# https://bugzilla.gnome.org/show_bug.cgi?id=581836
-addpredict /dev
-
src_prepare() {
epatch "${FILESDIR}"/${P}-x11-libs.patch
epatch_user
@@ -93,6 +89,11 @@ src_prepare() {
}
src_configure() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
local myconf
if use vala ; then
@@ -125,6 +126,15 @@ src_configure() {
econf ${myconf}
}
+src_compile() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
+ default
+}
+
src_install() {
default
diff --git a/net-misc/spice-gtk/spice-gtk-9999.ebuild b/net-misc/spice-gtk/spice-gtk-9999.ebuild
index 0fd61c85ef37..177090972c7a 100644
--- a/net-misc/spice-gtk/spice-gtk-9999.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-9999.ebuild
@@ -78,10 +78,6 @@ DEPEND="${RDEPEND}
# dev-lang/vala:0.14
# dev-lang/perl
-# Prevent sandbox violations, bug #581836
-# https://bugzilla.gnome.org/show_bug.cgi?id=581836
-addpredict /dev
-
src_prepare() {
epatch_user
@@ -91,6 +87,11 @@ src_prepare() {
}
src_configure() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
local myconf
if use vala ; then
@@ -123,6 +124,15 @@ src_configure() {
econf ${myconf}
}
+src_compile() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
+ default
+}
+
src_install() {
default