summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/shmux
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/shmux')
-rw-r--r--net-misc/shmux/Manifest2
-rw-r--r--net-misc/shmux/files/shmux-1.0.2-tinfo.patch11
-rw-r--r--net-misc/shmux/metadata.xml17
-rw-r--r--net-misc/shmux/shmux-1.0.2.ebuild38
-rw-r--r--net-misc/shmux/shmux-1.0.ebuild31
5 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/shmux/Manifest b/net-misc/shmux/Manifest
new file mode 100644
index 000000000000..0bf4c3ea4074
--- /dev/null
+++ b/net-misc/shmux/Manifest
@@ -0,0 +1,2 @@
+DIST shmux-1.0.2.tgz 110473 SHA256 0886aaca4936926d526988d85df403fa1679a60c355f1be8432bb4bc1e36580f SHA512 d114678827d4fc203f0d18b4a4e02f8b56efdf490df0aef32756a020c755b387468a88fea7266249445a862d7ed9374640432e5807fa57bca5a7d559d7e67a8a WHIRLPOOL 1159c35470e131c4001bde349bc0f31bd533e787ab9d5c6f50904139e80696cba5b32ab02cc5486ea7f10c71495f3e9ee55175fc6384c3c5c919cc6526bd6f1b
+DIST shmux-1.0.tgz 81096 SHA256 d97b2d7f01b32a4a92a87df4320249228da55d9ff0ae8c0e6319c131a0404782
diff --git a/net-misc/shmux/files/shmux-1.0.2-tinfo.patch b/net-misc/shmux/files/shmux-1.0.2-tinfo.patch
new file mode 100644
index 000000000000..802d5973bdc7
--- /dev/null
+++ b/net-misc/shmux/files/shmux-1.0.2-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -27,7 +27,7 @@
+ fi
+
+ # Checks for libraries.
+-AC_SEARCH_LIBS([tgetent], [termcap curses ncurses])
++AC_SEARCH_LIBS([tgetent], [termcap tinfo curses ncurses])
+ AC_SEARCH_LIBS([basename], [gen])
+ if test "x$with_pcre" != "xno"; then
+ AC_SEARCH_LIBS([pcre_compile], [pcre], ,
diff --git a/net-misc/shmux/metadata.xml b/net-misc/shmux/metadata.xml
new file mode 100644
index 000000000000..c514a998b805
--- /dev/null
+++ b/net-misc/shmux/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>alicef@gentoo.org</email>
+ <name>Alice Ferrazzi</name>
+</maintainer>
+<longdescription>
+shmux is program for executing the same command on many hosts in parallel.
+For each target, a child process is spawned by shmux, and a shell on the
+target obtained one of the supported methods: rsh, ssh, or sh. The output
+produced by the children is received by shmux and either (optionally)
+output in turn to the user, and/or written to files for later processing.
+The list of targets may either be specified on the command line or be read
+from the standard input.
+</longdescription>
+</pkgmetadata>
diff --git a/net-misc/shmux/shmux-1.0.2.ebuild b/net-misc/shmux/shmux-1.0.2.ebuild
new file mode 100644
index 000000000000..fe9bbf44014f
--- /dev/null
+++ b/net-misc/shmux/shmux-1.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit autotools eutils
+
+DESCRIPTION="Program for executing the same command on many hosts in parallel"
+HOMEPAGE="http://web.taranis.org/shmux/"
+SRC_URI="http://web.taranis.org/${PN}/dist/${P}.tgz"
+
+LICENSE="shmux"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="pcre"
+RESTRICT="test"
+
+RDEPEND="
+ pcre? ( dev-libs/libpcre )
+ sys-libs/ncurses
+"
+DEPEND="${RDEPEND}
+ virtual/awk"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with pcre)
+}
+
+src_install() {
+ dobin src/shmux
+ doman shmux.1
+ dodoc CHANGES
+}
diff --git a/net-misc/shmux/shmux-1.0.ebuild b/net-misc/shmux/shmux-1.0.ebuild
new file mode 100644
index 000000000000..6e68100e59a8
--- /dev/null
+++ b/net-misc/shmux/shmux-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Program for executing the same command on many hosts in parallel"
+HOMEPAGE="http://web.taranis.org/shmux/"
+SRC_URI="http://web.taranis.org/${PN}/dist/${P}.tgz"
+
+LICENSE="shmux"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="pcre"
+RESTRICT="test"
+
+RDEPEND="
+ pcre? ( dev-libs/libpcre )
+ sys-libs/ncurses
+"
+DEPEND="${RDEPEND}
+ virtual/awk"
+
+src_compile() {
+ econf $(use_with pcre) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin src/shmux || die "dobin failed"
+ doman shmux.1 || die "doman failed"
+ dodoc CHANGES || die "dodoc failed"
+}