summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2024-06-22 18:52:19 -0700
committerJason Zaman <perfinion@gentoo.org>2024-06-22 19:50:55 -0700
commit1733a83306a214ba568c639ece1852ee9adb9e18 (patch)
treefe7a3503f71219f0fd8a7f0c14318ffceee731db /net-misc/ser2net
parentnet-misc/ser2net: Fix pkgcheck issues in 2.10 (diff)
downloadgentoo-1733a83306a214ba568c639ece1852ee9adb9e18.tar.gz
gentoo-1733a83306a214ba568c639ece1852ee9adb9e18.tar.bz2
gentoo-1733a83306a214ba568c639ece1852ee9adb9e18.zip
net-misc/ser2net: add 4.6.2
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'net-misc/ser2net')
-rw-r--r--net-misc/ser2net/Manifest1
-rw-r--r--net-misc/ser2net/files/ser2net.confd-r221
-rw-r--r--net-misc/ser2net/files/ser2net.initd-r237
-rw-r--r--net-misc/ser2net/ser2net-4.6.2.ebuild37
4 files changed, 96 insertions, 0 deletions
diff --git a/net-misc/ser2net/Manifest b/net-misc/ser2net/Manifest
index 1e582c5cffa9..8856e9cc1668 100644
--- a/net-misc/ser2net/Manifest
+++ b/net-misc/ser2net/Manifest
@@ -1 +1,2 @@
DIST ser2net-2.10.0.tar.gz 364322 BLAKE2B db041297069ea0a111ed73d6b1fc8a639971f113952fbcd499a81671bbd873ee3e1724146bfb5c6975d1812acd8e545e9df2bde445f4a86af57a0ae5b9b19ec1 SHA512 dd3e37619b10d8bf20d738e90c253bc2d109e0a57ee9f3a8b2a85a69399afa5a8459a4602b2856f0b655427023a36c78330851bf7f8d8da0f28d1fe22c1d5e10
+DIST ser2net-4.6.2.tar.gz 474345 BLAKE2B b495628f7aeda3804c43e59f76a54bfb872551011ccf338a81dc4ed92fa89b36a7356f45b5d4d6804969505eb90b117a348c7a2f78e08a4ed08c730c58df2e40 SHA512 3bd7ceb743f1503c055e0c206cfd2b987fee8ba532683a8470c7c078134b68d115809ef94c38fe926ff29363930e014d9cc9a44cc32a8ed93559e193a13204f8
diff --git a/net-misc/ser2net/files/ser2net.confd-r2 b/net-misc/ser2net/files/ser2net.confd-r2
new file mode 100644
index 000000000000..a443ce752a75
--- /dev/null
+++ b/net-misc/ser2net/files/ser2net.confd-r2
@@ -0,0 +1,21 @@
+# Config file for /etc/init.d/ser2net
+
+# Set the configuration file to one other than the default of /etc/ser2net/ser2net.yaml
+#
+#CONFIG_FILE="/etc/ser2net/ser2net.yaml"
+
+# Enables the control port and sets the TCP port to listen to for the control port.
+# A port number may be of the form [host,]port, such as 127.0.0.1,2000 or localhost,2000.
+# If this is specified, it will only bind to the IP address specified for the port.
+# Otherwise, it will bind to all the addresses on the machine.
+#
+#CONTROL_PORT=""
+
+# Enable or disable UUCP locking (default=yes)
+#
+#UUCP_LOCKS="no"
+
+# see the ser2net(8) manual page for additional options you can configure here
+#
+#EXTRA_OPTS=""
+
diff --git a/net-misc/ser2net/files/ser2net.initd-r2 b/net-misc/ser2net/files/ser2net.initd-r2
new file mode 100644
index 000000000000..0321e8a9bbb6
--- /dev/null
+++ b/net-misc/ser2net/files/ser2net.initd-r2
@@ -0,0 +1,37 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Serial to network proxy (${RC_SVCNAME#*.})"
+pidfile="/var/run/${RC_SVCNAME}.pid"
+command="/usr/sbin/ser2net"
+name="${description}"
+
+extra_started_commands="reload"
+description_reload="Reread configuration file and make the appropriate changes"
+start_stop_daemon_args="--quiet"
+command_args_background="-P ${pidfile}"
+command_args_foreground="-n"
+
+depend() {
+ use logger
+ need net
+}
+
+start_pre() {
+ command_args="${EXTRA_OPTS}"
+ CONFIG_FILE_DEFAULT="/etc/ser2net/ser2net.yaml"
+
+ yesno "${UUCP_LOCKS:-yes}" || command_args="${command_args} -u"
+ [ -n "${CONTROL_PORT}" ] && command_args="${command_args} -p ${CONTROL_PORT}"
+ [ -z "${CONFIG_FILE}" ] && CONFIG_FILE="${CONFIG_FILE_DEFAULT}"
+ [ "${CONFIG_FILE}" != "${CONFIG_FILE_DEFAULT}" ] && command_args="${command_args} -c ${CONFIG_FILE}"
+
+ return 0
+}
+
+reload() {
+ ebegin "Reloading ${description}"
+ start-stop-daemon --signal HUP --pidfile "${pidfile}"
+ eend ${?}
+}
diff --git a/net-misc/ser2net/ser2net-4.6.2.ebuild b/net-misc/ser2net/ser2net-4.6.2.ebuild
new file mode 100644
index 000000000000..3fd27c27be52
--- /dev/null
+++ b/net-misc/ser2net/ser2net-4.6.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Serial To Network Proxy"
+HOMEPAGE="https://sourceforge.net/projects/ser2net"
+SRC_URI="https://downloads.sourceforge.net/ser2net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam"
+
+DEPEND="
+ dev-libs/libyaml:=
+ net-misc/gensio
+ pam? ( sys-libs/pam )
+"
+RDEPEND="${DEPEND}"
+
+# Test suite requires a kernel module
+RESTRICT="test"
+
+src_configure() {
+ econf --without-sysfs-led-support $(use_with pam)
+}
+
+src_install() {
+ default
+
+ insinto /etc/${PN}
+ doins ${PN}.yaml
+
+ newinitd "${FILESDIR}/${PN}.initd-r2" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd-r2" ${PN}
+}