summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/rygel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/rygel')
-rw-r--r--net-misc/rygel/Manifest2
-rw-r--r--net-misc/rygel/metadata.xml9
-rw-r--r--net-misc/rygel/rygel-0.24.4.ebuild91
-rw-r--r--net-misc/rygel/rygel-0.26.1.ebuild81
4 files changed, 183 insertions, 0 deletions
diff --git a/net-misc/rygel/Manifest b/net-misc/rygel/Manifest
new file mode 100644
index 000000000000..f5738e45bdc4
--- /dev/null
+++ b/net-misc/rygel/Manifest
@@ -0,0 +1,2 @@
+DIST rygel-0.24.4.tar.xz 3198880 SHA256 de7872ccb66aebd397dc664ad617a278e6c9eb3d6f6e706ddacfbbce89434d4c SHA512 f44de9afed85f26bc9d54976ecbc3aca6cc246bba9c86be9302df499fce4850a394c786d15e862ed6dab8a6a2e6ddb4c65ea6e970beb508172f2385fb39d511b WHIRLPOOL aacf3e995820cb57d688167b33e8eeea0d2c61d839e29f0a47975269139fd6414af2668bb351d28aabeea83d254b352a9c477a839984c5b1d02bf29036939593
+DIST rygel-0.26.1.tar.xz 2191348 SHA256 390740609e34399b886ddb9a8f7eca25055ad72048dfdd869edf02999b1e1d8f SHA512 3b0c168a9c974a8900a1e8ab9de764e24ed1b8b11df8f24ee0522ccd85cffce6477b36e4d83a7e278f7e9198865d800c35673ed0819e800bc406279a59d16fc8 WHIRLPOOL 54416b603a8a72695cfe59fd559006a12878ab0c51d6e21e3867b5fd36be6b2d33c144275ea9f05e3cfa822e0023fbc28dd9b0e1ae62f2e880718ca5e5235805
diff --git a/net-misc/rygel/metadata.xml b/net-misc/rygel/metadata.xml
new file mode 100644
index 000000000000..49d68040ba4c
--- /dev/null
+++ b/net-misc/rygel/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="tracker">Install dependencies for the tracker plugin</flag>
+ <flag name="transcode">Install dependencies for transcoding support</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/rygel/rygel-0.24.4.ebuild b/net-misc/rygel/rygel-0.24.4.ebuild
new file mode 100644
index 000000000000..82f05ffb669f
--- /dev/null
+++ b/net-misc/rygel/rygel-0.24.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="Rygel is an open source UPnP/DLNA MediaServer"
+HOMEPAGE="https://wiki.gnome.org/Projects/Rygel"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="X +introspection +sqlite tracker test transcode"
+
+# The deps for tracker? and transcode? are just the earliest available
+# version at the time of writing this ebuild
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libgee-0.8:0.8
+ >=dev-libs/libxml2-2.7:2
+ >=media-libs/gupnp-dlna-0.9.4:2.0
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-libs/libmediaart-0.5:1.0
+ media-plugins/gst-plugins-soup:1.0
+ >=net-libs/gssdp-0.13
+ >=net-libs/gupnp-0.19
+ >=net-libs/gupnp-av-0.12.4
+ >=net-libs/libsoup-2.44:2.4
+ >=sys-apps/util-linux-2.20
+ x11-misc/shared-mime-info
+ introspection? ( >=dev-libs/gobject-introspection-1.33.4:= )
+ sqlite? (
+ >=dev-db/sqlite-3.5:3
+ dev-libs/libunistring
+ )
+ tracker? ( >=app-misc/tracker-0.16:= )
+ transcode? (
+ media-libs/gst-plugins-bad:1.0
+ media-plugins/gst-plugins-twolame:1.0
+ media-plugins/gst-plugins-libav:1.0
+ )
+ X? ( >=x11-libs/gtk+-3:3 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# Maintainer only
+# >=dev-lang/vala-0.22
+# dev-libs/libxslt
+
+src_prepare() {
+ # runs gst-plugins-scanner on run with triggers sandbox violation
+ # trying to open dri
+ sed -e 's/rygel-media-engine-test$(EXEEXT)//' \
+ -e 's/rygel-playbin-renderer-test$(EXEEXT)//' \
+ -i tests/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # We defined xsltproc because man pages are provided by upstream
+ # and we do not want to regenerate them automagically.
+ gnome2_src_configure \
+ XSLTPROC=$(type -P false) \
+ --enable-gst-launch-plugin \
+ --enable-mediathek-plugin \
+ --with-media-engine=gstreamer \
+ --enable-nls \
+ $(use_enable introspection) \
+ $(use_enable sqlite media-export-plugin) \
+ $(use_enable test tests) \
+ $(use_enable tracker tracker-plugin) \
+ $(use_with X ui)
+}
+
+src_install() {
+ gnome2_src_install
+ # Autostart file is not placed correctly, bug #402745
+ insinto /etc/xdg/autostart
+ doins "${D}"/usr/share/applications/rygel.desktop
+ rm "${D}"/usr/share/applications/rygel.desktop
+}
diff --git a/net-misc/rygel/rygel-0.26.1.ebuild b/net-misc/rygel/rygel-0.26.1.ebuild
new file mode 100644
index 000000000000..9ec428c5da96
--- /dev/null
+++ b/net-misc/rygel/rygel-0.26.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="Rygel is an open source UPnP/DLNA MediaServer"
+HOMEPAGE="https://wiki.gnome.org/Projects/Rygel"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X +introspection +sqlite tracker test transcode"
+
+# The deps for tracker? and transcode? are just the earliest available
+# version at the time of writing this ebuild
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libgee-0.8:0.8
+ >=dev-libs/libxml2-2.7:2
+ >=media-libs/gupnp-dlna-0.9.4:2.0
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-libs/libmediaart-0.7:2.0
+ media-plugins/gst-plugins-soup:1.0
+ >=net-libs/gssdp-0.13
+ >=net-libs/gupnp-0.19
+ >=net-libs/gupnp-av-0.12.4
+ >=net-libs/libsoup-2.44:2.4
+ >=sys-apps/util-linux-2.20
+ x11-misc/shared-mime-info
+ introspection? ( >=dev-libs/gobject-introspection-1.33.4 )
+ sqlite? (
+ >=dev-db/sqlite-3.5:3
+ dev-libs/libunistring:=
+ )
+ tracker? ( >=app-misc/tracker-0.16:= )
+ transcode? (
+ media-libs/gst-plugins-bad:1.0
+ media-plugins/gst-plugins-twolame:1.0
+ media-plugins/gst-plugins-libav:1.0
+ )
+ X? ( >=x11-libs/gtk+-3:3 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# Maintainer only
+# >=dev-lang/vala-0.22
+# dev-libs/libxslt
+
+src_configure() {
+ # We defined xsltproc because man pages are provided by upstream
+ # and we do not want to regenerate them automagically.
+ gnome2_src_configure \
+ XSLTPROC=$(type -P false) \
+ --enable-gst-launch-plugin \
+ --enable-mediathek-plugin \
+ --with-media-engine=gstreamer \
+ --enable-nls \
+ $(use_enable introspection) \
+ $(use_enable sqlite media-export-plugin) \
+ $(use_enable test tests) \
+ $(use_enable tracker tracker-plugin) \
+ $(use_with X ui)
+}
+
+src_install() {
+ gnome2_src_install
+ # Autostart file is not placed correctly, bug #402745
+ insinto /etc/xdg/autostart
+ doins "${D}"/usr/share/applications/rygel.desktop
+ rm "${D}"/usr/share/applications/rygel.desktop
+}