summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-09-28 01:09:14 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-09-28 01:09:33 -0500
commit67fa3286ef91043177c182c964e4a6e6ec85a96c (patch)
treeea46b350fc91b6331228717a8c20a60fb6bbd0d1 /net-misc/pulseaudio-dlna
parentdev-ruby/haml: cleanup (diff)
downloadgentoo-67fa3286ef91043177c182c964e4a6e6ec85a96c.tar.gz
gentoo-67fa3286ef91043177c182c964e4a6e6ec85a96c.tar.bz2
gentoo-67fa3286ef91043177c182c964e4a6e6ec85a96c.zip
net-misc/pulseaudio-dlna: allow newer ffmpeg use
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-misc/pulseaudio-dlna')
-rw-r--r--net-misc/pulseaudio-dlna/pulseaudio-dlna-0.5.2-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/pulseaudio-dlna/pulseaudio-dlna-0.5.2-r1.ebuild b/net-misc/pulseaudio-dlna/pulseaudio-dlna-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..6714dd0bdc2d
--- /dev/null
+++ b/net-misc/pulseaudio-dlna/pulseaudio-dlna-0.5.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight DLNA/UPNP/Chromecast streaming server for PulseAudio"
+HOMEPAGE="https://github.com/masmu/pulseaudio-dlna"
+SRC_URI="https://github.com/masmu/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/protobuf-python-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/futures-2.1.6[${PYTHON_USEDEP}]
+ dev-python/librsvg-python[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.8[${PYTHON_USEDEP}]
+ >=dev-python/notify2-0.3[${PYTHON_USEDEP}]
+ >=dev-python/psutil-1.2.1[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/setproctitle-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.17[${PYTHON_USEDEP}]
+ || (
+ || ( media-video/ffmpeg[encode,faac,mp3,opus,vorbis]
+ media-video/ffmpeg[encode,fdk,mp3,opus,vorbis] )
+ ( media-video/libav[encode,faac,mp3,opus,vorbis] )
+ ( media-libs/faac
+ media-libs/flac
+ media-sound/lame
+ media-sound/opus-tools
+ media-sound/sox
+ media-sound/vorbis-tools )
+ )
+ virtual/python-futures[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ media-sound/pulseaudio"
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}/${PN}.desktop"
+}