summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2021-04-10 18:08:33 -0700
committerSteve Arnold <nerdboy@gentoo.org>2021-04-10 18:08:33 -0700
commit57a79f77b3ba9751622666956c52a558ec72de51 (patch)
treef747ca0e173eafeb6eb0ee72b2df1c0408595611 /net-misc/ntpsec
parentdev-util/cargo-license: bump to v0.4.1 (diff)
downloadgentoo-57a79f77b3ba9751622666956c52a558ec72de51.tar.gz
gentoo-57a79f77b3ba9751622666956c52a558ec72de51.tar.bz2
gentoo-57a79f77b3ba9751622666956c52a558ec72de51.zip
net-misc/ntpsec: switch to distutils-r1, fix shebangs
Should also fix bug 779880 Closes: https://bugs.gentoo.org/778011 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'net-misc/ntpsec')
-rw-r--r--net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild (renamed from net-misc/ntpsec/ntpsec-1.2.0.ebuild)7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-misc/ntpsec/ntpsec-1.2.0.ebuild b/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild
index a5193f995902..640727916e0f 100644
--- a/net-misc/ntpsec/ntpsec-1.2.0.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild
@@ -3,10 +3,11 @@
EAPI=6
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE='threads(+)'
+DISTUTILS_USE_SETUPTOOLS=no
-inherit flag-o-matic python-r1 waf-utils systemd
+inherit distutils-r1 flag-o-matic waf-utils systemd
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -72,6 +73,7 @@ src_prepare() {
fi
# remove extra default pool servers
sed -i '/use-pool/s/^/#/' "${S}"/etc/ntp.d/default.conf
+
python_copy_sources
}
@@ -122,6 +124,7 @@ src_compile() {
src_install() {
python_install() {
waf-utils_src_install
+ python_fix_shebang "${ED}"
}
python_foreach_impl run_in_build_dir python_install
python_foreach_impl python_optimize